Foscam : callback is not a function

Hi community,

I bought 3 New camera Foscam but when I want to Connect them to homey I have thé error message « callback is not a function ».

I need to introduce a camera user name and a password …

Do you have a solution to solve it ?

Thanks !

Judging from the reviews on the app page, this issue has existed for a while and apparently doesn’t get solved. You should contact the app developer:

Hi Cedric,

I also bought a Foscam camera. The “callback is not a function” means you are using the wrong UN/PW.
What worked for me was the following:

  • You first need to create a UN/PW for your Foscam account
  • Next you create in the foscam Android app after having selected the camera a un/pw admin123/admin123.
  • Next install Foscam VMS (download from Foscam website) on Windows
  • Search in the camera for the user admin123
  • Create for the camera in VMS a un/pw admin456/admin456 with administrator rights
  • Go to Homey, select the camera, for un/pw use the admin456/admin456
  • Please be aware of automatically added spaces or capitals!