Fibaro Update, Walli broken

Latest Fibaro app just broke my 2 walli that worked like a charm before.

Now can manually configure, device, change color with flow but unable to open/close with interface nor flow. Only way is with physical button. Every other tries fire an error:

I’m the only one with this issue?

My Walli Roller Shutter (firmware 5.1), configured as sun shade, works flawless with the Fibaro app version 3.1.1 and Homey firmware v.7.1.2-rc.3.
Probably only a new inclusion of the roller shutter will solve the problem.

Maybe @Edwin_D can explain what “Missing Capability Listener” means exactly?

This is of course possible, because it has nothing to do with Homey and Z-Wave. For this normal manual operation, no SmartHome is needed.

Missing capability listener sounds like an app bug - it means the is no code to translate the slider position changes into actions with the device. I do not have a Walli shutter device: is is normally supposed to have up/stop/down controls or does it know the end positions of the shutter and can it operate with a slider?

Also, it seems to have multiple slider controls, there is an arrow down next to the slider title. Can you pick the other and see if that works? Maybe the new app changed the name of the slider capability and the old slider is still there from a previous version.

Anyway, if removing the device and pairing again does not help it would be time to contact the app developer.

1 Like

Thx for your reply!

The end positions are determined by a one-time calibration in the beginning. The positioning of the shutter can only done by a slider or percentage values in flows.
The other slider control that can be selected instead of “Position” is the slat position for venetian blinds (windowcoverings_tilt_set).

Charles did not give any information about the version of the app and Homey firmware, but I assume that at least the app version is the same, as the Fibaro app was updated to version 3.1.1 yesterday.
So why does it work for me but not for Charles?

It’s a bit like our last discussion about the including process with a Fibaro Walli Switch… :wink:

Have you tried to restart the fibaro app?

A missing capability listener can also happen when it isn’t registered properly during boot, seen it happen once myself, and a few times to other people.

Yeah, remove and add device was in my todo but I got so much flows associated (control RGB ring depending on events on each walli) that I would avoid this one (I tried restarting app, and of course also Homey without success)

My Walli are V5.1 and Homey V7.2 but what is strange from the start is that these modules differs than other Fibaro roller shutter. Classic one has

And Walli I do not have the up/down screen


Did I done a bad config ?

Same issue as Charles for me on my Walli Roller Shutter since update to 3.1.1, but only 3 out of my 11 shutters have this problem…quite strange (Homey 7.2.0)

It’s not strange, because the different Fibaro Roller Shutter have different flow cards as you can see in the app store.
The only thing what is strange is, that Athom handled they differently. Of course, it may also have something to do with the general functions of the roller shutters.

Fibaro Roller Shutter

Fibaro Roller Shutter 2 (FW <2.4)

Fibaro Roller Shutter 2

Fibaro Roller Shutter 3

Fibaro Walli Roller Shutter

Correct, Athom changed what capabilities are allowed to be used for certain devices.

Now they have this rule: “if a device can use a slider, the developer should only implement the slider, and not the ternary buttons too”
This changed between the roller shutter 2 and roller shutter 3, so the roller shutter 3 also only has a slider, the walli is later then the roller shutter 3.

PS: you can click the icons of open and close (over and under the slider) to have a similar feeling as the up and down buttons of the ternary.

you can click the icons of open and close (over and under the slider) to have a similar feeling as the up and down buttons

Good to know thanks, can we stop then any time after, I mean, close it, then in the middle of the process stop it? To be honest even with calibration on my side slider is not same representation of shutter I mean set slider in the middle does not set my shutter midway.

@Maxime_Cieux all your walli have same version of firmware?

Yes they have, and I disagree. When you can do a specific percentage that is great. But what you miss is a way to stop a moving blind. Also, the ternary controls allow for way better control using button remotes, also because the ternary buttons allow to stop the motion with up/down button. Using positions would just send the shutter in the opposite direction. That is why I disregarded the rule with Motion Blinds (and I got away with it). It is hard to get right though.

Btw, Athom didn’t follow their own rules at the RS2.

Yes they all have the same version