Fibaro single switch 2, can`t connect


Im trying to connect fibaro single switch 2 to the homey app. It says you have to push the button on the fibaro device 3 times, and then it should be connected. But Im only get a message saying it cannot find a unit. Am i doing something wrong?

Best regards.

You did install the Fibaro App, I presume?
Goto Devices and start to ADD a device, choose general z-wave device, or point to the wanted Fibaro device, when you get the instructions, then press 3 times on the button, the device must be close to the Homey ( < 1 m ).

I thought I only had to have the Homey app? I have IOS wich fibaro app do I need then? When you say is has to be close to the homey, should I plug the homey in and out all around the house to get close to all the devices when setting up for the first time?

Hey @Jarle_Tjessem welcome!

Sometimes the terminology we use here is a little well …stupid.

Your Homey actually has its ‘own apps’ which need to be installed upon it in order to add new devices.

Don’t worry its nice and simple, in this case as you are installing a fibaro device, you will need to install the fibaro app onto your homey.

Just head to - login and click the install button. Then when you click add button + you will have the option into pick the 'Fibaro" brand.

You will only need to install the Fibaro homey app once, and all fibaro devices are now supported. For other devices make sure you check out the ‘App store’.

Thanks and welcome

Click here for the support article.


Thanks! I have already installed that, and when I go to “Homey” (app) -> Devices -> + -> Fibaro -> Single Switch 2 -> Install -> pushing the button on fibaro 3 times - > No Z-wave device has been found

Have tried this over and over again.

But do I need to take the homey device around the house to set up each and every device?

Some people find it easier to do that.

Before you go to that effort though, please try ‘Pressing the S2 button 5 times’. That is how many times I have to press the Dual switch 2, even though it says 3 times.


When you say S2 button, you mean the 1and only button there is? I have push it 3, 5, 10, times. I have tried to connect the homey 50cm frome the device. I have push the manual switch on the wall on and off. I have tried to hold the button on the fibaro for a while, then it start to light a light green/white/blue colured light, and if you hold it in longer it turns to green. And tried the same procedure.

It looks like your switch is on a ramification box (very common that in Europe @jamie and not existing in Australia and NZ) and not behind a switch so you have neither S1 nor S2 connected to a physical switch.

Can you please try the following?

  1. Go here: and login with your account.

  2. Scroll down and click on “Remove any Node”

    Now push the button B three times fast! If successful, then you will get a message in the left bottom corner in a green box, I think something like “An unknown node was removed” The message should come quite fast, if no message then try triple click again. If you get an error message (same location but in a red box) then try again.

  3. Once the above is successful, go back into the mobile app and add your device. My preference is that after I press the + button and get asked to “Pick up a brand” I select Homey then z-wave then when prompted “Please put your z-wave device in leaning mode” I triple click (fast) the button B. Of course, you must have the Fibaro app installed as Jamie mentioned above for this last step to work. Nothing wrong instead of selecting Homey to select the Fibaro app and the single switch 2. I just believe that no room for mistake with my method.

Good luck and hope you are successful :grinning:


Thannk you for reply @danone and sorry for late reply, I have been bussy lately. But I tried now following your step. Clicked on “remove any node” then pushing the button fast three times, tried pushing it more times. But only get this message in left corner in a red box “the network request failed”

What is wrong, and what can I do?

I had the “good luck” message for a reason…
Long story short, last month all my Fibaro devices (some 45) were gone. I had to exclude them and then re-include them one by one.
All went fairly well, with the exception of the double switches. I had to insist and try several times to exclude them. One particular gave me so much grieve that I almost chuck it in the bin. I then unplug Homey and also left the switch un-powered and went out the house for a couple of hours. When back I gave it one last chance and it worked.
Not sure if the fact that Homey was unplugged for so long or just because I was lucky, but it worked.

Sorry I cannot help you more.
I would unplug Homey for a couple of hours as well as the switch, then try again the remove process. I also suggest that after you plug back Homey leave it on for some 10 minutes at least before you attempt the above process.

It’s also good to know that if you have tried to include a device and it failed, you need to exclude it successfully before trying again.

You can do it as said above. Or you can go into settings -> zwave in the homey app and choose Remove a zwave device and then click three times on the device. You should get a successful message if it needed exclusion.

Then you can add it again the way you tried before. The inclusion process does not work 100% of the time. You may need to repeat this process more than once.

Thank you both for tip, I will try this later and post a update :slight_smile:

Hi again,

sorry for the late update, been busy renovating the house so the homey has not been my top priority. But I have tried so many times now that I`m starting to give up…still not working. have taking the power out both homey and fibaro switch. And tried to reset the z-wave network. Nothing working.

When you hold the button on the fibaro for a few second. There is a blu light blinking and if you hold one more there is a green light. What are those?

Did you end up excluding it?

The lights and what they mean can be found in the user manual on the fibaro site.

No nothing works.

Ok, thank you.

Controlling the Switch 2 using the B-button:
The Switch 2 is equipped with a B-button, which allows to use the
menu and perform the following actions:
1x click:
• Cancel alarm mode (flashing alarm).
• Select desired menu position (if menu is active).
• Exit range test.
• Turn 1st channel ON/OFF.
3x click:
• Send the Node Info Z-Wave command frame (adding/removing).
• Enter the menu (confirmed by the LED indicator).

Menu allows to perform Z-Wave network actions. In order to use the

  1. Switch off the mains voltage (disable the fuse).
  2. Remove the Switch 2 from the wall switch box.
  3. Switch on the mains voltage.
  4. Press and hold the B-button to enter the menu.
  5. Wait for the LED to indicate the desired menu position with colour:
    • GREEN - reset energy consumption memory
    • VIOLET - start range test
    • YELLOW - reset the device
  6. Quickly release and click the B-button again.

Thanks After days of research i finally solved the problem

What is the solution???