Fibaro Rgbw problem on 2.2.2

My Fibaro app updated automatically to 2.2.2 today and all flows I use to turn on a specific color won’t work. I can control the devices like a device but not through flows. Any one else who might have this problem?

Yes, all my flows containing a card related with the Fibaro RGBW are now broken after the 2.2.2 update. Replaced the card and indeed, I cannot turn on any specific colour.
Moreover, from the device itself I can choose any colour but the White channel stays always ON.
They are so incapable to fix this Fibaro RGBW which has been buggy since Homey 2.0

I have submitted a support request, I suggest you do the same @Tb1 maybe Athom would take notice.

1 Like

I have experienced the same problem. I guess we have to wait (hope) for an update.

Open a support ticket else you can wait for a long time.

1 Like

I’m typing a ticket right now :slight_smile:

1 Like

I have figured out a solution to the problem. Don’t set the color to 100% in the flow, If you set it to 99% it will work.

Thank you! 99% works here too.

Thats not a fix.
I also made a ticket bcs its been like this for over a year but with latest update not only warm white is broken… the rest as well.
White led stays on, al temp related white is ice blue white, orange is warm white, green some kinda teal, red more orange.
Really anoying and bcs of this takin so long offcourse also warranty allready expired.

It works if you only have an RGB light strip without W (white channel). With an RGBW the white channel is always ON. Yes, the RGB colours work correct as long as 99% or lower dim level. But with the white always ON, nothing looks good.

That’s the reason why I can’t choose a nice warm light color ? I tried for 30 minutes to find the white color but it looks like it’s not a option…

just seen a fix coming by on github (v2.2.3+), which is now in the beta channel, that should fix the issue with the white channel.

If I install the beta version there is a message if user switch from beta to stable they need to purge the settings, does this mean that u need to add all fibaro devices again ?

if you go back to stable, then indeed that means you’ll have re-pair all your devices, but you can also stay into the beta branch, and just disable auto update if you don’t dare more then that.

Thanks for the update, it’s a lot of work to repair all devices so I rather stay on the stable version and hope @Athom they don’t wait so long to fix issues.

I maneged to set the white channel by a flow if u use this card as shown on my picture.
But it’s not possible to choose white channel in the color option on the Fibaro device.

I’m giving up.
How to deal with this?

Fibaro RGBW controller
“Missing Capability Listener: light_mode”

The device was removed…added. The problem remains. Error on any color.
A week ago it was fine
Fibaro v 3.0.12
Homey 6.0.0 -rc.5

By contacting Athom, this is an app issue that has been there for the longest time, but only surfaced by a change that occurred in Homey v6.
Nothing you can change or do about yourself.

1 Like


i have the same problem and the reaction of the support is :

De foutmelding die je beschrijft heeft te maken met een aansturing die jouw RGBW controller nodig heeft, die nog niet door Homey wordt ondersteund. Hiervoor is namelijk een wijziging nodig in de Homey firmware die de secure koppeling mogelijk maakt van Z-Wave apparaten. Deze aansturing bevindt zich op dit moment in de testfase en gaat binnenkort uitgerold worden. De oplossing voor jouw issue is dus in de maak. Bij een toekomstige update van de Homey firmware zal deze functie ondersteund worden.
Ik verwacht dat deze firmware binnen enkele weken beschikbaar zal worden.

Google translate :
The error message you describe has to do with a control that your RGBW controller needs, which is not yet supported by Homey. This requires a change in the Homey firmware that enables the secure connection of Z-Wave devices. This management is currently in the testing phase and will be rolled out shortly. The solution for your issue is therefore in the making. This function will be supported in a future update of the Homey firmware.
I expect this firmware to be available in a few weeks.

so we need to wait a few weeks more…

Waiting for this fix as well. I have a few of those controllers in use and beeing able to use only colors suddently after an automatically installed update is just painful.

Z-Wave S2 secure pairing was released in Homey firmware v7, so you should ask Athom again about support for this device: