Fibaro Keyfob not saving advanced settings


Hope somebody can help me with this. It seams like saving advanced settings for Fibaro key fob is not working. I know that I am suppose to wake up device after saving but it doesn’t help. I tried with waking up before, after and during the saving but it didn’t help. It displays message settings are saved but when I try Square double click it doesn’t work. I installed Fibaro App recently (bought Homey Pro couple of days ago) so app should be up to date.

I also noticed that paring instructions for key fob are not correct as paring shoud be initiated by clicking any button 3 times. So I am wondering if app is out of date.

I’ve attached screenshot for device info just in case firmware version and other info is important.

Also just in case it can be a problem. Battery is low (25%)

I have no problems with the KeyFob.
You have to wake up the KeyFob before saving. Or you have “WakeUp Intervall” activated, then the changed settings will be saved the next time when the KeyFob wakes up automatically.

If you want to use “Scene Activation”, then:
– the parameters 21-26 must be configured correctly
– you have to create flows

– Keyfob buttons / Square / Pressed 2x
– Turn light on (or something else)

Homey Firmware: 6.1.0
Fibaro App Version: 3.0.14
Fibaro KeyFob Firmware: 3.2 (4113)

Don’t no why Athom choose the complicated way to include/exclude the KeyFob, but it should work also. But of course you can press any button 3 times.

Here is what I am doing:

  1. First I wake up device by pressing simultaneously 0 and - buttons. Led is continues white.
  2. Then I change settings for the buttons like so:

  1. Then I press save button.
  2. It saves without any complains. Keyfob it self doesn’t react at all (to show that it receive the settings)

When I try my flow:

– Keyfob buttons / Square / Pressed 2x

  • Push notification

It doesn’t work. If I change it to Pressed 1x it works.

Can you please let me know if I am missing something here.

Also when key fob is not added pressing (o and -) is not working so you can not go to GREEN. Only thing that works is 3X button press to put it in adding mode indicated by white blinking. That is why I am saying procedure as describe by the app is incorrect. You can go in to menu only after key fob is added. Removing it is correctly described.

Device is added as SecureDevice, don’t think you can change parameters in a SecureDevice.

But how can I change that?

Search for unsecure
Done by including as WallySwitch.

But the manual says:

And than try this order:

  1. Change settings
  2. Wake up
  3. Press save button

The settings on the shown screenshot, are these the settings when you go into the settings screen?
Or these are the changed settings before saving?

Don’t know what you mean exactly. If you mean the including process you have to follow the complete 3 steps. But I didn’t tried it out myself. If pressing 3 times work, then use 3 time pressing.
You can also contact Athom to clarify this:

No, this shouldn’t be the problem. I can change parameter on secure included devices, but I can’t change parameter with RAW configuration.

When you want to include the KeyFob (or other Z-Wave devices) you have to choose the Walli Switch (or other Walli devices) instead of the KeyFob. Push 3 times the button and than the KeyFob is included as KeyFob, but unsecure.

Yes they are already there since I changed it before (it just that change was newer sent to key fob it looks like). I am also trying to change something every time I go in to settings just to make sure it triggers the change.

I tried with o and + but still nothing.

I guess the setting are ok for what you want. So there is no need anymore to change the settings, wake up the KF and save the new settings.

Btw, I just tried it out:
– Change some settings
– wake up the KF (with pushing simultaneously + an O, 2 white LED pulses)
– save the new settings
It works absolutely flawless.

How many Z-Wave devices do you have? Which of them are electric powered? Which of them are battery powered? Are you sure that the KF is in range of Homey or other electric powered Z-Wave devices?

Key fob is only Z-Wawe device I have connected to Homey.

I reconnected it as non secure device and it saves advance settings now without any problem. Not sure what is that security for but I am not planning to assign any buttons to control my Nuki lock anyway :slight_smile:
Thanks for helping with this any way. I wonder why is it working for you even with secure adding.

1 Like

Probably it is not because the KeyFob is included secure or unsecure, but rather that it is a range problem.
Z-Wave is a technology that lives on a so-called mesh. Maybe you inform yourself.

I have not done the test on the KeyFob, because it is already included unsecure. I tried it on a Fibaro Single Switch, which is installed secure.
But that shouldn’t really matter. As already said, a RAW configuration is not possible if the device is secure included.

Aha so if you have more nodes range is longer. Thanks for info. I am new with this so I don’t know much about Z-Wawe. However not sure if range is the problem in my case since I was trying to save 10 cm from Homey just to make sure low battery is not the problem but was unable to save settings until I removed and add device as unsecure. I was removing and adding key fob before, resetting it and it didn’t helped.

But what do you mean when you say raw configuration. I was not trying edit raw configuration parameters, I was just trying to update regular parameters in advanced settings but it didn’t work until I include it as unsecured.

This is okay and was definitely not the problem.

In the menu advanced device settings or in Developer you have the possibility to do a RAW configuration. This could be necessary if you want to change a device parameter which is not listed in the advanced device settings. Not all device parameter are listed in the advanced setting menu. Why? I don’t know. Please ask Athom.

I know and this has nothing to do with RAW configuration, of course. This was just an additional information. More for Jan than for you.

1 Like

As for the Secure: unsecure has encryption as well, but the encryption is better for “Secure”. But it also requires a lot more data, and therefore it is more likely the data gets corrupted during send by other transmissions. When you are using associations, secure vs insecure inclusions may get in the way.

Also, when adding secure, the pairing needs to happen way closer to the controller as an added security measure. It sends deliberately at low power. This is also not helpful, albeit safer.

Still it does not explain problem with keyfob not saving settings when included as secured. As I was saying I was saving settings 10cm from homey and it didn’t help. On the other hand I was able to include it as secured from across the room.

So if saving should not be affected by secure mode this looks more and more like bug in the app.

Form experience, if the first attempt to save does not work, it is hard to get it to work the second time around. I’m guessing the app may think the settings are already saved and not try again. In order to get it to work I often have to first clear the setting or set it to something else, and then back. My guess is that adding it insecure got you out of that state, besides communicating way more reliable.

Ok I will try to add it as secured once I replace battery to make sure signal strength is not related to it and then try it again with changing just one parameter. Will have to remap all those buttons again :slight_smile:

In any case thanks a lot guys. I have working solution now.

In my experience unsecure is way more reliable and way faster, so my advice is to leave it unsecure.

1 Like