Fibaro advanced settings not saving

My changes of my Fibaro devices in advanced settings are not saved.
Don’t know if it is a problem of Homey 2.0 beta or the beta app of Fibaro.

Please advise.

Kind regards,


Battery-devices, mains-powered, both?

Battery devices, motion and smoke detectors.

Battery devices only receive their settings at wake-up. This is usually only after several hours or even days.
If you want to save immediately you have to wake up the device (clicking the button 3 times for Fibaro) and then press Save.
You’ll see that you receive a different response when saving then.

No the procedure does not work, the Homey app error message is: Settings cannot be saved, timed out after 30000ms.

Ah, would have been nice to mention that in your first post :wink:

So it’s working ok for powered devices?
Might be a bug then indeed.

Tried the procedure after your reply, so how could I have known…

Do not have powered devices.

Suddenly its now saving the settings…

Oh @Fire69 you saved me with your answer !

Now I can have temperature every minute with motion sensors :heart_eyes:

Thanks again !

Weird… No more time-outs?

Keep in mind, that will be bad for your battery life :wink:

Key have the Keyfob working fine and its fast for the time being.

Yet. I want to enable double and triple clicks on a button. So I go do the device advanced setting. Change the setting for a button to 1x,2x,3x, long (say for a square), click on save and it times out.

Here is a video:

Thanks in advance for any help.

Had this same problem after just pairing the Keyfob. I resolved this issue by restarting the Keyfob app in Homey. To do this, in the Homey app, go to ‘More’ -> ‘Apps’ -> ‘Fibaro’ -> the options/gear button in the upper right corner -> ‘Restart app’. Now you should be able to change the settings.

Usually, that is not how it works. A device has to be awake to receive new settings and a restart from an app normally doesn’t trigger a wake up of a device. Also, most battery devices have a setting for waking up after a specified time period, but even that is not enough to receive updates with a delay.
You must (almost) always wake up a device manually (mostly by pressing a button once or 3 times) just before sending the new settings to it.