Update Z-wave settings fails on time out

When trying to update the settings of any z-wave device i always get time-out
"Settings could not be saved. (TypeError: Timed out after 30000ms)
I tried 4 different brands of devices, Fibaro, Eminent, Aeotec, Nodon.
Using Homey Pro v2.0.4 with app version
Any ideas?

If you try this with Battery-Devices > Devices waked up before pressing the Save-Button?

1 Like

I have the same issue when updating the settings for a Fibaro Motion sensor (battery). I tried setting “Wake-up Interval” Enabled = Yes and saving the settings worked once. However, now I can not save the settings for the device anymore.

When trying to change advanced settings for a Fibaro Double Switch 2, I get a different error, saying settings could not be saved. However, this time not a “Time out” error.

Changing the settings for a Hank Tech z-wave door magnet sensor works fine.

I am using Homey 2.0.4, app version

Any ideas on how to solve these issues?



I followed CyberSponk’s advice and that worked for me.
Find out how you can manually wake-up your device(s) and press the save right after u wake up the device. It took some trial and error but finally managed. Now i even sometimes see message that Homey will wait for next wake-up cycle to update the device.

I am still having some trouble. I found the Wake-up button om my device (B-button on Fibaro Motion sensor). According to the manual a single press or a tripple press should wake up the device. I have tried pressing the B-button right before hitting save in Homey app which failed with time out error. I did the same, but pressing the B-button right after hitting the save button in the Homey app. Fail again due to time out error.

Going back and forth i finally noticed that some of the changes in the settings are actually reported to the device. So, somehow some settings got saved. But now I can not save anymore.

Just to make sure I am correct:
Wake up interval Enabled => Yes
Interval (in seconds) => 7200

What is the expected functionality here? Should I be able to change settings in the Homey app, and Homey reports the changes in the next wake up? Or, is the expected behavior that the device needs to be woken up before every change in the settings in the Homey app?


I have to press the button of my fibaro motion sensor 3 times to wake it up and the settings get saved.

@Johan_Lindbom I noticed the same behaviour, but for me it is some of the settings that time out, and others that ‘will wait for a wake up of the device’.

For example, changing one of my Fibare Zwave Smoke Detectors. Changing the report interval or report threshold will wait for wake up. But changing the Visual Alarm or Audio Alarm setting, will always time out.

I did not investigate it in detail but might explain the erratic behaviour I observed. Sometimes it simply shows Saved, sometimes it shows it will update at wakeup time and sometimes it fails on timeout. It might have been that I tried to update different fields.

Updating battery powered devices should always happen after first waking them up. The way you do this differs per brand/device, but is mostly done by pressing a button once or three times.
You should be able to find the right procedure in the device’s manual.

The same goes if you want to use the “heal” option from the developers page.

Sometimes it also works if you first send a “basic on” command to the device via the developer page but there is no guarantee that it will work.

Suddenly, I don’t get time out anymore. Everytime i save the settings I get a green bar saying that settings will be stored on the device on the next wakeup call. However, wake up intervall in the settings is turned off. So I am not sure when that is…

As you wrote you using Fibaro-Devices. WakeUp is pressing the Button three times within 1.5 Seconds.

Make sure that your Device is near Homey with Distance < 2 Meters.

Make also sure that you have opend advanced settings with your modifications ready so that you only have to press save.

Then make a WakeUp as written above. If you have e.g. a Fibaro-Motion the Eye has a blue color in WakeUp-State. On other Fibaro-Devices the small Led is blue. (or blinking blue).

Then press save. You should get a notification that the values saved.

My smoke detector devices suddenly, all accept all changes. (It tells me that it will be set at next wake up).

I suspect that the newest version of the phone app solved the issue

(could be wrong, but that is my strong suspicion)

And you are sure that they are really updated? What if you look at the settings a few days later?

Well, suddenly, means this morning.

So let me check in a few hours, after the device has reported something, like change of temperature.

Had the same issue (“timed out after 30000ms”) when changing any parameters on a Sensative Drip sensor. After waking up the sensor almost the same time as issuing the command in the Homey App it saved the setting successfully. Thank you @CyberSponk for helping out :grinning: :partying_face: :+1:

1 Like

I am experiencing the same thing. I was able to save the settings after waking up the device, but in my opinion, Homey should send the settings automatically when the sensor wakes up like with other sensors.

Fibaro in general seems to be giving problems with the Homey (had to include all my fibaro dimmers unsecure with a forked app for them to work)

1 Like

I also got this many times. Coming from eedomus I can just tell you that this is clearly a problem of Homey, as I never saw this problem with eedomus who sends the commands on next wakeup.

However, I have another problem with timeout and that is a true gamebreaker. Sometimes when a flow sets a mode change or a temperature change to my Spirit heating valves, I get a timeout error. This makes my flow very unstable and unsusable. This is absolutly no problem with the Spirit as the worked now 2 years with my eedomus system without any of these problems.