[FAQ][Advanced Flow] Infinite canvas. Infinite creativity

Vague memory of reading this more than a year ago, it may be Hue specific

1 Like

I use a virtual switch to disable a trigger
Screenshot from 2022-07-18 02-44-06

Sounds very interesting. However, I can’t get my head around how to create a state of 4 lights.
I created f.i. dimmed, day, evening states. But how to ‘connect’ certain lights or sensors to that? The app description is not helping me… and there’s no forum topic afaik.

Describe in words how you want it to work and I will try to show you.

Thanks, Anders. Well, I realize what I described can be achieved with the Zones app.
I just don’t understand what you can do with the Sets app, and how you can add devices to it.

If anyone is interested in charging their EV with Advanced Flows, I have created a Topic for that purpose!

2 Likes

You are using the the app Insight Trends. It is very useful and unique but is no longer is published on app store.

1 Like

Hi! I am sorry, I didn’t know. I actually use this app to average the excess power every two minutes over the last 2 minutes, but in fact you could also just take the excess power “at all”. I think it’s too sensitive however, I prefer to stabilize the value. Finally, any method to stabilize the value would work, but I don’t know of any other, and I haven’t been searching…

I am having problems with webhooks as triggers in advanced flows. Using the same format as I was with simple flows none of the flows are working. Has anything changed from before?


Using that flow design the trigger is not working. If I perform a test and input one of the 5 payload tags then it works as expected. It just seems that Homey is not receiving the webhook.

Hi @Philip_Montgomery,

I am using webhooks in combination with Locative in an advanced flow which works fine.
A little difference I noticed is that I use the “is exact” card instead of your “contains” card.

1 Like

Morning @Ronald_de_Boer , thanks for reply. Basically what I did was copy the cards from 5 separate simple flows onto 1 advanced flow so the contains card is what had worked previously. If I test from the trigger and give the tag value as any of the 5 options the flow works as expected but if I send the webhook using test macro option in Macrodroid, the flow does nothing. Don’t know if the fault is with Homey or macrodroid as in my exploring last night I found a note in macrodroid that the HTTP GET action that I have set up for a couple dozen webhooks from different phones is deprecated. It’s now HTTP Request and I don’t know nearly enough about webhooks yet to figure that out. I’m not sure how long that note has been there, if it’s months then macrodroid is not the culprit, fairly sure it’s Homey as the action stopped when I copied all thre flows across.

Have you tried with a temporary test flow?
Make a standard flow with one of the web hook triggers and send a push message to yourself.

Have just reactivated a previous simple flow, test within homey works but test from macrodroid does not. A behaviour somewhere has changed and broken a lot of flows and automation. Still not sure whether Homey or macrodroid although tbh if this were a Homey problem with the number of webhooks people seem to use it would be being reported all over

If you have not done any upgrade of the Homey since it worked with your previous standard flow, it is not a Homey issue.
My webhook still works, even with v8.0.2.

1 Like

Pretty sure it’s macrodroid, the app has updated a few times this past fortnight with no notification of changes which is odd as it usually does. So far it looks like the dev has redacted the feature I was using and I have the paid version. Need to start over figuring out webhooks

I took a look, they changed ‘HTTP GET’ to ‘HTTP request’, where you can select the GET method.
So that means you have to edit your macros…
Go to ‘Applications’ and pick ‘HTTP request’

Enter the url of your webhook, save it, et voilá.

.
But thanks for the alert, I didn’t know what was going on yet and now I know :upside_down_face:

Thanks for that, that’s exactly what I had done and it still isn’t working. I had been getting a lot of HTTP Get failed java. Net unknownhostexception

Sounds to me the url no longer accepts an IP address in the hostpart.

Well, it works here, with standard and adv. flows. With both local IP webhook (see screenshot in prev. msg), and via athom api (https://your-homey-cloud-id.connect.athom.com/api/manager/logic/webhook/MyEvent?tag=MyTag)

What gets returned if you enter the webhook in a browser?
Are u using http:// for the local Homey IP address URL, and https:// for the web api URL?

Perhaps I haven’t searched well enough, but I can’t seem to find the answer to a simple question:
How do I start a flow from an advanced flow?

I see these cards, bit don’t know how these can start a ‘standard’ flow.

The ‘old’ way - with a dropdown menu to select a flow - is no longer available.
Speaking of which, could some kind soul show how these flow start cards can be used…

Thanks!