Existing App Update Suggestion - Sony Multiroom Speakers

Hi,

There is an app for the Sony Multiroom speakers, like SRS ZR5, ZR7 and HT-N5. I really liked this app, but unfortunately the app does not work with Homey 2.0. I removed the app and hoped re-installing would fix it. However, the app doesn’t even install anymore on 2.0.

I tried to contact the developer in many ways but never got a response back. So after a few months of waiting, I was hoping someone else can update this to 2.0. I am very willing to alpha/beta test to help out!

This is the app https://apps.athom.com/app/nl.casperboone.sony-srs-multiroom-speakers

Note: I own the Sony SRS Z7 (speaker) and HT-N5 (soundbar) (they both worked flawlessly) and can test with either.

@Casper :arrow_up::arrow_up::arrow_up::arrow_up:

1 Like

The code has already been updated for v2 and is available at https://github.com/casperboone/homey-sony-srs-multiroom-speakers. However, I’m not sure why didn’t publish it in the app store 4 months ago after the last change. So will have to test that again, which I’ll try to do soon :).

1 Like

Thanks for the quick response Casper, really appreciate it! Is it possible for me to test/install that code on github through CLI?

Yes of course! Go ahead and let me know :slight_smile:

@Casper So I’ve just tested everything. The app installs fine and can find and add all three of my speakers, which is great news! I can use the volume and mute controls through Homey as well, also great! The main issue I’m having however is setting it up in Flows. I used the app for Flows before in conjunction with IFTTT and NumCatch. This way I could say to Google Home “set tv volume to #” in which IFTTT would start the Flow with NumCatch in it. That would then pass along the number in a Flow for the Sony app to change the volume. This worked flawlessy before.

Currently this does not work unfortunately. I have tested the Flow with other devices to make sure the Flow is set up correctly. Everything works there. I think the issue is now how the app controls the speakers. It uses a percentage now instead of direct numbers. Before I could input “volume 18” and the soundbar would set the volume to 18. Now I have to use a percentage, which for some reason will result in a volume exactly the halve of the value. I think because max volume is 50 (this is the same case with controlling the Volume of the Chromecast function using Google Assistant). If set it at 20%, the volume will be set at 10. But there is no way to use a “number” tag, it will not change the volume. This is the main issue I’m having (which worked before).

I hope the issue is clear because it’s kinda hard te explain cause of the Flows I use.

I am having trouble installing this app on 3.2.0.

Don’t bother trying this app. It’s broken since 2.0 release unfortunately. I tried the ‘newer’ build through CLI install. Though I could install and add devices, it wasn’t much usable. The developer doesn’t work on this anymore sadly (as you can see above). You should use infrared commands if you’re Sony device supports that.