Error creating local API key

Hi all,

I started this week with my new Homey pro 23. Everything works fine except I cannot create an API key. I get an error and a pop-up to send a crash report.

I tried to reboot, did a factory reset but I stil get an error when I want to create a key. The actual error can’t be read because the send crash report pop-up is over the error.

I already sent a message to support.

Has anyone a good idea to solve this issue?

1 Like

Try another browser.
And / or empty browsee cache and reload
Or try in private mode.
Or try using an other computer

Hi Peter,

Thanks for answering.

I tried another browser / empty the cache / private mode and also two different computers, all without luck. So I don’t think it is a browser problem.

I managed to get some more info about the error. After pressing create api, a short message appears saying: “TypeError cannot convert undefined or null to object”

1 Like

Same issue here:

But it’s intermittent, sometimes it does work after a reload.

Have you tried logging out and back in again?

Same issue here. Tried different browsers and different computers, but no luck.

I also tried to create a new account and changed ownership. Just to check it is not an account related problem. Also without any luck.

I posted about it on Slack, let’s hope Athom will pick it up.


Exact same problem here. Also created a ticket with Athom support. If you hear something back or find a solution I would be very happy to hear :grinning:


Just got a Homey Pro (2023) 10 days ago and cannot get the API Key, it crashes the interface every time i try…

Tried different computers, different web browsers, submitted a support ticket but… 3 weeks response time ? Seriously ? For a 400€ Box…

Anyone have the same issue and a workaround ?

here is the error i get

Thanks !

Have you done what is suggested in the pop-up window? Have you contacted support via this form and described what happened?

Hello Fantross,

Yes filled in the pop up window and contacted support where i got the “3 week reply time”…

thanks !


This is a standardized automatic response. Usually you will receive a response from Athom much sooner.

Support responded quickly and solved the issue !

Don’t know what or how they did it but i got the API Key working :slight_smile:

So solution to this problem is to contact support.



Same here,

Support solved the problem yesterday. Great, A fast reaction from support during this holiday season!

1 Like

I didn’t have contact with support, but with me the problem is also solved :slightly_smiling_face:

I experienced the same issue last week, multiple times. I sent a response to support. Error stated " An error occured TypeError Cannot convert undefined or null to object" . My HP23 locked up and had to restart between freezes.

Although my file was still flagged as “open” It appears the issue has been solved. I was able to create an API moments ago.

Idk but all three posts above yours also state the issue is solved already :wink: