I installed a meter reader today, and to my surprise, there seems to be no way to adjust the power tab in the app. Since I now have a reading on the total consumption, homey adds this to the existing power readings. Surely, there must be a way to remedy this???

That’s not a lot of information you provide. Which smart meter? Which app?
But read the following post, maybe that already explains everything.

1 Like

Ok, cool. That pretty much answered my question. What I need to know now, is where and how to access the driver, to make the appropriate changes. Any tips?

Do I need to write something from scratch, or can I change what is already there?

If the app code is available on something like GitHub hub then you could probably download it, make the changes and install it from the CLI.

What app are you using?

Isn’t there a Advanced setting available, like this one for the Homewizard P1 meter

I’m using the eva Meter reader, so the eva app. I guess I could always get in touch with eva, and see if they can change the driver.

There is no option to exclude from total in the advanced settings for this device, sadly. It was the first thing I checked.