Easy Logger App paused?


I’m developer for Easy Logger and got a message from one of mye user telling the App had stoppet. Meaning not producing anything.

The user was finding a pause icon on the App. I have never seen that before. Anyone knows about this state ?


When an app uses more than 80MB of RAM is gets paused automatically.

aha, didn’t know that.

The issue is now documented on web page



Is there a way to detect the memory usage and for now restart the app is it happens ?

assuming pausing is not a crash .

I assume that it will work, but I am not sure.
Another intermediate solution could be to restart the app automatically 1 time per day via Flow.

I had already pointed out to you on Twitter that your app requires a lot of RAM, but unfortunately you didn’t respond.

I’m not an app developer, but as far as I know there is a recommendation from Athom what the maximum memory consumption of an app should be. I think that it should be a maximum of 20-25 MB.
@robertklep, do you have any information on this?

I think you’re right, I seem to remember something similar (although the only actual limit is the aforementioned 80MB). Can’t find it on the dev site though.

1 Like

I had already looked there too and found nothing.

It’s mentioned under App performance in the Developer Tools


@fantross Sorry for not see your twitter message, got lost in the forest …

The true story behind is that this was only a ‘private’ app, but got popular so I put it on the app store.

Will try to shrink it. The Google API client must be the reason.

1 Like

Yes it does use some memory, but this is not only based on the amount of modules.

‘someting’ is happening here…

Does your app use timer (setInterval/setTimeout) or EventEmitter? Those are typically good candidates for memory leaks.

I have this sleep function

  async sleep(ms: number) {
    return new Promise(resolve => setTimeout(resolve, ms));

Is this a candidate for memory leak ?

No, that should be fine.

Kind’a fixed the memory footprint …

Replaced the big google complete library with the google sheet only version.

Just be exited for the next version … test version here : Easy Logger | Homey


1 Like

Had to revert the test version, found some bugs.

If the bugs are fixed and the memory consumption is in a normal range for such an app (Athom’s Google Sheet app consumes about 10 MB), then I’ll give the app a second chance. :+1:t2:

v1.4.3 is out in test Easy Logger | Homey

@fantross If you want to test the app I’m interested to see if the date and number format is working outside Norway. Not so easy to test.

Installed the v1.4.3 version and made some small tests:

Short summary:

  • in my opinion, the app still needs a lot of memory consumption (ca. 13-28 MB)

  • Action card Create a sheet works :white_check_mark:

  • Action card Append multicell items in spreadsheet… doesn’t work at all (same spreadsheet like above).:exclamation:
    Tried it with:
    – numeric tag only
    – with # in front of the numeric tag
    – with @NoDate in front of the numeric tag
    – with @NoDate|# in front of the numeric tag

I haven’t tried the other cards.

set debugmode see 4. Configure the Easy Logger App - Homey Easy Logger - Confluence
and send me a diagnostic trace

I can try to see what’s happening.