[App][Pro] Homey Easy Logger

The community thread for Easy Logger App for Homey | Homey

Homepage with instructions and a lot of tips : Homey Easy Logger Home - Homey Easy Logger - Confluence

NEW: v1.7.0 is released.

It uses luxon as time and date library, and should handle summer time conversions automatically. But it has a updated timeformat.

read more in the documentation : 5. Configure timestamp format - Homey Easy Logger - Confluence

NEW: v1.8.0 is released into test, with fire and forget support : Easy Logger App for Homey | Homey.

NEW: v1.8.2 is released. Option to adjust intervalCap setting. read more in the documentation : 11. Fire and forget - Homey Easy Logger - Confluence

Other features to be aware of :

read more in the documentation : 11. Fire and forget - Homey Easy Logger - Confluence



after creating the sheet etc which seems ( or not) went well i am not sure how to find the error in a flow.
How do I register a flowcard? the error is:

I created an error report would you please direct me in the right direction to solve this.


You need to check the contents in the json file

[err] 2023-02-09 12:21:31 [EasyLoggerApp] Credentials file were invalid, could not parse the content SyntaxError: Unexpected token h in JSON at position 1908


Use the Developer Tool is you can, to paste data in the settings dialog


1 Like


Thanks, copy and paste was wrong as I did it on the phone.
Up and running thanks!!

Now try to find the right way of using.


In the date/time field the are the letters “kl.” what does that mean?

It’s a norwegian format for the hour. I will provide a better format soon

@Addie Can you try the v1.5.0 currently only available as a test version Easy Logger | Homey

It should use a more generic dateformat

the kl is gone.

The version is 1.5

@Addie Can you put your own timestamp format to that cell/column to verify this is a valid timestamp. Maybe do a duration calculation to see if it works

As I am not very good at google sheets but:

When I go to “format” it sugest to use the “/” and the “:”

This might me depending on the language or area settings as well.

@Addie Try this formula =YEAR(P10) where P10 is a cell with date created by EasyLogger. If the year component is correct, the date is parsed the way it should be.


The formule is:

The error is that A67 is e text field and not a number.
Would it be possible to change the seperator to the “/” and the “:” or to have this as a variable in the settings menu?

@Addie I guess it migth be because I’m not putting zeros in front. Wait for the v1.5.1 …

@Addie You can try v1.5.1 from test and see if it solves your timestamp

The zero’s are there but this did not solve the issue.

My assumption is that it is the separator in date and time.

In your samples on the website:
The date/time field are on the right side of the cell, mine are on the left side.
When I format to date/time with the other separator in mine sheet it moves to the right as well.

When I change the sheet ( file >> settings to “Norway Norwegian Nynorsk”) it solve the problem and even added the KL to it.

So it appears that depending on the (language) setting in the sheet you need to change separator.

Hope this helps.

@Addie Thanks for the input. I will povide a custom timestampformatter in v1.6.0 so U can set the matching format, typical dd/MM/YYYY hh:MM:ss

@Addie You can try v1.6.0 and see if it this fits


1 Like

Yep, it’s working fine:
this is the Dutch format. DD-MM-YYYY
For the American you need to change the MM/DD/YYYY

Both seem to work fine!
YEAR(A404) gives 2023 where A404 is the date filed in the sample

:+1: Thanks

Good to hear. Moving it to prod in a day or two if nothing else issues occurs

Is it possible to add “at row-nbr” to the action card “Append multicell items”?
I would like to be able to fill such a table with values. With the beginning of a new month, I would then select a new column and simply fill in the values one below the other: