Downgrade or Re-Flash Homey

I am having trouble with Homey’s z-wave. I think it is not working anymore. I had Homey working with an Aeonlabs multisensor 6 for 6 months, when I bought an Qubino smart switch (ZMNHYD), two days ago. For this switch I needed to install the Qubino beta app, since this one only supports this switch. Install of the switch was started, but hung. I saw a long line of (I think) text referring to the zwave module in Homey’s OS, I guess? Trying again won’t find any module, at this point I see that the Aeonlabs sensor is gone, too! The scenes using this sensor show a broken keychain… Tried many things, such as remove the z-wave device, but no devices to remove, reset z-wave, set Homey back to factory defaults, again, upgrading to the beta, all without any result, no z-wave anymore. So, what I think needs to be done is flash the original Homey OS, so I can see if it is a software or hardware issue. Any ideas of how to do this? Thanks…

U also did a factory reset of the device itself?

What do you mean by original Homey OS?
What version firmware is Homey running now?

thanks for anwering, Yes, of course I did. It’s the procedure where one puts Homey upside down for 10 seconds, right?

Actualy i meant the Quibino device.

I mean the firmware, but, that is the OS (Operating System) in some way, right?
Homey Firmware Versie: 1.5.13-rc.11

I was not aware that the quibino device could be reset. How?


Tried the procedure (press button 5 times within 3 seconds), but the device gives no visual feedback or something, so how does one know it worked? I tried then to discover the Quibino again, but nothing detected. As said before, I tried to discover the Quibini and also the Aeonlabs device but both are not seen anymore by Homey. Isn’t there a way to do a “self” test in Homey, to discover if z-wave is working properly?

Maybe check the developer tool section?

Reset homey, do not keep your settings and press the Alt when you continue to choose to rollback from expeimental to the latest stable firmware.

But you can’t go back further like the one your Homey was delivered with. (Believe me, you don’t want :wink: )

Clicking with Alt pressed results in nothing, I see that the text in the button changes, but that’s it, so tried clicking without Alt, and the procedure continued… No have to wait for the download to finish. :frowning: But this is the previous software version, so at least that is better than the experimental version, I think. Will try again when finished…

Okay, thanks, I am back at firmware 1.5.12 now. I managed to re-add the Aeotec multisensor 6, but only after resetting the sensor. At least now I know that the z-wave of Homey still works. The Quibino smart switch still does not work, so I guess it is faulty, I am in contact with Quibino for that. Thanks all for helping!

Version 2.0.7

  • Removed ZMNHID (Flush On/Off Thermostat) Flow Cards for input 1/2/3 due to firmware issue with device