Does Homey Bridge acts as range extander or repeater?

Hi Guys!

I´m using Homey Pro 2023 and 2x Homey Bridge.
I already noticed that no Z-Wave devices connect to the Homey Bridge. They connect to everything surrounding them using the Mesh network. But no connection to the Bridge according to the tool.developer page.

Today I added few Gledopto RGB-CCT controllers. Adding from outside of the house (they are used in our carport) was not possible at all although the Homey Bridge was in the middle. Total distance device → HP2023 below 15m through just two wooden walls. Strange as Hue bridge did it easily.
Then I took them inside the house and put them close to HP. It worked. Then put them again outside and get an extremely unstable and slow connection.
Then I placed the Homey Bridge halfway. No change. Same bad connection.

My question: Does Homey Bridge act as a repeater or range extender?
From what I understand it is advertised to do this job.




Alex, I have the same doubt.

As I have two of the bridges and both behave exactly the same way in terms of extending the range, there are only two possible options: 1. I misunderstand what the bridge is for or there is a software issue.

And it doesnt matter what kind or manufacturer of the z-wave product it is. I have several in use. Not sure about Zigbee, as I only tried the Gledopto parts.

@Alex_S1 @Marco_Perotti Here’s all info you’ll need

1 Like

As I was disappointed that the bridge did not extend the 433 MHz receive range, I have just stored it away two months ago.
As I now would like to extend the Z-wave range, I put it on the first floor, just between the ground floor and the second floor and connect it to the mains.
After a while, the red exclamation mark is switched off in the device over view of Homey, and it says it cannot be controlled but it is fine. I can also change KaKu devices to use the Antenna of the bridge.
So everything seems fine.
However in the development tools I don’t see the bridge in the Zigbee and also not in the Z-wave network.
Does the bridge need a software update? Could not find it yet.

Wait, something has happened!!!
The Z-wave connection was directly to Homey, but now via node 3. That shall be the bridge, but node 3 is not in the list. Pings are better now.

It was set up correctly and is shown within the homey pro overview. Both bridges are shown. Do setup was done correctly from what I see.

Tested the IR functionality with our TV and the Bridge controls it via IR. So the bridge is connected correctly and works in satellite mode. But none of the bridges do it for Z-Wave or Zigbee.

Thank you Peter :smiley: meanwhile I ordered a Homey Bridge which should arrive next Thursday :smiley:
While on that: will the pairing have to be re-done towards the Bridge, for the devices which are remote, or will they dynamically switch to the strongest signal?
Thanks again!

It wont work. At least it did not for me. I added several Z-Wave devices having the bridge halfway in between the HP and the device. No connection to the HP is shown.
I wrote to the Athom Support. Automatic reply indicated response time of 3 weeks.

1 Like

I would like to see a network overview for Z-wave and ZigBee as proof that it cán work.

(taken from this post)

But a lot of people think that because they added a Zigbee router in their network, any devices that are physically located near that router will always switch to using it. Which isn’t the case.

Good to see your Homey Bridge in the ZigBee network table.
My bridge is at firmware 81, what is yours?

@robertklep I would like to really thak you for all your support you are extending to us , you are of a great help. in my opinion Homey are still working on enhancing the satellite capabilities specially with Zigbee and Zwave as for the moment they are not working properly . I see o nthe firmware 10 ( still beta ) they have done something to show how Homey bridge work as a router but i still don’t have the option to know which device connects to which node. on the Aqara hubs for example, you can click on the hub to see the child devices connecting to it and each time you add a new device, it asks you which hub you want to use as a parent hub

Homey is great and i wish one day they fix the satellite issue so i can return back to using it again

1 Like

this photo is taken from Firmware 10 ( still in beta ) you have to enable Beta firmware downloads to be able to upgrade to that release

That option isn’t available on the HP2023, and according to Athom it will not come back (it was available in a rudimentary form on earlier Homey Pro’s).

That’s simply not how Homey works. Also, it sounds like the Aqara hubs are more that just simple Zigbee routers, unlike the Bridge.

But we already explained to you why you’re having issues with your Zigbee network and how to fix it to make it work with Homey.

I just dit a test: the Homey bridge is extending my Z-wave network, but not my ZigBee network.
I tested by having a Zigbee and a Z-wave device out of reach of Homey, confirmed by ping commands. Then I switched on the Homey Bridge, located halfway between devices and Homey. The Z-wave device is reachable, the ZigBee not. In both network tables the bridge is not visible.
Maybe Athom implemented “transparant bridging” a little bit to transparant :grin:

How long did you wait? What type of Zigbee device did you test this with?

PTP of the bridge. And place it closer to the PRO. That did the trick for me to make the nodes available again on the tools page.

Zigbee: Philips Hue outdoor occupancy sensor SLM004
Z-wave: Fibaro Smart Implant
I only waited 3 minutes or even less, until the Z-wave device was visible and pingeble. Now the ZigBee device is also pingable. So it took some more time for Zigbee.
Conclusion: the Homey bridge is part of the ZigBee and Z-wave network, but not just visible as node in the developers tool. That is ok for me for now.