Disable experimental updates

Hey guys, I`ve enabled experimental updates in dev setting. However I decided to withdraw but the slider is grey and I cant disable it. Is there a way? Thanks.

Oh cool thanks. I went through the forum not FAQ.However hard reset is not a way for me :thinking:

You can always disable automatic updates and manually install only the stable updates.

1 Like

Hi Bob

On the developer site I see this: “Experimental updates are enabled”. The flip switch (to disable it) is greyed out.
I indeed have disabled automatic updates, but when I look for updates I’m only offered to install 3.2.1-rc…
Is there a way (I think that is what you are suggesting) to install 3.2.0 regardless of what Homey thinks is the latest available version ?

Since 3.0.0 I never installed a, experimental version, so I don’t understand why I can’t disable it.

Any help is welcome.

Updates will always only offer the latest available update for that branch, you can’t select older versions (which is 3.2.1 rc2 for experimental).
Athom won’t offer any other options for this either.

As for the being able to disable (this has been notified, with verification question that you’d understand, when you clicked the experimental checkbox BTW), can only be done with a full Homey factory reset.
A factory reset is also the only way to get 3.2.0 (for now) as that is the latest stable version.

1 Like

Soon :tm:
Last time you get the Experimental updates offered are for 4.0.0-RC#

Homey v4.0.0-rc.5 experimental

  • Introducing Homey Cloud Backups. Update the Homey app to v4 or higher to get started!
  • Experimental updates can now be disabled

If you are on a version 4.x Experimental you can disable the option and only get the firmware releases in the Stabler channel offered.
Or just wait until 4.0.0 will be offered to Stabel channel and then Upgrade and Switch back.

1 Like

I enabled experimental updates. Is that enough to get the Update regarding version 5? Will it be installed automatically or is there something else I need to do? I enabled it yesterday.

I had to check. But yes, auto update is ON. And I can see the update in the app. Thanks!