Develco Products App - Control your home and make it safe (v2.1.0)

Which Homey version and Develco app version are you using?

Homey v4.2.0 and Develco v1.0.0

My EMI Norwegian HAN only reports it’s values once after pairing (a slight delay). A while ago it reported regularly, but then without any change of software versions, it stopped reporting, at last the Develco app is not showing anyupdates. This started when I was using Homey v4.2/Develco v1? and the same happens with 5.0.0-rc.38/2.0.4. The meter is only 4 meters away from Homey. I’ve tried restarting Homey/app.

How do I best proceed to debug this?

Great work! I have implemented magnet contacts, motion sensors and smart plugs at two different locations. They all work flawlessly so far ( v5.0.0- rc.38).

Are the keypad, the siren and the air quality sensor on the roadmap going forward?

@monoburn unfortunately the migration from Homey v4.2 to Homey v5 is not stable yet and might result in issues. The general advise for now, not only for the Develco Products app, is to reset the Zigbee network after upgrading to Homey v5. Unfortunately, this will mean that you will need to add your Zigbee devices once more and rebuild your flows.
Athom is working on improving the migration from Homey v4.2 to Homey v5, but that will not have an effect on people already updated to Homey v5 experimental release.

@BalleClorin welcome to the community!
Thanks for the report and feedback.
Yes, once the Homey v5 and the current supported Develco Product devices is running stable, it is the intention to also add support for the keypad, siren and air quality sensor.

Thanks for your feedback. I’ll try resetting the Zigbee network (Homey App -> Settings -> Zigbee) and add the devices again.

1 Like

Thanks, looking forward to your feedback.

For all people having issues with the keeping Develco Products App (v1.0.0) on Homey v4.2.

We are aware of the issues and looking for options to resolve the issue.
Likely, the Zigbee implementation within Homey v4.2 will not provide the option to resolve this issue (completely).

Even if there would be a solution and app update, the current Homey app store does not allow to release a v4.2 update to the stable channel, while having a test version (compatible to Homey v5) in the app store as well. Please be aware, that this is completely outside our control and is also impacting other app updates, like for Aqara / INNR as reported here on the forum.

The current experimental Homey v5 compatible version (v2.0.4 | is showing a stable performance. But Homey v5 is still an experimental version, with two major issues:

  1. The current migration of the Zigbee network from Homey v4.2 to Homey v5.0 is not always yielding a stable Zigbee network,
  2. In some cases, people are not able to add more devices, even though all preconditions appear to be met.

I am working with Athom to get these issues resolved as soon as possible, by providing all diagnostics data available; but will need to rely on a Homey v5 update of Athom.

A containment for 1. would be to reset the entire Zigbee network after the update and re-add all Zigbee devices after the reset (starting with the mains powered routing devices). People who have done this, report to have a stable performance of the Zigbee network. But it is a step that requires extra effort from the end-user.

Please note, the Homey v5 is still an experimental release, with above mentioned issues.
Please check the generic Homey v5 topic and the topic tracking the apps not compatible with Homey v5 before upgrading the Homey v5.

1 Like

My EMI Norwegian HAN keeps getting stuck on the first values after pairing. I paired it again after resetting the zigbee network. Restart of Homey and the Develco app didn’t help either. Also having problems pairing other devices that worked before the network reset, but that might be temporary; some work, others won’t pair. I’ll try a few more times. Else I’ll wait for the final Homey v5.

Thanks for reporting back.
Could you send in a diagnostics report from the app? Settings > apps > Develco Products > Send diagnostics report, with mentioning the issue and you username?
I’ll have a look into it.

Diagnostics report 751fc339-780e-4eab-9cf6-1c79e7f9fb69
for EMI Norwegian HAN with stuck values.

Thanks, one additional question.
Can you go to and press the interview button next to the EMI Norwegian HAN device, copy the outcome of this interview and paste the content (does not include sensitive content) here?

I’m afraid the interview process timed out: Interview failed (error: timeout). I re-paired the HAN device, got one value (W), restarted the app, got the other value (kWh). Both values stuck at the initial values (no updates the last 25min/1 hour). Tried the interview again, but it timed out again.

I’ll add another reply if the interview returns a non-error.

I’ve just released the v2.0.5 update of the Develco Products app to the test environment, with the following main changes:

  • Fix for EMI Norwegian HAN initialization issue
  • Optimized initial initialization of the sensor devices
  • Add measure_luminance capability to the motion sensor, alarm_tamper to the window sensor and enabled alarm_battery capability

@monoburn @BalleClorin @Tangodelta can you support in testing this update and sharing your feedback? Much appreciated!

1 Like

Will do!

Have smoke, smart plugs, humidity and smart cable devices, all working normal!

1 Like

Both before and after updating to 2.0.5-TEST I have trouble adding Smart Plug Mini (Schuko). No progress in the pairing screen of the app. The EMI Norwegian HAN I need to test later this week. The power company deactived the HAN port (according to their web page). That might partially explain the stuck values. I’ll add to this topic once I’ve done more testing.

Athom is currently testing a next Homey v5 update that should fix among others this pairing issues

Thanks for the feedback. If you find an option that I would be able to enable the HAN port from within the device, let me know. :wink:

One motion sensor and one magnet sensor at my current location. Luminance not reporting after upgrading app, but tampering sensor does.
Everything else working as normal.

Adopted a new motion sensor and for this one luminance works as well.

Pulled the batteries on the motion sensor that didn´t report luminance. That did the trick and now this one reports as well…