Danfoss Ally - devices stop responding

I have the Homey Pro 2023 and added 7 Danfoss Ally to the Hub (directly using the Homey Danfoss App).
Devices are detected and I can adjust the temperature directly and create flows that sets the temperature without any issues - for the first couple of hours.
Then, they start to become unresponsive and I get timeout errors if I try to set them directly from Homey.

Is this bugged?

Btw, I have the Danfoss Hub - but it’s not connected - the Ally Temperature devices are connected directly to Homey.


Please provide for some relevant info, and
product links and such.
Wifi? Zigbee? Zwave? Bluetooth?

:rofl: Excuse me? Do I know you? This is your first post, and you start bossing me around? You don’t tell me what to do, funny guy.

And when the TS doesn’t respond in 2 months,

Screenshot from 2023-11-28 09-27-53

the issue was not an issue at all appearantly, so the process ends here…

I have the exact same problem. I have 7 Danfoss Ally thermostats, a single zigbee relay (for powering on/off LED spots) and an Airthing View device connected to my newly bought Homey Pro 2023. Everything worked great - for a couple of days.
Now, if I reset a thermostat it is impossible to get it to connect to the Homey, and if I try to change a temperature for one of the thermostats that are still connected, the homey app times out after 30s - but sometimes eventually reports ok. However, it takes like 10 minutes for the thermostat displays to update - and the temperature being set is complete wrong. I tried to set all to eg 21 Celsius but some changed to 33 Celsius, others didn’t change.
I have tried placing the homey next to a thermostat when reconnecting and adjusting - but that didn’t make any difference.
I have filed a report in the Danfoss Ally app (version 2.3.1) : aa37e5e6-a7ee-41d0-b146-c2d0f2618b47

I filed a support issue instead, and the case was handed over to development.
Using my debug files etc, they could establish the same evidence, as you described it as well.
Nothing has yet happened, so in the meantime I had to put the thermostats back to the native Danfoss hub.
It’s just a shame, since they worked perfectly in SmartThings, but never worked in Homey (for me)

I have the same.
So the situation is thar Ally does not work with Homey.?
Can Homey confirm.?

This is a community forum and your posts, questions and suggestions will not be read by Athom. You can read more about this here Welcome to the forum..

For support or issue resolution, first have a look at support.athom.com. If you are unable to find the answer to your question on support.athom.com you can send a support request to Athom via https://support.athom.com/hc/requests/new.

If you need help you can read more about how to submit a support request.

When filing a support request, make sure you add all necessary information so Athom can help you as quickly as possible.

I have exactly the same problem. I made a routine that checked if the set value was correct every 30 seconds. it can take up to 10 adjustments before the set value is correct

Has this issue been solved now? I am considering Danfoss for my under floor heating system with Homey. But if it does not work I would rather look for something else.

I have two Homey Pro (Early 2023) in different buildings

  • one with two Danfoss Alley and
  • one with three Danfoss Alley

As long as they react, they sometimes set wrong temperature.
For example:
Flow sets 22°C Danfoss Alley goes to 28°C.
Flow sets 17°C Danfoss Alley goes to 12°C.

Latest after some days they stop working completely.
Homey shows the setting that the flow set, but the Danfoss Ally does not change its temperature.

It is completely unreliable.

It is the Ally Radiator Thermostats you are using right? Not the Icon2 wall thermostats connected to Ally Gateway ?

It is the Ally thermostat without any other Danfoss hardware.
Ally is diretcly connected to Homey.


Homey still doesn’t work. I opened a support case, and was in dialogue with the Team at Homey. They closed the issue and told me they’d transfer the issue to the App Team, and since then… nothing.
I chose to use the hub from Danfoss, but I would prefer the Homey over anything else.
Disappointed that it still doesn’t work.


I have the same issue and I did contact the Homey support about it back in December. The answer I got was more or less nothing. They don’t care. The other issue I have is that the measured temperatures do get stuck after a couple of days. It happens for all my 9 Ally thermostats.

It worked absolutely fine when they were connected to SmartThings. I might go fully back to SmartThings and put my Homey hub up for sale.

I have the same problem and even though I told them I was not the only one with the problem the answer was that they could see that most people did not have this problem so they could not do any more about this issue, but I could send a device to them to investigate. So I dont expect them to try to solve it. It is an arrogant behaviour from them.