Chronograph transition steps missing

When I use chronograph transition and want to start a flow at e.g the 5th step, it sometimes skip a step. It could be te 5th. You can’t rely on the function. Everytime a transion step is made I made a notice. In the sreenshots you can see that there are random missing steps. Is anybody having an idea what could be wrong?

Could be the number of steps you use and the start / end. If you count from 0 to 10 I think Chronograph counts it’s 11 steps, not 10? But then again, I would expect decimals in the transition value and the same place it skips. Maybe share your flow, not just the output?

Do you have additional conditions in the flow with the notification?

I also do not always trust timeline notifications. They can throttle, although they shouldn’t at a minute apart :slight_smile:

I tried to reproduce but cannot, albeit in seconds. I didn’t want to wait 10 mins. - Then tried minutes too, same normal result. No skipping.

I ran some tests, but I can’t reproduce the behaviour you experienced.
Homey v7.1.2-rc1 (non-pro)
Chronograph v1.1.1




Output 1st run

Output 2nd run

Output 3rd run

Output 4th run

System load

Memory & app overview

The reason why I use 11 steps is that I noticed that Chronograph transition use starting point as first step. So if you want a step from 1 minute you need 11 steps. You could be wright about timeline throttle. I’m going to test if timeline missing a step also there will be no output reaction (Then). .

No problem. Thanks
Couldn’t find the right place.

1 Like

I.m using Homey Pro V 7.1.1 and Chronograph v1.1.1 .
strange that he sometimes skips a step. As a Reply on Edwin. It could be that the steps are there but not set to timeline. Therefore I try only to look at the outcome. Which is: put the screen up 100% at step 5

Unrelated to the notification, but maybe that was put there to debug another issue I noticed in your flows: cards are executed in parallel. So “Opstaan transitiewaarde” may not be set when “Opstaan cos down 6” runs. You probably know the principle, seeing you put a delay to make sure “Opstaan sin berekening” was set when you use it for dimming. But you havent protected the first one. It is less likely to fail, but it may.

A safer way with less delays is to create flows with a trigger “a variable has changed” (assuming each step actually changes the value).

Another thing that may be bugging you, numbers are floats, and floats are not precise. So maybe step 5 is actually 4.9999999999997. This is not unlikely, as probably there is a division by 11 in there somewhere inside. Maybe try testing between 4.5 and 5.5?

OK Edwin, I will continue testing. Thanks

I put my bets on 5 not being 5 :slight_smile:


In the mean time I tested some changes. I changed flows to prevent cards executed parallel.
It’s now like:

With this I still sometimes missing a step

When I tested with these cards.

So also when I have some simple cards I miss a step. Often different steps and mostly only onen out of 10.

Very strange that this only happens to me and not with Peter and Edwin.
What can be wrong?

To ckeck that it isn’t a problem with the timeline you should implement a log, for example with papertrail log and implement it in the Test Waarde flow.

How can I implement a “papertrail Log”?

1 Like

Correct, but a timeline notification of 1 per minute is not an issue (I may hope).
As you can see in my test screenshots, 1 per 2 seconds is going OK.
BUT @Fred_de_Goede please DO try the Papertrails logcards in parallel (use a notification AND a log card). This can rule out timeline issues.

Did you check your load and memory already, as shown here at the bottom. Maybe your Homey is too busy with all kinds of other stuff?
Can you f.i. start your test flows with a time trigger, at a point in time when Homey most likely is bored as fuck? (note: @ 3 AM backups and cleanups take place afaik)

Integrated papertrail log in simple flow Started when Homey is not busy,. Still missing step.
It looks like it’s not a timeline issue.

-=-=- Log Cleared from Settings page 20210822110957] -=-=-
2021-08-22 11:10.28 Test 0 0 true false
2021-08-22 11:11.28 Test 60 1 false false
2021-08-22 11:13.28 Test 180 3 false false
2021-08-22 11:14.28 Test 240 4 false false
2021-08-22 11:15.28 Test 300 5 false false
2021-08-22 11:16.28 Test 360 6 false false
2021-08-22 11:17.28 Test 420 7 false false
2021-08-22 11:18.28 Test 480 8 false false
2021-08-22 11:19.28 Test 540 9 false false
2021-08-22 11:20.28 Test 600 10 false true

The only thing I can think of is to contact the dev. Maybe sending a diagnostic log right after a ‘step missing’ run can reveal some issue.

I see in another post that you have flows triggering every minute, starting timers checking device states on a periodical level and so on as in the below post. I would check your system load, as I would not be surprised if you use this approach more that Homey is too busy at times to execute the step at the right time.

I only use one and when the flow is active my sytem load. Do you think this is a bad sollution for this?

The load goes from 65 to 35. I don’t think this will effect my chronograph issue but don’t have experience with system load.