Can't change configuration of Fibaro Dimmer 2

Hi,

I’ve got some strange behaviour with my Fibaro Dimmer 2: I’ve connected the Dimmer 2 as described, The dimmer works perfectly. I can dim, turn the lights on or off, no problems at all from Homey.

he problem is with the wall switch (connected to SX & S1): When I push the wall switch, the lights go on. When I push it again, the lights stay on. Nothing happens. The only way to put the lights of, is through the app… Then if I touch the wall switch again, it turns on.

So I went searching and people tell me to try changing parameter 20. But it looks like Homey doesn’t really change the parameter. When I read it out with another device, the parameter is still on the old version. Why doesn’t Homey save the configuration? And does anyone understand my problem with Fibaro?

Kinda curious with what you use to read out the dimmer 2’s parameter, as the dimmer 2 can only be connected to 1 controller, if you connect it (temporarily) to another one then you reset the dimmer to its factory defaults.

But to answer the question I need more information like
what kind of switch is connected to the S1 input?
what did you do to change the parameter, just changed the setting “switch type” in the dimmer 2’s advanced settings, or tried to do it with a other means?

Hi,

Thank you for your response! I didn’t know that it will reset if you connect it to another device. So in that case: I’m not sure if it saves its confiruation or not.

However, I have tried a monetary switch and a normal switch, both with the same result. I changed the “switch type” in the advanced settings, but it doesn’t work. I tried some other settings, like the soft start, etc, but also that doesn’t work. If I disable the soft start, it still stoft starts, so that was the start for me thinking it doesn’t write the config.

Some brands do keep the settings after removal and pairing, but fibaro (and most other brands) do not for most settings.

But then it leaves it to 3 options,
you try to change it from a big distance, with not much other zwave devices that can relay the signal, but as you mention that it does switch switch the output consistently from Homey that isn’t very likely.
It probably is more the issue that you either didn’t connect it properly, or you dimmer 2 is just broken.
As the default value is momentary, if it doesn’t work from the start with a momentary switch, it isn’t a parameter thing at all.

Hi,

  • Homey and the Fibaro Dimmer are about 1.5 meters from eachother. Distance is not the issue.
  • I’ve replaced it with 2 other dimmers, same problems, so the dimmer is not broken.
  • Installing is not very difficult… And everything works, except it does a bit strange with the buttons. When not installed properly, I wouldn’t have light at all, or other problems.

Well, then it beats me what is up, it isn’t a software issue, as the default settings don’t need to be changed if you attached a momentary switch, not a hardware issue as you state it is connected properly, then there is nothing left other then a glitch in the matrix.

When you change the parameter 20, do you get a confirmation (text in green field) that the parameter is changed? And you used the Confirm sign on the right top ?
image

@JPe4619 Yes and yes

@Caseda Well that is why I’m opening this topic. Got my other house full of this Dimmers and no problems at all. So figuring out what is different here… The strange thing is that it works almost perfectly, I just can’t turn the lights off with the switch. I can turn them on, I can use the app, I can dim it without any problems. Perfect system. It’s just the turning of with the button.

All “normal” questions are already asked, so only “stupid” questions remain.
Maybe you can show your Advanced settings, just to check if nothing is overseen?

And maybe post a photo of the wiring… maybe we can make suggestions on that? Otherwise most stuff has been asked and answered.

You mention a different system to see if parameter 20 has been set, I don’t know what that is but does it work on that system?

Yes, I will reinstall it tomorrow. I’ve placed the original situation back yesterday, but I will reinstall it and make pictures, that’s a good idea.

The different system is Domoticz, but I just understand that by reconnecting it, it will factory reset. However: Domoticz is also unavailable of setting the parameter 20. I can save the configuration a 100 times, if I read out the current configuration a couple of minutes later, it is still on the wrong switch and settings.

MENU mode & visual indications:
FIBARO Dimmer 2 has a MENU with each position indicated by the
specified LED indicator colour. In order to enter the menu press the
B-button and hold for at least 2 seconds. While the B-button is still
pressed, LED indicator colour will change in the following sequence:
BLUE - initiate the load calibration procedure (see „Calibration” on
page 15)
RED - load calibration procedure with FIBARO Bypass 2 (see „Calibration”
on page 15)
WHITE - activate turning the load on/off using the B-button
GREEN - reset the energy consumption data memory (see „Power and
energy consumption measurement” on page 16)
VIOLET - initiate the Z-Wave network range test (see „Z-Wave range
test” on page 18)
YELLOW - reset the FIBARO Dimmer 2 to factory defaults
Release the B-button to choose the desired function and confirm your
choice with the B-button click.