Can't add any device to my Homey Pro 2023, strange app report: 'Invalid header value char'

Hey, I received my new Homey pro recently, but I can’t use it at all, because I can’t add any device to it. If I click any app, and add new divece than conntect, I get this message: “No new devices have been found”. I think it’s a general problem, because I tried with different devices (Ecowitt weather station and myIO smart home system). I contacted one app developer (myIO) and I sent him the app report, which was the following, but he had no idea what the problem could be:

App ID
App Version
Homey Version
Stack Trace
Note: this log has been manually submitted by a user.
Log ID: 2239f71c-8002-48a9-8fc4-3444226c9207
User Message:
can’t add new device
reason: ‘Invalid header value char’,
2023-06-25T22:23:55.613Z [log] [myIO_App] HTTP request error Error: Parse Error: Invalid header value char
at Socket.socketOnData (node:_http_client:542:22)
at Socket.emit (node:events:513:28)
at addChunk (node:internal/streams/readable:324:12)
at readableAddChunk (node:internal/streams/readable:297:9)
at Readable.push (node:internal/streams/readable:234:10)
at TCP.onStreamRead (node:internal/stream_base_commons:190:23) {
bytesParsed: 46,
reason: ‘Invalid header value char’,

Could anyone help with this problem? Is this ‘Invalid header value char’ familiar to anyone? I tried everything, same wifi network, no strange characters in any name, password etc…

This looks like a local networking issue. Perhaps you’re using something like PiHole or AdGuard? Some sort of filtering proxy? A firewall?

Also, the firmware of your Homey is lagging a few versions, make sure it’s running the latest version.

Thank you for your idea, it took me a few days to get a new, clean router, with factory settings to check, if it’s a local network issue… but nothing has changed, the problem still exist… So I don’t think it’s my local network… I don’t have proxy, firewall etc. I even updated my Homey too as you suggested. I attach some screenshots. As you can see I could add a “device” actually, which is a wake on lan app isntalled on Homey, but no external device.

Problem solved at myIO app…
You have to update to myIO 2.0.1.