Homey Community Forum

Cannot pair Sonos anymore

Hi there,

since I think a week or so, maybe related to a Homey update, pairing of my Sonos boxes in a flow is not possible anymore. When in a flow I use “Join the group of”, the error is “This device is not in a group”. When there is no group at all, this is clear, but then, it will never be possible to make a group…

Context by the way: I put all my Sonos boxes off at night and restart them in the morning. I even do a restart of the Sonos app before the pairing action itself. And I take some time for each box to pair.

Any clue?

Thx upfront,

Michel

And what happens if u actually joining a group of speakers?
Because that’s what the cards says. It says joining a group of speakers, not joining a speaker.

That’s the problem. It doesn’t say “Join a group of speakers”, it says ‘join the group of’… and then you have to select 1 speaker. The error that shows then after run ning it says

Off course it hasn’t on the first time.

Even if I pair two of the boxes in the Sonos-app itself, I get the same error…

Did this pairing command change lately? For I had the sam flow working before (alltough I had to restart my Sonos-app first tot make it work…)

So the card says “join a group of”
Dunno if this changed lately, not using the app meself. Am using the Sonos docker on a Synology.

For me it works absolutely flawless.
I can add one speaker with another speaker → group of 2 speakers
I can add another speaker to the group of 2 speakers → group of 3 speakers
I can remove the speaker out of the group

It could be that this card “Join the group of” also only works after restarting the app. At least I noticed that the card “Plays / Does not play” only works after a restart of the app. So if Homey is restarted, then the Sonos app must also be restarted. I have already reported this to Athom. Please report this as well.

Sonos App v.6.1.3

Hello all,

this morning I run the flow with the join actions with a delay of a few minutes. It worked! Again… Pfff.

Worth mentioning is that in the night I had to restart Homey. Couldn’t control some light switches anymore… :frowning:

So with a restarted Homney AND with a delay of 5 mins AND with a starting restart of Sonos app, it worked…

To be continued tomorrow…

Good news. For two days in a row it worked!

Thx @Rocodamelshekima and @fantross for thinking with me!

2 Likes

For me it’s already 5 days… :wink: