Cannot connecting Z-wave Neo Coolcam plug anymore

After one succesfull connection (and use) of a Neo Coolcam powerplug, i tried to connect two new devices. But No succes anymore get with both devices not Z-wave connection, the program can not find a zway device.
I have tried it in several wall sockets even within 0.5 m of the Homey, without positive result.
Can someone help me how to do it, i;m just started with the Homey. And have connected severaklikaanklikuit devices, one neocam Powerplug and the Remotec scenemaster without any problem

And you first removed them (i know sounds strange) even new plugs should sometimes removed first.

Go to settings----zwave—remove device

Are you sure you have the Z-wave version (blue rim)? There are also Wi-Fi versions, they have a grey rim…

Here is a nice topic about adding Zwave devices. For the Neo plug adding specifically: u have to hit the button 3 times . Hit it like u mean it like 3 times within 1 second!

I’ve tried to do it but no change

Yes, identical to the devices allready connected

Hold the button of the plug for more than 10 seconds, wait for the led to flash red and then it flashes purple 5 times. Then it has been reset completely.

After that pull the plug out, set Homey to insert mode and plug the plug back in. If it doesn’t start including within 5 seconds then press the button 3 times within 1-2 seconds. Of course you should do that in close vicinity of Homey as always.

If that doesn’t work then i’m out of options and suggestions besides the one that they may have changed something in the firmware again.


It works, thank you. Not following the instructions of the manual just plug the plug in after you started the procedure on Homey.