Cannot connect Netatmo smart smoke alarm

Hello all.

This is technically not a problem with Homey, or any of the apps, but I am hoping that someone here has had the same problem connecting as I have, and did find a solution. Or that the combined braintrust I have found here can help me figure out my next step.

So I want to connect a Netatmo Smart Smoke Sensor to Homey. Unfortunately, you can’t “just connect” the device like any aqara device. First you have to register the device in the Netatmo Security app, and once that is done, you can add the device to Homey by letting Homey log in to your Netatmo account.

And this is where the problems begin. I am using an iPhone. Netatmo has decided that in order for me to add my device, I MUST use apple homekit (I don’t for anything else, so this is a bit annoying). And I can manage to register the device withint homekit, but after the device is added in homekit, it should also be added in the Netatmo Security app. But the app instead gives me an error message stating “Accessory is not Netadmo manufactured”.

So I am left with the device registered in homekit, and not in the app (and there not on my netatmo account). And since it’s not present on the account, I cannot add it to Homey.

I have send a message to Netatmo support around 48 hours ago, but as of now, I have not received a reply.

Please help :slight_smile:

So this does not work?

source

Hello Peter Kawa. Thank you for taking an interest in my problem.

Yes, I have tried all steps above a total of three times (except for steps 8 and 9 since I DO own the device myself).

I just received a reply from Netatmo who also asked me if I have reset the device and tried again, so that didn’t help, but hopefully now I have started a discussion with them.

YW, foretag.

I hope Netatmo can help you out on this one!

Hello, any news from netatmo? Same problem here. The detector shows up in home but not in netatmo security. Thanks

My Netatmo smoke alarms (in Dutch rookmelders) are registered in the security app on my iPhone and also added in homey.


Hello Astrid.

I bought a total of 6 smoke detectors, and the first one I tried to install malfunctioned as mentioned above. Netatmo got back to me and offered me to order a new one on their homepage free of charge, and I would send the “defective” one back to them.

I write “defective” as while waiting for the response from netatmo, I tried to install the other 5 detectors, and all of them worked (sometimes the Netatmo security app froze during installation and I had to force kill it, but when I restarted it, the device had beed added both in the security app and in the home app). Once I had done this with 5 devices, I tried the “defective” again, and this time it worked.

Things I had done (in order) prior to installing the 5 devices (that might have helped in some way) were:

  • Removing all rooms and homes from the home app
  • Removing the home app
  • Removing security app
  • Restarting my phone
  • Installing the security app again
  • Installing the home app again (here I can’t remeber if the security app did this for me).

So my suggestion is to contact netatmo, they will probably offer the same to you, and while you are waiting for their reply, try the above mentioned steps, and if you have a second smoke detector already available, try that one instead.

I hope it will help!

Hi Andy, thanks for your reply! That smoke detector really got me. Had given up on the Netatmo app and managed to install it on the HomeKit BUT the option to set the alarms for that device simply does not show! (even though alarms are set for the HomeKit app itself), so HomeKit would not send the alarm………
By now I sent three messages on coming up problems to Netatmo, no response yet. Will try your suggestions, thanks a lot again!
Best, Astrid