Cannot connect Neo Coolcam pir

Is there a manual supplied ? Please make pictures and post so I can compare if the settings are still the same

And something else that comes to mind . I hope the Pd03 revision has a new Wave chip that’s based on FLIRS
Then the timeouts would make perfect sense

Athom aka Emile said he is not willing to implement the new zwave standard protocols to let home comply to zwave standards . Therefore devices based on the new flirs technology are non working and give timeouts all the time .

Just like the new S2 security on those new chips that they are incapable to incorporate in the buggy zwave core of homey .

Ooooh @roco I so hope these a flirs . I will give a huge party if they are :champagne:
They where warned for 3 years now and are to stubborn to implement it / aka not capable enough

1 Like

Give me a few minutes; I will scan the manual.

Peter

Manual seems to be the same as for the old one (V1).


I’ve found another manual (more recently) but it is in PDF format.
Cannot upload PDF here.

Can i send you this PDF through another channel (if you still want to have it ?)

PEter

Try the Slack channel at https://homey.community

I have been trying to get the pir to work. I do not get the timeout anymore, but the values are not updated. Also no movement is reported. Looks like the pir detects movement since the led lights up. The pir is reported as “offline, battery, unreachable”. Sending a testframe fails. It has a direct connection from Homey to pir. Not sure now what the problem is.

A few observations from my Coolcam V2 after I re-installed it yesterday evening with the updated app:

  • Although the pir detects movement Homey does not receive any indication of that.
  • Temperature is updated 8 hours ago, seems a long time.
  • The light intensity (lux) was updated 8 minutes ago, looks ok.
  • If I update a parameter, it fails after a 30s timeout.

Not sure what to next. Is this an interface issue between Homey and Coolcam? Should I return the sensor?

This is quite normal for battery operated devices.

Did you wake up the sensor just before?

Maybe it could be due to the settings, but it is rather unusual.

Did you wake up the sensor just before?

No, I did not wake up the sensor. I will give it another try when I am back home. Thanks.

@fantross : “Did you wake up the sensor just before?”

I did. Three quick pushes on the button. Then the app says that Saving was succesfull but that seems not to be the truth. After restarting the app the old values are back.

My supplier contacted me this morning after i send them a service request.
They have already contacted the programmer of the NC app to investigate the problem.

Peter

Okay, weird.
Let us wait and see.

I have also contacted my supplier and he has created a trouble ticket for the issue. Let’s see what happens. Currently I cannot use it with my Homey. To be sure I re-installed the sensor another time. Again it appears that temp and lux are reported, but movement is not reported. However I assume the sensor detects movement since the led lights up when I am in the area.

Two hours after re-installation:

Looks like only Lux is updating.

@MarcoRuiter : big question for now:

Do you think this problem is solvable or not ?
My 14 days refund period for this PIR is almost expired.
Am i gonna send it back to my supplier ?

Peter

Can only find why it’s giving a timeout when I have one of those pirs on my homey.

Maybee one of you could post the log of the zigbee when filtered on the device id
Or even run it in cli mode with debug turned on ?

Haha,
@MarcoRuiter , my supplier told me they’ve send you a new PIR V2 so you can figure it out.
So i guess that’s a feritale :wink:

I want to help but i do not know how to make the desired log; can you tell me ?

Peter

So far I did not get a magic package :package:

You can go to developers.athom.com

Then login select you’re homey and go to the zwave section and turn on logging . The. Filter on the device if the pir has and gather the log for a while . Hopefully it throws a few motion and other messages in there so I can see what it’s reporting

@MarcoRuiter ,

Below you find a part of the requested log from the Neo Coolcam PIR V2 versie NEO_PD03Z.

Also interesting is that the PIR is reported as offline (offline, battery) while it is sending movement information to Homey (so not offline ?).

I hope this will help. If i can do anything else to help, please let me know.

Peter

[2020-07-14T07:09:29.665Z] Node[17]: Received application command for COMMAND_CLASS_NOTIFICATION, data: 0x05000000ff070800

[2020-07-14T07:09:29.667Z] Node[17]: [COMMAND_CLASS_NOTIFICATION] {“V1 Alarm Type (Raw)”:{“type”:“Buffer”,“data”:[0]},“V1 Alarm Type”:0,“V1 Alarm Level (Raw)”:{“type”:“Buffer”,“data”:[0]},“V1 Alarm Level”:0,“Reserved (Raw)”:{“type”:“Buffer”,“data”:[0]},“Notification Status (Raw)”:{“type”:“Buffer”,“data”:[255]},“Notification Status”:“On”,“Notification Type (Raw)”:{“type”:“Buffer”,“data”:[7]},“Notification Type”:“Home Security”,“Event (Raw)”:{“type”:“Buffer”,“data”:[8]},“Event”:8,“Properties1 (Raw)”:{“type”:“Buffer”,“data”:[0]},“Properties1”:{“Event Parameters Length”:0,“Sequence”:false},“Event (Parsed)”:“Motion Detection, Unknown Location”}

[2020-07-14T07:10:01.141Z] Node[17]: Received application command for COMMAND_CLASS_NOTIFICATION, data: 0x05000000ff07000108

[2020-07-14T07:10:01.142Z] Node[17]: [COMMAND_CLASS_NOTIFICATION] {“V1 Alarm Type (Raw)”:{“type”:“Buffer”,“data”:[0]},“V1 Alarm Type”:0,“V1 Alarm Level (Raw)”:{“type”:“Buffer”,“data”:[0]},“V1 Alarm Level”:0,“Reserved (Raw)”:{“type”:“Buffer”,“data”:[0]},“Notification Status (Raw)”:{“type”:“Buffer”,“data”:[255]},“Notification Status”:“On”,“Notification Type (Raw)”:{“type”:“Buffer”,“data”:[7]},“Notification Type”:“Home Security”,“Event (Raw)”:{“type”:“Buffer”,“data”:[0]},“Event”:0,“Properties1 (Raw)”:{“type”:“Buffer”,“data”:[1]},“Properties1”:{“Event Parameters Length”:1,“Sequence”:false},“Event Parameter”:{“type”:“Buffer”,“data”:[8]},“Event (Parsed)”:“Event inactive”}

[2020-07-14T07:12:32.690Z] Node[17]: Received application command for COMMAND_CLASS_SENSOR_MULTILEVEL, data: 0x05030a003b

[2020-07-14T07:12:32.691Z] Node[17]: [COMMAND_CLASS_SENSOR_MULTILEVEL] {“Sensor Type (Raw)”:{“type”:“Buffer”,“data”:[3]},“Sensor Type”:“Luminance (version 1)”,“Level (Raw)”:{“type”:“Buffer”,“data”:[10]},“Level”:{“Size”:2,“Scale”:1,“Precision”:0},“Sensor Value”:{“type”:“Buffer”,“data”:[0,59]},“Sensor Value (Parsed)”:59}

[2020-07-14T07:12:52.588Z] Node[17]: Received application command for COMMAND_CLASS_NOTIFICATION, data: 0x05000000ff070800

[2020-07-14T07:12:52.590Z] Node[17]: [COMMAND_CLASS_NOTIFICATION] {“V1 Alarm Type (Raw)”:{“type”:“Buffer”,“data”:[0]},“V1 Alarm Type”:0,“V1 Alarm Level (Raw)”:{“type”:“Buffer”,“data”:[0]},“V1 Alarm Level”:0,“Reserved (Raw)”:{“type”:“Buffer”,“data”:[0]},“Notification Status (Raw)”:{“type”:“Buffer”,“data”:[255]},“Notification Status”:“On”,“Notification Type (Raw)”:{“type”:“Buffer”,“data”:[7]},“Notification Type”:“Home Security”,“Event (Raw)”:{“type”:“Buffer”,“data”:[8]},“Event”:8,“Properties1 (Raw)”:{“type”:“Buffer”,“data”:[0]},“Properties1”:{“Event Parameters Length”:0,“Sequence”:false},“Event (Parsed)”:“Motion Detection, Unknown Location”}

I have been away for the last 3 days. The device has been running during this time and I thought it would be good to share by experiences:

  • The motion detection does not seem to work at all. It indicates that the last motion was detected 4 days ago, that’s exactly when I re-installed it the last time.
  • The interval when the temperature is reported is extremely long. For instance now it states that it has been reported 1 day ago.
  • The light intensity is the only one that seems to work. The interval is pretty short, now it is 14 minutes ago.

The above behavior for the for temp/Lux is also shown in the ‘insights’. Temp almost never updated, Lux pretty much follows the daylight (which is expected).

I also just tried to update a parameter. That seems to work. If I change one of the values and save it, it states that the actual updates will be made during the following wake-up. When I force that by pressing the button, the value is updated.

My supplier told me that there would be a new app during this week. However he also requested me to prepare a return in case it will not solve the problem. Not sure what the actual status is now

Below I also share a part of the logfile:

2020-07-14T13:50:36.266Z Node[19]: Received application command for COMMAND_CLASS_SENSOR_MULTILEVEL, data: 0x05030a008e
2020-07-14T13:50:36.267Z Node[19]: [COMMAND_CLASS_SENSOR_MULTILEVEL] {“Sensor Type (Raw)”:{“type”:“Buffer”,“data”:[3]},“Sensor Type”:“Luminance (version 1)”,“Level (Raw)”:{“type”:“Buffer”,“data”:[10]},“Level”:{“Size”:2,“Scale”:1,“Precision”:0},“Sensor Value”:{“type”:“Buffer”,“data”:[0,142]},“Sensor Value (Parsed)”:142}
2020-07-14T13:52:35.876Z Node[19]: Received application command for COMMAND_CLASS_NOTIFICATION, data: 0x05000000ff070800
2020-07-14T13:52:35.878Z Node[19]: [COMMAND_CLASS_NOTIFICATION] {“V1 Alarm Type (Raw)”:{“type”:“Buffer”,“data”:[0]},“V1 Alarm Type”:0,“V1 Alarm Level (Raw)”:{“type”:“Buffer”,“data”:[0]},“V1 Alarm Level”:0,“Reserved (Raw)”:{“type”:“Buffer”,“data”:[0]},“Notification Status (Raw)”:{“type”:“Buffer”,“data”:[255]},“Notification Status”:“On”,“Notification Type (Raw)”:{“type”:“Buffer”,“data”:[7]},“Notification Type”:“Home Security”,“Event (Raw)”:{“type”:“Buffer”,“data”:[8]},“Event”:8,“Properties1 (Raw)”:{“type”:“Buffer”,“data”:[0]},“Properties1”:{“Event Parameters Length”:0,“Sequence”:false},“Event (Parsed)”:“Motion Detection, Unknown Location”}
2020-07-14T13:53:07.568Z Node[19]: Received application command for COMMAND_CLASS_NOTIFICATION, data: 0x05000000ff07000108
2020-07-14T13:53:07.569Z Node[19]: [COMMAND_CLASS_NOTIFICATION] {“V1 Alarm Type (Raw)”:{“type”:“Buffer”,“data”:[0]},“V1 Alarm Type”:0,“V1 Alarm Level (Raw)”:{“type”:“Buffer”,“data”:[0]},“V1 Alarm Level”:0,“Reserved (Raw)”:{“type”:“Buffer”,“data”:[0]},“Notification Status (Raw)”:{“type”:“Buffer”,“data”:[255]},“Notification Status”:“On”,“Notification Type (Raw)”:{“type”:“Buffer”,“data”:[7]},“Notification Type”:“Home Security”,“Event (Raw)”:{“type”:“Buffer”,“data”:[0]},“Event”:0,“Properties1 (Raw)”:{“type”:“Buffer”,“data”:[1]},“Properties1”:{“Event Parameters Length”:1,“Sequence”:false},“Event Parameter”:{“type”:“Buffer”,“data”:[8]},“Event (Parsed)”:“Event inactive”}
2020-07-14T13:54:51.763Z Node[19]: Received application command for COMMAND_CLASS_NOTIFICATION, data: 0x05000000ff070800
2020-07-14T13:54:51.764Z Node[19]: [COMMAND_CLASS_NOTIFICATION] {“V1 Alarm Type (Raw)”:{“type”:“Buffer”,“data”:[0]},“V1 Alarm Type”:0,“V1 Alarm Level (Raw)”:{“type”:“Buffer”,“data”:[0]},“V1 Alarm Level”:0,“Reserved (Raw)”:{“type”:“Buffer”,“data”:[0]},“Notification Status (Raw)”:{“type”:“Buffer”,“data”:[255]},“Notification Status”:“On”,“Notification Type (Raw)”:{“type”:“Buffer”,“data”:[7]},“Notification Type”:“Home Security”,“Event (Raw)”:{“type”:“Buffer”,“data”:[8]},“Event”:8,“Properties1 (Raw)”:{“type”:“Buffer”,“data”:[0]},“Properties1”:{“Event Parameters Length”:0,“Sequence”:false},“Event (Parsed)”:“Motion Detection, Unknown Location”}
2020-07-14T13:55:46.974Z Node[19]: Received application command for COMMAND_CLASS_NOTIFICATION, data: 0x05000000ff07000108
2020-07-14T13:55:46.975Z Node[19]: [COMMAND_CLASS_NOTIFICATION] {“V1 Alarm Type (Raw)”:{“type”:“Buffer”,“data”:[0]},“V1 Alarm Type”:0,“V1 Alarm Level (Raw)”:{“type”:“Buffer”,“data”:[0]},“V1 Alarm Level”:0,“Reserved (Raw)”:{“type”:“Buffer”,“data”:[0]},“Notification Status (Raw)”:{“type”:“Buffer”,“data”:[255]},“Notification Status”:“On”,“Notification Type (Raw)”:{“type”:“Buffer”,“data”:[7]},“Notification Type”:“Home Security”,“Event (Raw)”:{“type”:“Buffer”,“data”:[0]},“Event”:0,“Properties1 (Raw)”:{“type”:“Buffer”,“data”:[1]},“Properties1”:{“Event Parameters Length”:1,“Sequence”:false},“Event Parameter”:{“type”:“Buffer”,“data”:[8]},“Event (Parsed)”:“Event inactive”}
2020-07-14T14:03:55.054Z Node[19]: Received application command for COMMAND_CLASS_SENSOR_MULTILEVEL, data: 0x05030a0050
2020-07-14T14:03:55.055Z Node[19]: [COMMAND_CLASS_SENSOR_MULTILEVEL] {“Sensor Type (Raw)”:{“type”:“Buffer”,“data”:[3]},“Sensor Type”:“Luminance (version 1)”,“Level (Raw)”:{“type”:“Buffer”,“data”:[10]},“Level”:{“Size”:2,“Scale”:1,“Precision”:0},“Sensor Value”:{“type”:“Buffer”,“data”:[0,80]},“Sensor Value (Parsed)”:80}
2020-07-14T14:12:59.271Z Node[19]: Received application command for COMMAND_CLASS_SENSOR_MULTILEVEL, data: 0x05030a008c
2020-07-14T14:12:59.272Z Node[19]: [COMMAND_CLASS_SENSOR_MULTILEVEL] {“Sensor Type (Raw)”:{“type”:“Buffer”,“data”:[3]},“Sensor Type”:“Luminance (version 1)”,“Level (Raw)”:{“type”:“Buffer”,“data”:[10]},“Level”:{“Size”:2,“Scale”:1,“Precision”:0},“Sensor Value”:{“type”:“Buffer”,“data”:[0,140]},“Sensor Value (Parsed)”:140}
2020-07-14T14:13:43.043Z Node[19]: Received application command for COMMAND_CLASS_NOTIFICATION, data: 0x05000000ff070800
2020-07-14T14:13:43.044Z Node[19]: [COMMAND_CLASS_NOTIFICATION] {“V1 Alarm Type (Raw)”:{“type”:“Buffer”,“data”:[0]},“V1 Alarm Type”:0,“V1 Alarm Level (Raw)”:{“type”:“Buffer”,“data”:[0]},“V1 Alarm Level”:0,“Reserved (Raw)”:{“type”:“Buffer”,“data”:[0]},“Notification Status (Raw)”:{“type”:“Buffer”,“data”:[255]},“Notification Status”:“On”,“Notification Type (Raw)”:{“type”:“Buffer”,“data”:[7]},“Notification Type”:“Home Security”,“Event (Raw)”:{“type”:“Buffer”,“data”:[8]},“Event”:8,“Properties1 (Raw)”:{“type”:“Buffer”,“data”:[0]},“Properties1”:{“Event Parameters Length”:0,“Sequence”:false},“Event (Parsed)”:“Motion Detection, Unknown Location”}
2020-07-14T14:15:13.978Z Node[19]: Received application command for COMMAND_CLASS_NOTIFICATION, data: 0x05000000ff07000108
2020-07-14T14:15:13.979Z Node[19]: [COMMAND_CLASS_NOTIFICATION] {“V1 Alarm Type (Raw)”:{“type”:“Buffer”,“data”:[0]},“V1 Alarm Type”:0,“V1 Alarm Level (Raw)”:{“type”:“Buffer”,“data”:[0]},“V1 Alarm Level”:0,“Reserved (Raw)”:{“type”:“Buffer”,“data”:[0]},“Notification Status (Raw)”:{“type”:“Buffer”,“data”:[255]},“Notification Status”:“On”,“Notification Type (Raw)”:{“type”:“Buffer”,“data”:[7]},“Notification Type”:“Home Security”,“Event (Raw)”:{“type”:“Buffer”,“data”:[0]},“Event”:0,“Properties1 (Raw)”:{“type”:“Buffer”,“data”:[1]},“Properties1”:{“Event Parameters Length”:1,“Sequence”:false},“Event Parameter”:{“type”:“Buffer”,“data”:[8]},“Event (Parsed)”:“Event inactive”}
2020-07-14T14:41:52.950Z Node[19]: Received application command for COMMAND_CLASS_NOTIFICATION, data: 0x05000000ff070800
2020-07-14T14:41:52.952Z Node[19]: [COMMAND_CLASS_NOTIFICATION] {“V1 Alarm Type (Raw)”:{“type”:“Buffer”,“data”:[0]},“V1 Alarm Type”:0,“V1 Alarm Level (Raw)”:{“type”:“Buffer”,“data”:[0]},“V1 Alarm Level”:0,“Reserved (Raw)”:{“type”:“Buffer”,“data”:[0]},“Notification Status (Raw)”:{“type”:“Buffer”,“data”:[255]},“Notification Status”:“On”,“Notification Type (Raw)”:{“type”:“Buffer”,“data”:[7]},“Notification Type”:“Home Security”,“Event (Raw)”:{“type”:“Buffer”,“data”:[8]},“Event”:8,“Properties1 (Raw)”:{“type”:“Buffer”,“data”:[0]},“Properties1”:{“Event Parameters Length”:0,“Sequence”:false},“Event (Parsed)”:“Motion Detection, Unknown Location”}
2020-07-14T14:43:07.711Z Node[19]: Received application command for COMMAND_CLASS_NOTIFICATION, data: 0x05000000ff07000108
2020-07-14T14:43:07.712Z Node[19]: [COMMAND_CLASS_NOTIFICATION] {“V1 Alarm Type (Raw)”:{“type”:“Buffer”,“data”:[0]},“V1 Alarm Type”:0,“V1 Alarm Level (Raw)”:{“type”:“Buffer”,“data”:[0]},“V1 Alarm Level”:0,“Reserved (Raw)”:{“type”:“Buffer”,“data”:[0]},“Notification Status (Raw)”:{“type”:“Buffer”,“data”:[255]},“Notification Status”:“On”,“Notification Type (Raw)”:{“type”:“Buffer”,“data”:[7]},“Notification Type”:“Home Security”,“Event (Raw)”:{“type”:“Buffer”,“data”:[0]},“Event”:0,“Properties1 (Raw)”:{“type”:“Buffer”,“data”:[1]},“Properties1”:{“Event Parameters Length”:1,“Sequence”:false},“Event Parameter”:{“type”:“Buffer”,“data”:[8]},“Event (Parsed)”:“Event inactive”}