Cannot connect Neo Coolcam pir

Thanks for the quick answer and possible solution. What is the root cause of the issue. Just curious, did I receive a newer version of the sensor which is not part of the app yet? I am pretty new to Homey. How do I install the app from the community appstore? Can you point me to the procedure. So far I also installed apps fro the official appstore.

Yes you received a new revision :champagne:


1 Like

Interesting. Do you know the difference?
I ordered 4 pieces on 12.05. in the original NEO Coolcam Shop (AliExpress) and received them about a week ago.
These have the following identification:

There is a test version available, made by Marco ofc! Please take note of the warning before u install test versions in common.
What’s new in v2.1.5

• Added newly reported device ID for Motion Sensor V2. • Added MultiChannelAss for 3 way switch. • Added test base for new Doorsensor V2. • Updated MeshDriver.

Just tried the new version. It now recognizes my pir V2. However straight after installation is completed the app gives a time out. What could this be?

Looks like the AppStore did not add all of the mesh driver . Hold up I will need to upload a new version

2.1.6 is published under the test link . This one should work :crossed_fingers:


Thanks, looks good now. Will play with it further now.

1 Like

Received also a new NC V2 today.
Same problem as @Henk_Stap with SKU: NEO_PD03Z.

Downloaded the new APP (2.1.6) but mine isn’t even detecting now.
Lux and temp are reporterd, but no detection of movement (the detection is set to on).


Time-outs point to a problem with the pir and communications with homey zwave chip. Doesn’t look app related.

You could do a re-pair . Don’t forget unpair the pir . Do the reset to default procedure on the pir like it tells you to in the manual . To be fully sure reboot homey and after 10 minutes pair the pir again. With this procedure we would have taken most problems that could happen into account

Is there a manual supplied ? Please make pictures and post so I can compare if the settings are still the same

And something else that comes to mind . I hope the Pd03 revision has a new Wave chip that’s based on FLIRS
Then the timeouts would make perfect sense

Athom aka Emile said he is not willing to implement the new zwave standard protocols to let home comply to zwave standards . Therefore devices based on the new flirs technology are non working and give timeouts all the time .

Just like the new S2 security on those new chips that they are incapable to incorporate in the buggy zwave core of homey .

Ooooh @roco I so hope these a flirs . I will give a huge party if they are :champagne:
They where warned for 3 years now and are to stubborn to implement it / aka not capable enough

1 Like

Give me a few minutes; I will scan the manual.


Manual seems to be the same as for the old one (V1).

I’ve found another manual (more recently) but it is in PDF format.
Cannot upload PDF here.

Can i send you this PDF through another channel (if you still want to have it ?)


Try the Slack channel at

I have been trying to get the pir to work. I do not get the timeout anymore, but the values are not updated. Also no movement is reported. Looks like the pir detects movement since the led lights up. The pir is reported as “offline, battery, unreachable”. Sending a testframe fails. It has a direct connection from Homey to pir. Not sure now what the problem is.

A few observations from my Coolcam V2 after I re-installed it yesterday evening with the updated app:

  • Although the pir detects movement Homey does not receive any indication of that.
  • Temperature is updated 8 hours ago, seems a long time.
  • The light intensity (lux) was updated 8 minutes ago, looks ok.
  • If I update a parameter, it fails after a 30s timeout.

Not sure what to next. Is this an interface issue between Homey and Coolcam? Should I return the sensor?