Bug in combination of Vthermo + Homey Heating Scheduler?

I use the VThermo App by @balmli with the Homey Heating Schedule App by @Markus to control my house heating.

The main flow checks every 15 minutes if one or more VThermo’s are switched ON:
Here, one of the VThermo’s is in ON state:

However, if I execute the flow manually, all the AND conditions are false!

I checked the setting of the VThermo’s. No delay / changed hysteresis or other modifications. They do switch state from Blue to Black and Red, indicating the status.

If I manually increase the temperature of the VThermo to an extreme value - say to 28 degrees - the flow does work; the VThermo is seen as ON and the flow triggers the heating.


You can check the state from https://developer.athom.com/tools/devices

Search for the VThermo, and look at the vt_onoff - capability.

The VThermo switches if the temperature is outside the hysteresis area. So, the color can be red even if the termostat is cooling down, and vice versa. Check the vt_onoff - capability :slight_smile:

Thanks for the reply!

So, if the hysteresis is set to zero, only the interval time between measuring the setpoint versus measured is a variable?

Is it possible to make the visual state and the capability state match better?

The ‘lag’ happens with both switching ON, and OFF.

The vt_onoff - capability is correct.

The visual indication for the thermostat in the mobile app, black/blue/red, does not reflect this state. Nothing I can do about this… and it doesn’t matter much…

I think it would be better for you to use “Thermostat turned on” and “Thermostat turned off” - triggers., than updating every 15 minutes.

Don’t think setting the hysteresis to zero is good. Then the VThermos will switch too often…

1 Like

I agree, but I have different rooms that need to be checked and two different heaters. But, good point! I will think about a different approach!

I will correct the hysteresis to the standard setting!

Thanks for your explanation!

1 Like

One more question :sweat_smile:

If I check the developer settings, I see that the setpoint is higher than the measured temperature, but the capability is still ‘false’. When will it switch to True?

When the diff is larger than the hysteresis it will trigger…

And here I guess you have hysteresis = 0.5.

1 Like