[Archived][APP][Pro] OpenWeatherMap

Who do you think I am, Piet Paulusma? :stuck_out_tongue_winking_eye:

Joking aside, yes, that looks normal. Values are only udated when they have actually changed.

I could/might change this behavior and update all values at each polling interval… On the other hand this may be a bit misleading and suggest the data is more accurate than it really is :thinking:

One of these days I’ll look at the lacking icons…

Hello Piet :roll_eyes: your fired!
Okay, clear, sounds logic.
But the “current weather” app is almost not updating.
That sounds not oke

Fired for the second time this week :wink:

If the (current) temperature graph looks a bit like the screenshot below, I think it’s ‘normal’ behavior. Sometimes the temperature doesn’t change for hours according to the OWM data.

image

FYI, the OpenWeatherMap app is affected by a bug in Homey core. When you add several weather sensors using the same OWM ‘device’, the first device may stop updating, or when restarting, the first device may continue while the second device stops updating.

The bug is tracked here: https://github.com/athombv/homey-apps-sdk-issues/issues/50.

I also have some issues with new icons that do not display properly. With a bit of luck this will be sorted out later this week. When the icons are sorted out I will see if I’ll rewrite the app to use the setInterval function instead of cron to avoid the bug mentioned above.

2 Likes

I see the problem of having more than one device and only one updates which i wanted to post about is already being handled :). if first thought it was because i used the same api key for current and forecast , so i made another api key. But whichever i update/save settings last will keeps working, the other one stops :slight_smile:
But what do you mean by using the “same” OWM device, I have a current weather and a forecast device added is that still the same device ? besides this issue nice app!

Yesterday the icon issue was fixed :partying_face:

I have submitted an update with icons for capabilities that didn’t have any. I have also removed a bunch of (duplicate) capabilities in the mobile interface.

Finally I have replaced cron with setInterval to avoid the (Homey) bug which caused ‘devices’ to stop updating.

The update can be installed through the cli right away from https://github.com/abaretta/nu.baretta.openweathermap/, and it will appear in the appstore as soon as Athom approves the update (early next week with a bit of luck).

3 Likes

The app is working Very Nice at the moment.
I do miss the UV value.
Will this be added in the future?

Good to hear the app is working well :+1:

The UV index is not part of the free API, it requires a paid subscription (quite expensive, from $470p/m and more :grimacing:). Like most users I don’t have a supscription, so I have no plans to add it to the app.

Thanks, clear!

I’m trying to setup this app, but don’t get it to work. I created several API keys on openweathermap but the app is constantly saying ‘Could not find that PairSession’.

I just enter the name of the api key as the name and then the API key as it appears on OWM. And the location ‘city, NL’ which is recognized online by OWM.

Am I doing something wrong?

Hi Paul,

I am guessing you manually entered a location? It seems OWM returns the ‘pairing’ error when it can’t find the location.

Can you try adding a device without entering a location? So do not enter a City/countrycode or zipcode.

The app will then use Homey’s longitude/latitude which OWM will match to the nearest location it has data for this should always return data (provided a valid API key is entered).

Note that a single API key is sufficient for hundreds of sensors, as it allows polling the API every second, and app only polls every 10, 15 or 30 minutes (depending on wchich table you poll).

@anne Thank you! Yes, that is it. When I leave the location empty, it populates the data!

@anne, except the multiday forecast doesn’t work. The field where to enter the number of days also mentions ‘3 hour interval’ instead of number of days. Current weather and 3 hour interval weather works fine.

Hi Paul,

The 16-day forecast works for me, although I did spot a typo in the settings, it does indeed say ‘3-hour interval’ instead of ‘1 day’. However, this does not affect the working of the 16-forecast.

I have updated the app, I’ll submit it to the store once I have made some V2 screenshots to add to the Readme. The update can be installed right now using the CLI install method.

What exactly have you tried with the 16-day forecast that doesn’t work?

Hi Anne, I have just added it just like the current and 3 hour forecast. I figures it was probably a typo, so in the settings I have entered ‘1’ for tomorrows forecast. I left the location data blank. After adding it, there is no data populated (also not after a few days). On the settings page under location it says ‘…pending data first’. When adding the location manually, exactly as how the other apps have found it, it also doesn’t work.

@anne

I tried to install your app instead of weather underground which is no longer working. Unfortunately, I keep getting this error:
2019-03-26_15-21-08

Is this because WU already used the same object?

I already rebooted homey, logout/login, no succes. Any suggestions?

Hi Ruud,

Are you still on Homey V1 (1.5.13 for instance)? If so, I guess it means the latest OpenWeatherMap version is no longer compatible with V1. I can’t test that, as I only have 1 Homey which is on V2.

If this is the case, you can manually (via the CLI method, see the link earlier in the thread) install an older version which will work on Homey V1.

Yes @Anne, you are correct; still on 1.5.latest. Planning to stay this way for the next months…
I will try the CLI method you suggested, thanks!

Eh… where do I find older versions of your app??

I forgot; tried to install that CLI thing before… Not working, I simply get the program is being blocked by some group policy. Shit! @#%$@@! Windows

Hi Ruud,

If you DM me the emailadres of your Athom account, I can make the last version that (should) work with V1 available to you as an alpha version. You can then install it directly from the appstore.