Aqara & Xiaomi Smart Home - Zigbee App (v1.4.1 - TEST: v1.4.2)

You could try work with a countdown timer.
If the min value of the sensor is 60sec. I would start the timer for 90sec, because if you would walk back on the 60 sec, the light may go off (if the sensor didn’t see you already), now the sensor had 30 sec to spot you again :slight_smile:

Try to re-add them without removing them, it will tell you upon add it’s duplicated device but the error state may disappear. Had this issue before on version prior to v4.

How many zigbee devices you have? When i reach more than 20 this often happens to me too.

Currently 24 had 28 before with 2 Ikea plugs as a routers. Do you have all zigbee devices unavailable, or only Aqara models?

Hi Daniel_S

Sorry for going off topic … How did you include those nice tags to the tiles?

Only Aqara app devices were not working. Other or generic zigbee ok. So I linked this problem to Aqara app.

@Gas thank you for sending the link; didn’t see this comment (in this thread) yet.
So it appears that indeed the device behavior can be controlled.

  • Multiple options per button is controlled by setting a specific attribute: endpoint.write('aqaraOpple', {'mode': 1}, {manufacturerCode: 0x115f});
  • Preventing “hostile take-over” of other Zigbee devices is controlled by defining the right Group(s)

Unfortunately, both options to control these devices are not implemented in Homey’s current Zigbee Core… Manufacturer specific attributes not (also needed to e.g. control the Aqara Curtains direction), nor does defining Groups…

I will, once more (see comment on Aqara Curtains), check if there is a work around; but don’t get your hopes too high… likely will be one for the Zigbee rewrite.

1 Like

Just use your google keyboard emotikons in mobile.

1 Like

Thanks Daniel!!!

Thanks so much for your work on this app and continuing to look into these switches, even though they’re proving so much trouble. I/we really appreciate it.

Do you mean the multiple-options-per-button feature will have to wait for the Zigbee rewrite, or support of the switch altogether?

As far as the “hostile take-over” behavior - could that be circumvented by not having any Zigbee bulbs connected to mains during the pairing process?

This is not possible because the App highlights all existing sensors w/ red exclamation mark

Has to be an error w/ the App, maybe Athom can investigate this, will report to

them.

Well as mentioned I will report to Athom but am not the first nor the only one. Seems to be a serious memory leak in v4.x.

https://athomcommunity.slack.com/archives/C04E9KJAD/p1583409531388200

@TedTolboom
Im very sorry to say, it only looks like its the Aqara that dosen`t initialize correctly, all are with a red exclamation mark and not sends data back to Homey.
Sometimes motionsensors work, sometimes not, door/window sensors the same, temp sensors does not work at all.
Fun thing, problem occured after update to ver. 4, all other works fine.
No memory leak either:

Only 19 apps installed

Hue works, but through Hue bridge
Ikea also works, directly with Homey

How many Zigbee devices do you have? Sounds like you might be reaching the hardware limit.

@robertklep only 17 Aqara, rest is acting as routers, 3 Hue and 5 Ikea.
Should`nt be a problem, and has not been problem before, nothing changed the last 6 months.
But, very good idea :blush:

And magic suddenly appeared :partying_face::partying_face::partying_face:

Did you do anything special? My got fixed somehow too, but when I reset homey the problem got back. Try it :slight_smile:

Lets see tomorrow when it restarts, i`m not confident

Since a few days, i think the update to v0.80 (can also be homey v4.0) my aquara sensors don’t work anymore. After a reset it works for a little bit and then drops out again. before the update this was not the case please check .

sensors used:
aqara temperature and hummidity sensor
door window sensor 2X

I also got problem, night between thursday and friday, one and a half week ago. Suddenly many of my Xiaomi-devices stopped workning (motion, temp, wallbuttons). Came suddenly with no config-changes. What I could see, no updates of FW, no update of app in the near time. Looking at developer-web, i could see that they were present but had no connection with “0” (Homey). Just hanging loose. All devices that worked were directly connected to Homey, none via routers, as they were before. Pushed button on device, restarted Homey many times, restarted app, power down Homey and pull the plug for an hour, started again. No change. Waited some days, tested again.
Then I tried to add them as “new” device. Started add procedure, took some really long time during adding, and the got message “status.duplicate_device”. After this, they worked again! Now, they had connected via router. Everything intact, all flows worked again. Have been working since then.
So my conclution was ZigBee, and to maný direct connected devices. I have 38 ZigBee-devices in total, but all IKEA via IKEA GW, and all Hue via Hue Bridge, so left directly connected to Homey 19 (mostly Xiaomi). I have earlier had problems when passing 14 direct connected, and that was how many that worked this time aswell. Some people talk about 20 as max directly connected, but for mee it seems to be 14.
So, now, after “re-adding” them, still 14 direct connected, and 5 via routers (and IKEA and Hue in separate ZigBee-networks).
All is working fine now, but I will not add any mor for a while. Hopefully ZigBee rewrite is coming…
Still confused why suddenly over a night 5 units decided not to go via routers anymore, and resulted in “hanging loose”, not working…