Aqara B1 Curtain Controllers on a U track

I’m about to go crazy after trying to mount and connect my curtain rails for a few weeks (!) now. (I don’t have much spare time). The main issue is probably that I have a U-shaped track, i.e. two 90-degree bends.

The “locomotive” of the train that carries the curtain gets stuck.
I thought the main issue was to get the tracks properly connected to the corner-pieces without any gaps, but after spending A LOT of time fine tuning this with distances behind the mounting brackets, turning the whole track to mirroring positions to make the belt joint run on the inside of the turn instead of the outside etc.

But now everything is as good alined as it can be and it still gets stuck. Normally you can pull the locomotives back and forth with only some resistance, but right now the two locomotives are not in the corners and still feel totally stuck. The locomotive where the belt joint is, also feels very tens, as if the belt was slightly too short for the track suddenly. This has happened before and I don’t really know how I have got it loose again.
Does anyone have experience of getting the curtain locomotive stuck?
I thought this was only a problem with the hardware, but now I’m suspecting that there is something else wrong. For example, in the app, there are two arrows to controle the curtain. The circle between them is some kind of stop button, but what does it mean when it’s white versus black?

Sorry for the confused tone, but I’m really frustrated and don’t know what to ask for because I don’t know what is wrong!!!

Thankful for any help

No need to go crazy on this; let’s see if we can find a solution.
Which type of curtain controller are you using on the tracks?
When the curtain controller is connected to the tracks, can you:

  1. remove it from Homey
  2. Factory reset the curtain controller: for the “old” Aqara controller, use the following instruction:
  3. Wait for the reset to be completed; the controller will start searching the the end states of the track
  4. Once completed, re-include the controller to Homey. It will remember the end states from the reset

On you question about the middle button of the tennary controls; the white button is indicating the active state. Once the up or down button has been pressed and the controller locomotive is moving, they will be active (white), once the track has been stopped (by reaching the end states or by user intervention) the middel button will turn white indicating the idle state.

Thank you for trying to help me!
I am using Aqara B1 Curtain Controllers. One in each end of the track. The track is approximately 2+4+2 meters, with the two 90-degree corners where the pluses are.
I have now removed the Aqara B1 devices in the app and reconnected them using the reset button. (If I try to reset without removing the device it only tells me that it has left the network and that I need to remove and re-pair.) When I open one of them the graphic looks like the curtain is fully closed and when I open the other device it looks like they’re fully opened. In reality they are half way.
Pushing the arrow up (opening), the motor tries to open and it looks like it tries to pull, but something is stuck, so it doesn’t sound good. If I push the arrow down nothing happens. Trying to move either of the locomotives still feels totally stuck and like the belt somehow is “too short” or too “tight” for the track. But earlier, I was able to run the locomotives both manually and by motor, it just got stuck in the corners. So I don’t get it…

One in each end of the track is not needed; only one controller per track.

Oh no!! Only one motor or only one device as controller in the app?

You only need to install one Aqara curtain controller per track (at either one of the sides); even if the curtains are opening not to one side but to both sides (opening in the middle).
So don’t install two curtain controllers on one track; they likely counteract each other.

Aha, that’s probably what happened when it felt stuck. They were probably pulling in the opposite directions. (Still strange that you can’t move it manually… but never mind).

So, I have unpaired one of the devices which made it all run again. BUT it only ran in one direction, and still got stuck in the corners (hardware problem). Now I have tried to make the joints in the corners even smoother and am trying to reset the controller to make it find the length of the track, because that has never worked for me.
However, for some reason the motors now refuse to pair with the app. I’ve tried both motors like 20 times now.
While writing this I thought I’d try just a last time. Then something strange happened! When pressing the reset button it beeped after 5 sec. as usuall, but then the motor started running! Unfortunately the locomotive got stuck in the corner again and the device was never paired, but this got me thinking… Is the motor supposed to start running while it is pairing?
It still refuses to pair, by the way, and is totally stuck. Maybe I should leave it alone for a while?
(I have tried restarting the app)

Again, I’m so greatful that you are helping me! I feel like I’m closer to getting it to work now at least!

Try setting it up without the curtains attached to identify your problem.
Your track should have a ‘flexible’ first runner/cart which can bend around corners (2 versions exist in aqara rails)
Post some pictures of your installed tracks to get a better understanding of your setup.
Ps. Create a new topic to prevent spamming this dedicated Xiaomi zigbee topic :wink:

I’ve asked on of the mods to split this discussion into a seperate topic.
I don’t consider this as spamming BTW.

1 Like

As requested split from the aqara Zigbee App topic as this is a customer specific issue for one device and unrelated to the app.

On Youtube another reset procedure is shown: here. Perhaps that might help!


If AnnieB needs one or two controllers depends on the length of the rails and the weight of her curtains.
I use only one per rail.
My rails have a maximum of 3 meters.
But my curtains aren’t really heavy.
For AnnieB i would suggest two controllers too.


Thanks for splitting the thread and sorry for the spamming in wrong thread.
I am still stuck on not beeing able to re-pair my motor (Aqara B1 Curtain Controller, the one with battery). I have been pairing and unpairing them many times during my attempts to fix my set ups, but now suddenly it doesn’t work. I guess I’ll try to read up on how Zigbee works, to try to figure out what is wrong. I have tried detaching the motor and going closer to the wifi-router and to the Athom homey hub, but neither helped.

I’m doing it all without curtains.
Yes, I have a runner/cart (I called it “locomotive” previously) which is “flexible”.

In the picture you can see one of the two corners, full view. (Could only attache one picture since I’m a “new user” in the forum.)


@Hugo thanks for thinking along.
I have not seen any recommendation to install two controllers (!) on the same track; always one controller per track, either with one or two motors (with one controller).

In case of the Aqara B1 curtain controller, there is no obvious setup to install two B1 curtain controllers and use them in a master / slave configuration.
Possible hack option for the old Aqara controller (not the B1) could be to split the RJ11 connector between the Zigbee module and the motor unit. In case of the B1 controller, the Zigbee module is integrated into the motor.

Please try to restart Homey (or pulling the plug) to re-initialize the Zigbee chip and then try again to include the controller.


I am sorry, my bad.
I thought you meant controllers as being the motors.
But you don’t need two controllers!
It should be possible to ise one controller for two motors on one rail.

Ok, so now I have restarted Homey.
(A bit annoying that there is no way to send or reset the password to your homey account, but eventually a password that I tried worked. Where should I send this feedback?)
First I couldn’t control any of my previous devices and thought I had to re-pair everything, but after a few minutes it started working.

So now I have paired one of my detached motors successfully, and before I start messing things up my question is:
How do I make it find the ends of my curtain? (assuming it doesn’t get stuck somewhere again)

Thanks for hanging in there with me!

Hello my dear helping angels on this forum!

I regret to say that I still need your help :confused:
So, I spent the whole summer not touching those curtain tracks and motors, because I was too angry to deal with them. But yesterday I had a new try and I’m still on it.
I had a major breakthrough in making the first cart run quite smoothely through the corners by cutting the belt between the two attatchments of the first cart. This made it much more flexible in the joint. I also moved one attachment closer to the end in this new cut in the belt, making the total length of the belt a few millimiters longer so it isn’t so extremely tight.

So that’s one big problem solved, however there are a few left!
I still have trouble controlling the cart with the Homey app. In june I learnt that I only need to pair one of my two motors with Homey. I still often have trouble pairing after I have removed the device, but right now I have managed to pair one motor. But it only runs in ONE DIRECTION! Regardless if I press open or close or up or down, it still just opens. I have tried starting with the cart in different positions on the track, I have tried swiching places of the two motors, I have tried removing the device and re-pairing it (also needing to turning the Homey ball upside down to make it do a “recovery”), but still it will only run the cart in one direction.
I would like to try and pair with the OTHER motor instead, because I know that one did run in both directons previously, but unfortunately, it just won’t pair with the Homey. Even after the reset it won’t.

And if I do make it run both ways, I still haven’t figured out how to make it find the length of the track :cold_sweat: All the posts I have read just says “It will find the length of your track first time you use it.” or “… after pairing.”, but mine never has.

Please help :pray:

Not a direct solution, but merely a suggestion. My mains powered xiaomi curtain controller can be reset via the button on the bottom, but also with a pin in a hole under the bottom cap. Perhaps your B1 needs that second reset (if the B1 has that pinhole too).

Good luck!

Thanks for the suggestion! I’ve been looking for some kind of additional reset button or pinhole too, but haven’t found any. The only reset I can do is to push the button for 5 sec, and then it beeps and there is a blue light. After that the blue light blinks 1/sec ca 9 times.
On other occations the light has signalled in red or white, but I can’t really understand what it means. The QR code for an installation guide doesn’t work, and I haven’t found any by googling.
If anyone has experience of what the lights mean, or if you can do a “deeper” reset, I’m happy to hear!