[App] Telldus - Z-wave

Created to discuss the Telldus Z-wave app.


I have a Telldus Plug-in switch mini, which I use for measuring the power consumption of my heat pump. That means that the Telldus should never be switched off.

So is there a way to prevent the Telldus from switching off, should I accidentally happen to short-press the device icon in the Homey app?

No, not that I know of. I don’t think you can.

Does anybody know how to branch the repo and make a pull request with the implementation to be able to add the min plug as non secure?
I asked @Yhaugom but he hasn’t the time right now and I dont know how to do that. :blush:

Got a reply from Homey support regarding add z-wave devices as non secure,

You can refer them to the Fibaro sensor implementation in the latest app update if they need an example how to.

EDIT I did some “digging” and is it possible to add the following in the app.json file on row 481?
"includeSecure": false,

It’s probably not that simple, but I had to try. :stuck_out_tongue:

Yes! I found @HansieNL guid how to install apps via CLI so I downloaded the project, made the above change and now I have the mini plug as non secure.
What I see aftrer is that the mini plugs connect without a hop to my Homey. When they where secure they did at least one hop to a non secure device.

I will see if I can make branch and make a pull with the change I made.

Hmm, should the tellusplug add as secure or unsecure? I´ll like it to be secure but adds as insecure.

That’s really strange. I wanted to add my plugs as unsecure but the app was adding them as secure so I had to change the code, compile a new app and load it onto my Homey.
According to Telldus, the only devices that should be added as secure are locks and alarm devices.

But you should add them according to your wishes. .

Looks like Telldus soon will release a combined rain/wind z-wave weather-station. Any chance it will be included in the Telldus-app for Homey?

If someone feels the urge to help out writing the code then maybe. :upside_down_face:

I have some small changes/fixes lined up, but it is for v5, and I don’t want to install unstable firmware on my only Homey.

1 Like

The one in the link says 433MHz

Hi. Is there a way to reset power measures in Telldus zwave plug?

@Mats_Nygren Yes, you should be able to do it in a flow or under device settings if I recall correctly.


I’m having a lot of problems with my Telldus z-wave plugs in Homey Pro 2023.
They have been working fine with my old TellStick ZNet Lite v2, but with Homey they are often unreachable and don’t respond to commands.
If I unplug them and plug them in again they might work for a day or two, but not always.
They are spread evenly throughout the house, so the distance shouldn’t be an issue.

Are there any settings for the plugs that I could play with, or any other ideas how to fix this? I have tried to heal all plugs several times to force them to find better routes - sometimes it helps for a while but not often.

Here is an extract from the developer tools that shows some of the plugs:

Hello @SThyni !
I guess it was you who just triggered a diagnostic report from the app.

In the report I see some errors regarding capabilityId ‘measure_power’, and I see a lot of crash reports in the dev-portal in general. I dont know if this could be the cause of the problem, or if the errors is due to the plug itself not responding.
Error message says:

[Driver:TZWP-102] [Device:f1....] Error: capability get command failed {
  capabilityId: 'measure_power',
  commandClassId: 'METER',
  parsedPayload: { Properties1: { Scale: 2 } }
} Error: ZWaveSendCommandTimeout after 30000ms

Unfortunately I do not have much time to look into it in the first couple of days, but I will try to make some time here and there. And I am not sure if this is something I can fix at all…
I will have a look in the coming days.

1 Like

Hi @Yhaugom,

Yes, I triggered the report :slight_smile:.
It would be great if you could have a look and see if you find something - any idea is appreciated!
I notice for instance that all devices are listed as “secure”. If I understand it correctly that is not needed for smart plugs, but I don’t know if that has anything to do with my problems.

After my Homey was updated to version 10.0.5 it’s worse than ever, I have now lost contact with almost all my Telldus plug-in switches. Maybe the problem is on the Homey side, but I’m desperately reaching out to whoever I think might be able to help.
I’ve restarted the app and the Homey several times without success.

Do you have any idea what I can do?

I have tried to locate the issue but been unable to so far. I have not changed anything lately, so I would guess the problem is on the Homey/Athom side, but I will keep investigating when I’ve got the time. It is not easy to find the time these days though.
I know that there is a major problem the Z-wave devices that is being worked on both from Athom and Silicon labs.
Have a look here: Homey Pro 23 - firmware changelog.
Maybe that can be relevant. I see some random crash reports from my app as well, but they don’t make sense to be the root cause for this.

Are you drawing a lot of power through the plugs? I have one connected to a water kettle just to use the power meter to trigger a flow, and that is stable for months and months, but I also have one I have used with a 2000w heater, which needs plugging out and in again ever so often. It will typically be like this:

I probably reset it October 24., and then it worked fine until November 5. I haven’t had the time to play around, but the theory is that the power meter flows over, or something to that effect. I will try resetting it with a flow every night, to see if that helps.

Any chance Telldus pet safe motion detector will be supported?