[APP][Pro] Xiaomi mi flora sensor/ropot app

Xiaomi mi flora sensor/ropot app

This app integrate the Xiaomi mi flora sensor and Xiaomi mi flora ropot into Homey.


Keep in mind:

  • For an optimal signal strength keep the sensor within a close distance of Homey.
  • Always download the original Xiaomi Mi Flora app and add the devices to the app. This automatically updates the sensor’s firmware to the latest version.


Do you like the app? Donate me a beer!


Q1 Why can’t the sensor be found by Homey?

  • Check if the eensor is not connected to another bluetooth device. The Xiaomi Mi Flora app for example

Q1 Why are the readings from the sensors different than in the Xiaomi Mi Flora app?

  • It is caused by old firmware (2.7.0), try to update the sensors through the Xiaomi Mi Flora app

Q3 Is the app compatibel with v2.0.0?

  • The app is only compatible from v2.1.2 and up due to change to the BLE core.

Q4 Is the app compatibel with the Xiaomi Vegtrug Flora Care?

  • The app is also compatible from the Xiaomi Vegtrug Flora Care.

Report Bugs for this App to the Developer

  • Please use the Link in the App Store and follow the community guidelines, the more info provided the faster it can be solved.

Supported devices

  • Xiaomi mi flora pot
  • Xiaomi mi flora sensor

Release history

That is found on the github page:


Example flows:

Send a notification if some plant needs water.

by: @Skorpion

Create a log if the sensors did’t report anymore after 2 hours.

by: @Dijker

Log and send a push notification when a plant needs water.

by: @Robinjo

Log and send a push notification when to replace the battery.

by: @Koktail


Moved flows to openings post

Can I tha alpha access? Thanks

The app is currently in beta.
See: https://apps.athom.com/app/com.mi.flora

I have had my 6 Mi Flora sensors up and running on Home Assistant for 4 months now without any problems.

Moving them into Homey has not been a breeze.

It looks like the sensors stop updating to Homey after a couple of hours, which is kinda strange.

I see that others have experienced the same error before, but it seems like it’s been fixed with newer versions of the Mi Flora App…

I, however, still can’t get them to update…

My config is:

Mi Flora Firmware: 3.1.9
Mi Flora App version: 2.0.8
Homey firmware: 1.5.11


That is strange, i’ve been running the app (2.0.x) for 6 months without a problem. The (1.0.x) app was not stable however, at that point i’ve switched the old app for the new app.

Have you tried to remove and add a sensor again?
Have you tried to remove and add the app again?
Are u using the “mi flora app” and connect it to the devices?
Do you have another app in Homey that uses BLE?

Can you send a log to the developer:
Goto: /manager/settings/#homey:manager:apps
Click one time inside the white frame with: Apps installed on Homey
Hover the app: homey-mi-flora with the key and wait until the Send to developer button appear and click on it.

A hard reset (taking out the power) did the magic for me. Tried several times with both installing and uninstalling the sensors and the app, and also “soft” resetting the Homey though the menu.

Thank for your quick reply and awsome app.

Good to hear. Happy to help. :smiley:

I’ve added the example flows from the old forum.

Hmmm… I sent you the logs…

As you can see from the logs, the Homey lost contact with all my Floras after a while, and contact was established again when the Homey rebooted due to an automatic software update.

So something here isn’t quite right.

I’ve looked into the log. At one point is said: “failed connection to peripheral: Error: Peripheral not found.”.
Looks like the connection in interupted, the app tries that 3 times. After that it will resume updating the next device.

Are you sure the device is in range? (max 4 meters)
Do you have another BLE device attached to Homey?
Is your ‘Home Assistant’ still updating the sensors?

The device is in the same place as they were when I was using Home Assistant, and they are all in my living room, so +/- 4 meter.

No… I don’t have any other BLE devices connected, and Home Assistant is not updating the sensors.

The strange thing here is that after every reboot of Homey, they seem to update perfectly for a while, and then fail.

The logging does not show any strange behavior en looks good. I think the delayed event for updating for the next update is lost by Homey somehow. Can you set your update interval to 15 minutes and test it again?

What I’m doing wrong, 2x Mi Flora sensors with same firmware version, both with fresh battery after adding first one, scanning doesn’t find second one. Mobile app off, bluetooth off when scanning.

Homey Firmware Version: 1.5.13-rc.11
Xiaomi Mi Flora v2.0.8 Leendert De Kok

You do nothing wrong, should be found. Have you see the other device the first time? Can you try to scan again and send me a log?

Tried differently, hard reset, taking battery from first one out and etc. And i tried to get log by your manual too but no button appered in Homey deskop App and from web view too. Can’t find some screencast or video in internet about that “log button hack” too

Can you send a log to the developer:
Goto: /manager/settings/#homey:manager:apps
Click one time inside the white frame with: Apps installed on Homey
Hover the app: homey-mi-flora with the key and wait until the Send to developer button appear and click on it.

In google chrome:
Goto: /manager/settings/#homey:manager:apps
Click one time inside the white “frame” with: Apps installed on Homey.
Hover the app: ‘homey-mi-flora’ with the <alt> key and wait until the ‘Send to developer’-button appear and click on it.

Have you seen the sensor im either Homey or the xiaomi mi flora app?

Ah ok, now i see.


Yes both sensors correctly displayed in mobile app always when running app.


I put the update interval to 15 and everything ran perfectly well for 5 days.

Then suddenly yesterday, all Flora sensors stopped updating approximately at the same time, and around the time when I watered the plants.

Looks like there is nothing wrong in the app. Maybee the name of the device is different and is the device not found. Do you have access to a computer with bluetooth? Which OS are you running? Can you search for BLE devices?