[App][Pro] Tuya Cloud

I can select a mood, as shown in first screenshot. It’s strange that’s not working in your case and I don’t know why at the moment.

I need more information to solve this problem, do you know how to run an app in CLI?

When I’m home, I try to make a flow with the computer instead of my phone. Don’t think it will make any change, but just to be sure. If it still won’t work, I let you know and see what I have to do to give to more information (app in cli)

1 Like

Jurgen, I’m home so let me know what to do…when ever your ready

Oke…I reinstalled the app, and now it’s working… strange, but for the time beining it’s working

Correction…afther about 10 min. agian I can’t select any moods, there gone again

Oke, I reinstalled the tuya cloud app again and again, Everytime the app works for a few minutes. After that I can’t see the moods anymore and can’t add any device. In the configuration of the app, when saving my data I get the next error (not the first time after installing, but when the problem starts)

I tried to reinstall couple of times and even restarted homey… nothing helps

The brightness error is reported earlier, I have to look into that problem. I can probably look at it this weekend.

Yes, that’s was me I think. No that is app was in the store, I hoped that this problem was over but unfortunately not for me… If you need any info, pls let me know

If you run the app instead of install with CLI, you get debug info. Can you send this with PM?

Oke, you lost me… Where/how can I get the debug info? Is that the diagnostisch rapport? Dat is jou de code moet sturen?

@Jurgen_Heine, the lights I’m missing the color wheel for is ordinary bulbs.

I added them to the TuyaSmart app using the autoscan functionality. The icon for the RGB bulb is a bulb with color on the upper part. In the TuyaSmart app they work fine.

I am also not alone with this issue, I have multiple reports from other users with the same problem.

How can I help troubleshoot?

Hey @Jurgen_Heine,

I’m experiencing a bit of difficulty getting a ledstrip to work properly, there’s multiple things:

  1. When I set the brightness in homey, it doesn’t always actually change it, but jumps back to the old value after a little.
  2. The color wheel is missing, making it impossible to set colors through homey. I’m surprised that the Home Assistant Tuya API only has that option for the local control. I also got a Lsc light bulb and that one works perfectly fine, is it maybe an option to add the ledstrip the same way as the light bulb is added?

From what I understand it’s something that is not supported in the Home Assistant Tuya API. Therefore, might it be an option to also support local control like the other tuya app for Homey does?
I’m a programmer myself, is there any way that I can locally edit the app and try to get the local control stuff to work inside your app? I haven’t really looked at it yet, but I could try to make it work.

Kind Regards,

Lenard van der Maas

@Jurgen_Heine Sure thing. I’ll keep a lookout for when you add support for the fans.

@johan_bendz and @Lenard_van_der_Maas, there is new hardware for lights. This hardware was used only for ledstrips, but it looks like it’s used for bulbs also now. This hardware was initialy not supported at all by the API, but around 3 weeks ago this hardware was added to the API. But Tuya is not returning the color information for those lights. Also sending color information results in an error. So until Tuya fixes the API, it is not supported by this API. An other issue is that the brightness values are different than currently used. The other Tuya app is not using a Tuya API and is using a reversed engineered local control.

Okay, that’s good to know. How do you get all these details about the products? I’ve looked for info online but I could hardly find anything. If you could point me in the right direction, I’d really appreciate it. And as for now, I’ll just take an old phone and set it up so that I can easily get the keys for the devices I need to add to the other app.

Hi Lenard.
I think that the only thing that makes ppl use the cloud API is that the Tuya app with local control use a key that has to be extracted from the device. This is not very hard to do if you have the time and skills but the average Joe will not be able to do it. If someone could come up with a way to extract the Key hassle free the local control would be the primary app.

edit: I see you already know about the key :slight_smile:

Yeah @johan_bendz, it seems we were typing our responses at the same time.

I indeed know about the key and I intent to make it a lot easier to extract them. I was thinking to maybe make an app that reads the outgoing network, but I’ll give you an update on it when I’ve got something. This is getting a bit off topic though, in my opinion.

1 Like

This is also the reason I published the app. The other Tuya app was developed the same time I did, but was earlier in store. First I thought not to publish app, but this app is easier for not technical people and if you don’t want to install an untrusted root certificate on your phone.


Thanks for the feedback @Jurgen_Heine.
I’ll check with my contacts if they can pull som Tuya strings, might help if their customers asks for an API update and not only the end users…


There is a new test version. In this version a bug is solved for scenes not visible in Homey. This bug probably also solves problems with brigtness setting for led-strips. Color for led-strips is still not working and unfortunately remains an issue!

Below url to test version:


Hey. Thanks for great app, would it also be possible to get Energy readings to work from Smart Life app?