[APP]PRO] Tesla

Correction: If one assumes that the limit is reset at midnight and according to the tile the car was reachable until 7 a.m., then the limit would have to be 420 queries per day with a minute-by-minute query.
Bildschirmfoto vom 2024-06-08 11-54-18

In the german forum someone made 180 reading requests in 3 minutes and got a 24h rate limit.
But it seems, not all cars are affected. And I’m not sure if it depends on the firmware version because the limit is done on the Tesla server.

On the Homey, the UI is showing for me that API rate limit to be at 3%

My car was as sleep during the night, but then I did do a drive for appr. 2 hours, and the wake call frequency was 1 minute, so I might have had around 120 calls during the drive, + some 9x6 = 60 calls before that. During the drive I did see the phone icon pop-up which would indicate a location poll (like previously)


Just to clarify some details about the current rate limit issue:

  • The rate limit counter (%) in device settings is only the app internal one counting the commands you send.

  • This only affects commands sent by device buttons or flow cards.

  • The current rate limit shown in device details (device not available) is caused by the Tesla API.

  • Currently I have no information about the max. calls a day

  • I also don’t know if only reading requests are counted or if command are added, too. I think both calls are counted.

  • This rate limit is new for a few users. Not sure if Tesla enlarges this limit in steps to all cars soon or if it depends on other things like software version.

  • It seems, the rate limit is ~300 API calls a day. That makes it possible to use a 5min online interval


1 Like

I get the rate limited error on a 2017 model S. The only flow I can think of is one that uses the trigger card “when minutes to full charge changed”. This will obviously trigger 120 times in a two hour charge….
EDIT: Made a workaround to trigger this flow (calculating hours needed for a full charge) only when needed. Will report back if the rate limiting lifts tomorrow.

I think there might be status-related changes that also make our usage of the API “bad” in the rate limiting detection area.
From my polling with TeslaMate, I have noticed since I upgraded to 2024.14.8 10 days ago, that the car goes offline most of the time instead of sleeping. Yellow in the graph, instead of green.
If Apps like homey tesla app is polling every minute default, when car is offline, but only every 10min when asleep, this might be part of the answer why we all are getting rate limited now.
I have put my 1 min online polling interval up to 10 min now, let’s see how that behaves…

Yesterday i increased my online interval from 1 to 5 minutes and now my tesla is reachable again, lets see how long…

Good point.
This can be a reason. The app request the car state first (asleepnor not). If asleep, the offline interval is activated. In the other case, the car data is requested. So in offline state, the app still tries to reach the car because in such a case, the car is only offline for a short time (no LTE access).

This will result in a online interval usage for 24/7.

But let’s see if a higher interval can solve it. In other forums I read about 300 request and 50 commands a day. But that’s still not confirmed.

For me, Homey “reaquired” my car this morning at 3 am. (I changed the setting for Online to every 3 minutes and offline to every 20 minutes). So far today the car has stayed in Homey. Not sure if it is thanks to the changes in the settings, or if it was just a clitch on Tesla’s APIs restricting the access.

If 300 requests a day is right, then 5min online interval would keep you below the limit.
Dependent on the online/asleep relationship it’s possible to use s shorter online interval if you save some calls during asleep time.

1 Like

Just tested today with the 5 min limit, still online now.
Oh and the car didn’t come back online until after midnight.

Rate limit hit today at around 6pm. Meaning that connection stayed up from 3am to 6pm => 15 hours, and the online polling was set at 3min and offline at 20mins. If the changed to the sleep vs offline has impacted that the car stays online all the time, then I could it would mean that the rate limit would be around 15x20 = 300, as Ronny mentioned above.

Mine has been online today with both set to 10min.

Note that Teslamate thinks car was asleep for a long session during the night.

And also note Insights for the rate limit. There was big numbers just the last two days…

With an interval of 5 minutes, the access limit does not seem to be reached. I will reduce it to 4 minutes.
However, I do not have any other third-party apps that access the car, perhaps that also reduces the total quota. Apart from Homey, the Tesla app is the only one that accesses the car.

…and since the friday/saturday spikes, it is all well again. I still think it was something tesla did (in error?) in the api, not really how we and our app usages are behaving.


I think I found something regarding the interval settings at this url:
Membership Levels – Tesla Fleet API

I just installed this app on my new M3Highland. It could send a command for a short while but now keeps getting error 500.

Is this the problem that most people experience?

If your device is unavailable due to rate limit, then it’s not possible to send commands I think. Perhaps the command proxy doesn’t provide a correct error code and returns http-500 instead.

1 Like

I will try to morow. Disabled all my flows for now (regarding Tesla)

That’s an older information anmounced to be replaced with another one in 2024.