[APP]PRO] Tesla

Thanks for your feedback.
Do you have an idea what could be the cause in yoru LAN setup?
New router or TP-link’s? New firmware? Homey update?

At the end it’s the Homey that thinks it’s a IPv6 network and tries to use the IPv6 address.
With a lot of help from @robertklep we tried to find a way to force IPv4, but without luck.
So the only current solution is to check and change the LAN/router settings.

New Live version 1.6.0 including all updates since 1.5.1:

  • Added climate keeper mode (dog/camp mode).
  • Added device tile state. Devices are shown inactive if car is offline/asleep.
  • Force IPv4 instead of IPv6 in auth process. If you still have timeouts for IPv6 addresses, please check your Router/LAN settings and deactivate IPv6 if not used. It’s a general Homey issue where the IPv6 is used but calls to external IPs are not possible (missing IPv6 on WAN/ISP side?)
1 Like

New firmware TP-link router might have caused the issue, as I have updated a few days ago (but didn’t check if Tesla app was still working directly afterwards).

Hopefully Homey will improve/solve this, as what I understood last days, IPv6 is ‘the future’ (you have reported this issue to Homey? Unfortunately, I can’t as I’ve no idea what and how to report).

Anyway, thanks again for providing a solution in only a couple of days (wish Homey had same ‘service levels’ :smiling_face_with_tear:)!

I added a newsletter subscription to my homepage. There you can register to get updated if new blog posts are published.

Newsletter – Ronny Winkler

And if you have some questions, need examples or need a HowTo for this app , that are worth to be published as a blog post, please let me know :wink:
Just ask here in the forum.

1 Like

When I connect my Tesla to Homey, does Homey keep Tesla “awake”? In other words, will the energy consumption go up when my Tesla is idle?

Only when you send commands, not when you send status queries.


As addition…

  • you can wake up the car with a flow card.
  • you can define in app settings if a command will wake up the car or not (auto wake up is best way, then the app waits until the car is online and then sends the command)
  • reading car state doesn’t wake up the car
  • the car goes to sleep by itself

Ik have an exclamation mark in the app and it says: Rate Limited. Tried to repair without success. Any ideas?

Same issue here since yesterday evening. Rate Limited. API rate limt is only 3%

Did you check your flows?

Maybe Tesla shut down the “Command Proxy” API

Same issue here since yesterday. Tried to repair, but both options don’t work :cry:

same problem here, device non available → Rate limited. API rate limit at 0%…
Not possible to use the app anymore, do you have any idea please ?

1 Like

Can confirm as well that the app reports „rate limited“. Let‘s wait for the answer from @RonnyW

Copy that

If the device gets unavailable, it’s an http error response from the Tesla API. It seems, Tesla activated a rate limit.
I haven’t found any details about it.

From some comments in the german Tesla forum, it sound like a daily limit.
Try to increase the online interval to 5 min and wait until next day.

I don’t know if it only depends on data requests or also on commands. Perhaps the limit is caused by too many commands (PV charging) and results in a blocked account via Tesla API.

This night the car was online for between 3-6 hours. I had an interval of 1 minute, so the quota would be 6x60=360 requests per day in the best case scenario. That’s not very much.

The same here

I updated my car yesterday to 2024.14.9 and got into same situation. Commands work (I can start/stop charging, turn on/off climate) but no data is coming in (charging speed, battery status etc).

Last status is location update at 3.10 this morning.

Having same “rate limited” error on car dispay.

Note, no changes in Homey side and everything has been working before the update fine for several months.