[APP]PRO] Tesla

I hope I post at the right place, its my first post :slight_smile:

I have HP2019 and have a lot of flows connected to my Tesla and Tesla app.
I’ve reasently got a dog and was looking for a way to make a flow activate/deactivate “Dog Mode”, but I cant seem to find it.

Is it me who’s terrible at looking, or is this not an option in the app?

Hi and welcome,
these climate modes (dog, camping) are not added yet because it’s not a common use case for automations.
But I will check if it can be added.

Could you give me a hint, how/when do you want to activate the mode in a flow? Just to know the use case. Thanks.

Thanks, and thanks for a quick reply.
I have homey liked to Google home/assistant and have quite a few flows linked as favorites so I can use voice commands.
The main use would be to create flows for on and off, and then activate it by telling G A to turn it on and off.
There are probably also a few places where I would automatically set it to activate when at a certain location.

Its not that hard to go in the Tesla app and activate/deactivate it manually, but Homey and G A has made me lazy :joy:

1 Like

Thanks, yes, a good use case :smile:
I’ll check it the next days.


Evening @RonnyW the work you are doing with your Tesla app is excellent, appreciated. Query regarding user presence, we have two Tesla and two registered users, can the presence be used to identify which user is driving which car?

I don’t think so. There is only a simple state:

is_user_present: true,

So it’s only a state if a user (or a key) is present or not.

1 Like

Had wondered if maybe security considerations would prevent this info being made available. It is still a useful feature though. The amount of logic involved is a super menta exercise. I’m in the process of changing some presence flows to better use Tesla app along with others.

New test version 1.5.5:

  • Added climate keeper mode (off, on, dog mode, camping mode) as device selector and flow action
  • Added changes to prioritize IPv4

@Jan-ErikP FYI. You can install the test version and try if the climate keeper mode is working.


@RonnyW Awesome. Thanks.

Forgive me for a perhaps silly question : how do I install the test version? :see_no_evil:

Open the “Changelog” on the app homepage and hit “Test” or add “/test” on the end of the URL. Then hit “install”

1 Like

Sorry, I forgot the link. Marius was faster :slight_smile:

I’ve installed, created a flow and seem to work perfectly :heart_eyes:
Haven’t linked the flow to G A yet, but that won’t be a problem setting up :blush:
Thanks :blush::blush:

1 Like

@RonnyW Update: Have linked the flows to G A ang tried it today: Both on and off Dog Mode.
Worked flawlessly :smiley:

Test version 1.5.6:

  • Added device tile state. Devices are shown active/inactive if car is online/offline or asleep.
1 Like

Hi Ronny,

After using this great app (thanks!) for about one month, an exclamation mark suddenly appeared in the ‘car’ device. I tried every option available to repair, but it stopt after logging in on my Tesla account, showing a page ‘login with your account. Login on the website of the producer’ (I also tried to login to my Tesla account, opened the Tesla app, etc.). After this steps:

the proces stops and the attached attached screenshot is shown for a while.

The car device was not repaired.
I tried to remove the car device and add again. Without success (same page with same message as above was shown). Finally I removed ‘everything’: Tesla Homey App, Homey credentials in my Tesla account, keys in my Tesla and also restarted Homey to start all over again.
It ended at the same screen (screenshot).

After a while an error (timeout) was shown (see second screenshot).

(I don’t know what the code ater ‘TIMEOUT’ means, so just in case I hide it behind a red line).
Access for the Homey app was granted again, I could see in my Tesla account. But whatever I tried, the process always stops when after the screen in first screenshot was shown for a while (ending in a time out error).
Additionaly, I also tried on different devices (Mac and iPhone) and different browsers, also after cleaning cache, etc.
Trying the very last time (before writing this support request), I also got this message:

However, I couldn’t find anything to abort that ‘pair session’ and also didn’t find any way to finish (where is that session?).

So, how to get it working again (what did I do wrong or did I miss)?

sorry for the issues you had/have. Just a quick reply.

Is it right that a IPv6 address is shown in your screenshot?
I ask because another user also had issues with IPv6.

It can happen in the folliwing case:

  • The DNS server returns IPv6 first and IPv4 later
  • The http module uses IPv6 to connect.
  • Homey can’t connect due to missing IPv6 support in the LAN/router.

I preparerd a fix in the current test version to use IPv4 first. I hope this helps.
Can you please try the test version and report if it’s working for you?


Hi Ronny,

Thanks for the prompt reply.

About your question:
I’m not a IT specialist and don’t know how to recognise a IPv6 address (or IPv4).

The good news it that adding the car device works again (thanks!) and also pairing (being inside the car). Data from the car (e.g. battery status) is shown in Homey again as well.

The bad/sad news is that sending commands to Tesla (e.g. open loading dock or, after enabling in app, open trunk) still doesn’t work. I get errors like ‘timeout after 10.000 ms’ and ‘aborted’. Before the problems with the app started, that worked also fine.
Any suggestions?

Kind regards,

It’s the same reason (IPv6) but based in the Athom core classes. I’m still investigating this issue.

A first workaound would be to disable IPv6 in your router. Hopefully, the DNS request will deliver only IPv4.

But how?

I have a router from my internetprovider (Ziggo) and extended the network by 3 TP-link Deco’s. In the Deco-app, I found the Deco’s already configured with IPv4. Homey is linked with the ‘Deco-network’ (not the Ziggo-router), but I don’t know if that matters. Homey had also a wired (ethernet) connection with the Ziggo-router, but after unplugging that connection (and using Wifi), sending commands to Tesla still doesn’t work.
Maybe I forget something and, again, I don’t know much about IT, routers, etc., etc. Anyhow, thanks again for this workaround that I can hopefully use when I know what to do (and where).

Update: switching IPv6 on and off on Deco’s and restarting Homey solved it. The workaround now works, thanks. Hope you can find the issue soon and the workaround can be replaced by a ‘real’ solution.

1 Like