[APP]PRO] Tesla

New test version1.2.1:

  • Added media next/prev favorite flow action.
  • Update charging state on charge action.

Aha Okey. I probably remember it wrong.
We would love to have the X icons again. Thanks again for the previous app and this!

New test version 1.2.2:

  • Fix stop sync after device got deleted.

Thanks a lot for your very complete answer!

@RonnyW: I was struggling to get charging of the Tesla under control. I just wanted to keep the w usage between 3500w and 4000w. I created the flow below, but it seemed I had no interaction with the Tesla app at all.
Until I started reading this post and added the key to my car.
I have Tesla app version 4.29.5-2203 and installed on homey version 1.2.2 of the Tesla app and with the key added to my car, it seems to work well now.

Thank you for the great app.
Just one question, which command API should I use. Currently it’s set on Tesla Vehicle Command Proxy and working fine, but if I’m reading well, I should start using: Tesla Vehicle Command Protocol (Alpha)?

You can also share IBAN, I’ll make a donation for this app!

the “Command Proxy” is the right one.
The “Command Protocol” for direct messaging is still in work. The commands are not documented and only a half is implemented yet. That’s more for my own tests.

Version 1.2.2. is live now including all changed and additions since 1.1.5

1 Like

Make sure you have the latest iOS or android Tesla app installed. In homey, select your car and go to maintenance —> repair —> register app in car. You will need to confirm the access by using your physical keycard in your car

I am migrating flows from the deprecated app into the new one. I used to set a flow that sends me a message when Charging Stopped with the added energy and ending battery level.
The Charging Started and Charging Stopped triggers are not (yet) available, is that correct?

I assume you have also added the “Battery & Charging” device?

If not, do that.
Then you should have the cards:

Charging has started
Charging has been stopped

you should see.

Tags are then available with which you can obtain the data:

#Charging energy added
#Battery level

I hope I have understood you correctly :slight_smile:


The CommandProxy server will be offline for a short time due to maintenance.
Commands will only work via REST API.

CommandProxy is back and online again :slight_smile:

1 Like

Ahh, thanks! I didn’t notice before that there are now separate devices to add for the same car, specific for navigation, charging, media, etc.

1 Like

In the Command settings for the vehicle, there is a toggle “Retry commands”. If I set that to ‘Yes’, what does it actually do?
Let’s say my flow tried to start charging, but there was an API Error like ‘Could not wake up the car’. Will it retry automatically?

You can find further details behind the ( i ) icon:


If a command returns an error, the app tries up to 3 times to send the command with a 5sec delay between.
The wake up is done before ( if activated in device settings). If wake up was not successful, then the command will error in this case.
Retry commands can help if you have a bad network connection and a call got stuck.

In general, best way is to wake up for commands if needed. This way, you can use a flow action independent of the car state (asleep or online) and the app wakes up and waits up to 30sec until the car is online.


Thanks. Sometimes it takes a long time for my car to wake up, I’m guessing longer than 30 sec. “Retry commands” will not help in this case since the wake up didn’t work?

Yes, in this case, the wake up is not successful and the app won’t send a command.
If your are using flow actions, you perhaps can try 2 sequential “wake up and wait” flow action in your flow to try a second wake up.

As I discovered, a wake up is finished normally between 6 or 10 seconds.
If it takes much longer, then the car is offline (no LTE connection) in most cases.
In this case, the Tesla mobile app will also fail.

Hi, something went wrong and I did not give all allowance in the Tesla app. Now there is no location coming in. I have removed the Tesla app and tried again. Added the Car and the location app. I don’t get in the allowence part and stil no location.

What can I do to fix this?


  1. Did you allow location check im car device settings?

  2. Check the details in your Tesla account. You can see the authorization you allowed during oAuth. If you missed a scope and would like to allow more, you have to remove the Homey app from your Tela account. Then login in Homey again amd you can define the scopes again.

Hi Ronny,

Maybe that is the catch.
I don’t see homey in my Tesla account at all.
Is it in the app on my iPhone or in de car by the keys?