[APP][Pro] Telegram

thanks for replying both.

If resetted it multiple times back to factory settings. I have a modem from Sagemcom and a router from TP-Link. Ive only fixed some IP’s for mobiles to use the smart presence app. Nothing more.

I changed the bot token once.

This morning suddenly i received messages from the bot. (I made a flow somewhere with "every 3 seconds send me TEST message via telegram. It gave a TEST message 70 times in 1 minute and then stopped again.

How do i do the HTTPS suggestion?

It’s an IPv6 routing issue, but I’m unsure what’s causing it. Possibly a misconfiguration between Homey core and Homey app containers, but I wouldn’t know how to debug that.

1 Like

Hi Robert
Thank you for replying and answer.
Is it something I should be able to fix in the router setup?

Any idea?

Any other people that you know that can be tagged here, that maybe know it?

I use telegram a lot for my homey system. Really hate that it’s not working anymore…

@Dijker Hi Geurt, I saw your name in the guidelines of how to use this forum and saw your an it expert.
May I please ask you if you have any idea about this network problem?

You had it working for some time, which seems to rule out a routing issue.

Are you sure the test flow you made hasn’t been paused by Homey? Periodic flows that start too often will get rate limited and stopped, and “every 3 seconds” sounds like a good candidate for that.

No I deleted the 3 sec flow right away.
I have a couple of simple and advanced flows with telegram ifttt rules…

But the flow worked, and now it doesn’t with the same UNETUNREACH error? Perhaps it’s possible to disable IPv6 support in your router or modem to see if that fixes it?

It worked for sure. Weeks/ months.

I had ipv6 switched off in my router already after resetting it back to factory settings. (i dont know if that was switched off too before the problems started)

Now i switched ipv6 off in my modem too. Homey is offline. Rebooting.
Rebooting the telegram app after that too, extra.

Made a new simple flow (not advanced)
if time is X (just selected my time)
Then send via telegram Timetest

It worked!

Now testing my old flow to read out my temperature meters for example: it WORKED


so now it works with ipv6 turned of both in modem and router. Any idea why?
do i need ipv6? Not enough knowledge about that…

Thank you sir!!

It sounds like Homey was getting an IPv6 IP address from your modem (although I’m not sure how). If your router is then situated (network-wise) in between your Homey and your modem, and the router has IPv6 disabled, it could cause routing problems because the router doesn’t know how to handle IPv6 packets.

So you need to either turn IPv6 on on both the modem and router, or off, but you shouldn’t have it turned on on one device and turned off on the other.

Probably not. But if you start having issues with your internet connection, it may be that IPv6 is needed for it to turn properly. In that case you need to turn it on on both devices, as explained above.

My modem - Cable - Router (not access point mode)

First situation : honey was connected to modem via another cable and active splitter.
Then my kid started walking and playing with homey pro :rofl: so I moved it somewhere else and connected it, wired, with router.

Then I started playing around and resetting etc…
Turned ipv6 off at router (forgot the modem)
Resetting multiple times both etc…

Moved it back to wired connection with modem. Resetted it again multiple times both…

And now your solution is to turn ipv6 off at modem too. It worked.

Again. I’m not sure if i had it turned off before. But it’s working now… I’m very happy with that.
I don’t dare to test it again with turning v6 on on both I must say :sweat_smile:

Is it possible to sent silent images and questions?

I sent myself graphs (images) at the end of the day of my power, gas and water usage. I don’t need my phone to ring then. Also when we all are away from home I sent myself the question if my vaccuum may start or not. If I’m home before answering Homey removes the question, so then also I don’t need to hear my phone.

I thought abouw something like a silent-mode (yes/no (default)) on every/most available cards, so there is no need of making all cards double. But I’m not a developper, so I don’t know if this is even possible :wink: :rofl: Just thinking out loud…

Since few days the Telegram cards “A message from Chat Gé is received” and “A message is received” doesn’t trigger anymore when I send my bot a message, also anwers on questions aren’t received anymore. I can send mesages from Homey to my bot.

So(?) I uninstalled Telegram from Homey and reinstalled it, configuring it with my (old) bot token. But now there’s no user in Telegram config. Now I’m at step 6 of the “How to setup” but my bot isn’t respond to “/start” anymore.

Help would be appreciated a lot.

New bot also not responding to “/start”

Edit 2:
With new bot everything is fine now, I guess I went too quick thru the steps. Old bot still not working.

Hi. Just found and installed Telegram after using Telegram Bot for years!
I like that almost all special characters (including _ *) pass without Regex function, even BLL. And so much additional functionality. Thank you!

On the Set-up:
I entered my old bot token and could immediately receive messages (with tags Chatname and Username, etc). But I could not send since it required chat/topic or User.

I simply missed the small instructions within the card attached.
Perhaps add this to your setup instructions?

To register a user/chat in your bot:

  1. /start MYPASSWORD
  2. Confirm to register this Telegram chat.


Somehow markdown/html won’t work in my messages. What am I doing wrong?

A < B > tag or * will be printed in my messages.


Please read the FAQ.

I did. But it is not really informative. I started with Q7, but that was already on (html in settings). Then Q4. Which is just a table with html and markdown information (I know about it). Then Q3 (although I don’t get an error) isn’t an answer and it’s about variables. And Q2 is also something with markdown (which I don’t use) and I read to convert my messages to html. Is that something I need to do or just use html tags, like < b >. The latter is not working and the first lacks how to convert to html.

So, what am I doing wrong? :man_shrugging:

Could you send a diag. report?

Also you only need to use html tags <b>Hello world</b>

Edit: Also what flow card are you’re using?

I’ve managed it, don’t ask me how. Checked all settings, restarted the app, etc. Now it works! :slight_smile: Thanks

1 Like

Hi there!

Getting an error : Image source is invalid for flow card send-a-image-with-tag!

The push notification is perfect, the telegram message is not.

How to solve this, it seems to be a bot problem, I have 2 other homeys with Telegram working flawlessly.


Anything on this issue? I need to solve this quickly

Send me a diag. report