[APP][Pro] Support for ONVIF compatible cameras (Release 2.0.41)

Strange, if it detected the camera, you shouldn’t need to enter the IP or port as that should have been picked up. The ONVIF port certainly won’t be the same as the RTSP port. Also, a lot of cameras have several ONVIF username and password configuration to the normal connection.

You know what, I got it working!
I changed the settings on the camera from ONVIF Authentication: Enabled to Disabled.
And then I didn’t enter any PORT number at all in the box, it was empty from the beginning, so I left it empty.
Then it worked!

1 Like

How were you able to get the firmware? Do you know which version it is?

I am not getting ONVIF events for AI Detection on my RLC-510-WA but I am having trouble getting the beta version out of Reolink. Thanks!

I got v3.1.0.2109_23051513 via link on email.

I have downloaded the Onvif app and successfully added this camera: AXIS M2026-LE Mk II Network Camera.

It seems that motion detection on this camera is not working with this Onvif app. I see that there are also many settings.

Is there a step-by-step guide to ensure that motion detection is not working, or to make it work?

Can you enable the the Diagnostics log in the app settings

Then trigger motion on the camera and see what is logged. You can send the log if you want me to analyse it.

1 Like

i have sent it to you. thanks

After a lot of debugging, factory resets etc, it seems like I’ve solved my problem with multiple push notifications on person/vehicle detections using onvif.

I saw when person/vehicle alarm was triggered, an “general” motion detection alarm was also triggering at the same time. Adding an IF statement and check “motion alarm” was not triggered, eliminated the dual notifications…

Case closed :slight_smile:

1 Like

Hi Adrian,

Pro 2019
App v2.0.48

I noticed the app was paused or frozen in some way. It happened several times.
I’ve no info yet on how many times in how many hours.
Here’s the diag after app disable & enable:
9646126f-4248-4069-bd6c-069939db3632

While I could not send it in frozen state:

I also sent you the detailed log, with peter_kawa as sendername.

Tia,
and no hurries!

Hello, I have a Reolink NVR " RNL8-410 " And a couple of Reolink " RLC-810A ".
I can connect them with the Onvif app, and get snapshots from the cameras without problems. but I don’t get any motion detection from the cameras. I have activated the “Motion detection” button for the camera. and it turns white and green. On the last page like a timeline, there it just says " Tamper Alarm Disabled XX Minutes Ago by ONVIF Camera "
And " Motion alarm disabled XX Minutes ago by ONVIF Camera "
Am I doing something wrong here that I’m missing? Thanks in advance

Can you open the app settings page, select the Diagnostics Log tab and set the Log Level to Detailed information. Then trigger motion on the camera and it should appear in the Log output. If it does, tap on Send Log and I will check the type of event.
If it doesn’t then restart the app and once it has finished starting, send the log.

The log has been sent :slight_smile: Thanks for looking at it.

For some reason it is failing to register push events. Could you try changing to pull events in the device advanced settings.

I cant change it from " push and pull supported : using push " seems like that’s the only choice i have in notification method :grimacing:

The setting is Prefer Pull Events:


Set that on to use Pull events.

I will try that! I will give you an update when im home again :grin: thanks!

1 Like

Hello Adrian! That seems to have done the trick! Not super reliable, but it gives a motion detection notification, thanks alot :love_you_gesture:

1 Like