[APP][Pro] SMA Solar devices

It is and can be negative with Youless and many other P1 meters and has been for a pretty long time. :grinning: So if you could fix that that would rock!

built-in type would be fine i guess :grinning: thx hope you can make it work

New test version 2.3.8 is out, with a new Energy Summary device with standard capabilities. Ie possible to display them on the device card.

You need to delete the old energy summary device and add it again. The old device will stop updating.

2 Likes

Works like a charm! :slight_smile: Thank you so much!

Would be cool if you could do the same for the Energy meter as that is the one you can use together with Power by the hour.

Do you have Youless working with this SMA app and the virtual device “Energy summary”?

I have the Youless LS120P1 and get this when adding Energy summary. I have two SMA inverters working with this app

I removed the Youless device after the SMA Home Manager 2.0 was installed :wink: So Im using that purely now to monitor.

I tried today to add two inverters (I have two). If one inverter is present, the second one is not found, not even via the IP address. If you remove the existing one and search for both of them, two are displayed, then they are added with the same IP address. This can be changed, but then the type data of the inverter is not transferred. Maybe this can be improved. In principle, however, I get the necessary data.

It would be good if the state of charge of the battery could be indicated in percent on the icon.


Reading my inverter, I get a lot of zero’s in between correct data. Is there anything I can do about this?

Do you connect your SMA inverter via wifi or cable? I don’t observe that on my inverter (I connect via cable). Could this be network related?

Hi Richard,
Thanks for checking. While the inverter is connected via ethernet, Homey only uses stupid 2.4 GHz WiFi… I relocated Homey, and the problem seems to be solved. I guess this problem also caused my other inverter’s connection to fail. Come on new Homey Pro with ethernet…
Have a nice day!

1 Like

Hi Richard,

Is it possible to add L2 and L3? Only L1 is displayed at the moment of my 3-phase inverter.
If it’s possible and if I can help you by testing, please let me know :slightly_smiling_face:


There is a test version 2.3.9 where I added L2 and L3. Please try it out.
If you want the “capabilities” in the correct order you have to remove and add the inverter again.

1 Like

Do you have a link to download the test version?

The link for the test version is always the same

Sorry about that. I just installed the app, and it works flawlessly! Thank you very much for your effort. Now I can monitor the grid’s over voltage.