[APP][Pro] Slide - Automate your curtains

@TKroon

Your help is also greatly appreciated! :slight_smile: And yes, i think its my Unifi stuff what blocks something… Homey / Slides are on the same network, but still something is blocking de API request i think. I’m going to try using a separate AP to link the Slides…

I have a complete UniFi network as well. Homey is connected via ethernet, and the slides via an AP of course. They are on the same LAN.

I have the exact same problem: I switched the Slide to local mode via the reset button, added it to Homey (next to the Slide cloud device that was already there), but the Slide Local API within Homey does not respond when I use the slider to open and close the curtains. Any help/suggestions are welcome!

Did you delete the Slide cloud device that was already within Homey before you added the Slide local API in Homey?

For one Slide I did delete the cloud device first, for the other Slide I didn’t. See the steps above. It worked either way.

Of course when I had two devices added in Homey for one Slide (curtain cloud and curtain local api) only one of them worked.

From my Homey Pro 2018 I couldn’t get it working with the Local API.

Local API worked from another Homey Pro 2023 but Cloud API also still worked.

For Today I reverted As I don’t want to run it from The test-Homey

I can confirm the local API isn’t working on a homey pro early 2019. Switch also back to cloud API, for as long it will be working.

What exactly isn’t working… Is it the detection of the Slide during pairing, or controlling it?

I don’t have an old homey lying around anymore I think, but maybe I can find out what is the cause of the problems. I don’t have a lot of spare time but I have seen some error reports in my mail box.

When I add a AND card to re-calibrate my Slide, save it and re-open this flow; it says “Missing owner name”…?
The flow seems to funtion correctly though.

Unfortunately, the (official) Slide Application no longer works if you have (accidentally) logged out. You now get an “authentication failed” screen when you want to log in. And yes, I really entered the correct password. So, don’t log out is my advice…

And also unfortunately my Slides are now in factory reset modes… and because I can’t login in the Slide app. I can’t add them to my Wi-Fi network. So it’s get better and better… :sweat_smile:

You cannot operate the slides. Eventually Homey finds them, but that’s it… And also after Homey PTP-en, or the Slide app. restarting doesn’t make any difference, it never works.

I keep having the same problem: on my homey pro 2019 I can add the Slide Local API. It also detects if the slide is on or not (if I unplug the Slide I get a red exclamation mark in Homey. So Homey does connect to the device. However, controlling the device does not work (opening/closing etc). Deleted and added the local api slide several times, but keep getting the same result…

The behaviour is exactly the same as @Remy described. I can switch back to local API and send you a diagnostic report if that is helpfull in troubleshooting. Please let me know.

Some more details on the behavior: on my Homey 2019 I manage to add the Slide Local API to my Homey. However, if I try to control it via Homey, it does not respond to commands (opening/closing etc). Also, the variables of this Local API Slide are blank (curtain position + touch & go). However, I do think the Homey sees the Slide: when I was troubleshooting the issue myself and the Slide would go offline for a few seconds, a red exclamation mark appears on the device icon on the Homey. So Homey does see if the device is live or not. I have both the local API device and the cloud device on my Homey, if the Slide goes offline both of them give a red exclamation mark at the same time. Last thing: if the Slide is set to Local API mode via the reset button, the cloud API device on Homey keeps working. So I can keep opening en closing the curtains with the cloud API device, even if the Slide is in local API mode. I hope this info helps, and I’m also willing to send you a diagnostic report if that helps.

I tried to contact Kaj, unfortunately this was not successful. but I did get an automatic response back.

*"Dear reader, *

The company behind Slide has shut its doors sadly. This means there is no more support available to answer your question. In the next coming days an app update will be released that will enable your Slide to work without the Slide server. Hopefully, you will be able to keep enjoying your Slide. "

So for people like me, and others is there is still hope to be able to use the curtains in the future.

Yes, the local API (Android) Slide app is available! And my curtains working again! Unfortunately not with homey…

I hope you have some spare time @Jorden to find the problem why Slide is not working with HP19…:crossed_fingers::crossed_fingers: :sweat_smile: If you need some diagnostic reports or something, give me a heads up.

1 Like

On iOS not available

Apple takes always longer… :laughing:

I found the difference in mdsn-ds discovery between HP 2023 and earlier Homey Pro’s where in the host (name) the .local suffix is missing.

Added a small workaround as Fix (As I don’t know if that will be fixed by Athom later)

For me this keeps the App v2.0.0 working on HP 2023 and makes it working on earlier Homey Pro (Models 2016-2019) after re-pairing. (Discovery was working but everything else not)

Als noticed that the Slide cloud still works (although with some delay now) but this makes it for me possible to migrate the Flows.

Created a PR for @Jorden

Where did you find the info to get this Android App?
I expected to be published at the communicated site: https://innovationinmotion.nl/

Update: Sorry I found just now an update from the Play Store with Local support that wasn’t available a hour ago.

Update 2: for Local API mode in the updated App you need to connect all your slides with the Code printed on the Top (or on the Welcome sheet in the Box) … (Lucky I noted them in the Password DB)

Update 3: Sadly the Android Mobile App can’t connect on my WiFi with the Slides,
I get a FileNotFound Error! so there that stops again for Mobile App.

(while it already works with Homey Pro with the Local API)