[APP][Pro] Shell Recharge - Smart charging at home for you electric vehicle

No worries, there is no hurry.
Thanks for trying if you can!

So the getting the token part I do as this:
call the https://my.newmotion.com/ page. The html is parsed to find the login box controls, these are unique every load and need to match with the login post serverside information.
Using these values from the html I do a POST to: https://my.newmotion.com/ajax_request/[value-from-form]-00/ with the login credentials.
That gives me a result with the login token.
That token I keep for the time it is valid before going to the above process again to get a new token.

That should either give a not able to login result or direct you to the device settings page.
That gets your cars and cards to link to the chargepoint you want to add:
I also collect your charge cards and cars using these endpoints:

The device discovery does the following steps:
to retrieve your charge points from your account, next I get your charge point details:
https://ui-chargepoints.newmotion.com/api/facade/v1/charge-points/[point id]

So a mix of endpoints that are used.

I am also very interested in what step you get this timeout.

One lat thought: I added the car selection most recent. Maybe you have no cars setup and instead of just giving an empty result it gives the timeout there?

1 Like

Hi Kaoh,

I followed the steps you list above using a regular web browser.

These are the results for the different endpoints (obfuscated GUIDs and IDs):

  • Vehicles:


0000-000000000000/1"}},“id”:1,“name”:“Hyundai Ioniq 28kWh”,“makeAndModel”:{“id”:77,“make”:“Hyundai”,“model”:“IONIQ Electric”},“edition”:{“id”:98,“description”:“28.0 kWh”,“batteryCapacity”:28}}]}}

  • Assets:


  • Charge points:

I tried several variations but all return a 404:




https://ui-chargepoints.newmotion.com/api/facade/v1/charge-points/0000000000 (the actual rfid from the previous call is used)

https://ui-chargepoints.newmotion.com/api/facade/v1/charge-points/NL-TNM-000000-0 (the actual printednumber from the previous call is used)

404 - {“errorCode”:“NotFoundOrNotPermitted”,“message”:“The requested resource could not be found or you do not have access to it”}

I suspect 2 steps could have gone wrong:

  • the actual login step (low probability)

  • the charge-point step

Furthermore I have the following question: you list one URI two times:


Is this intentional or should there be another URI in your list?


So the single point should end with a charge point guid:

That guid you should be able to get with the assets list call:
In the response there should be a collection for chargePoints and one for chargeTokens.

Thats why its there twice.

But looking at your response:
{“chargePoints”: ,“chargeTokens”:[{“rfid”:“00000000000000”,“printedNumber”:“NL-TNM-000000-0”}]}
Your chargePoints collections is clearly empty. And that could only mean that you have no owned chargepoint registered to your account.
If you navigate to https://my.newmotion.com/dashboard (after logging in) you should see a section called chargepoints and a tab for chargecards. In that Chargepoints section you should see your private owned chargepoint listed, if not… ensure it is registered properly on the site.

Hi Kaoh,

As it turns out, although my charge card can be used on NewMotion, my charge point is not of their make but another. For this reason, I will never be able to register my charge point there.

This means, with the current implementation I cannot use your app.

One thing I noticed though: when I am charging (even on my own charge point which is not registered) that the newmotion website displays whether or not I am charging… Perhaps a feature request :wink:

Thanks for your support so-far Kaoh!

Thats the public api. I could consider to support public chargepoints using hteir api. But there was a The New Motion app out here that supported the public charge points. I needed one that could start and stop sessions on my private and hidden chargepoint. I believe the other one died (and I did canabalize the skeleton of that app). So if I get bored I might spend time on it. But my Xbox companion app has a long list of improvements I want to do second after my LG Music Flow app who is waiting on getting the latest Ring app update out who is waiting on testing the new Alexa app by Jamie…
so dont hold your breath :wink:

Thanks, much appreciated anyway!

Beste lezer,

Het koppelen van laadpaal niet, Homey geeft time out.
Wat moet ik doen?

Gr Heiko

First of all, welcome to the Homey Community!

To make sure you are aware of the forum rules, please read the Welcome to the forum post here.

If you could please keep the conversation in English as much as possible, then more people will be able to participate and help you. If you would rather not or can’t communicate in English then please check out Non-English boards at


so you experience a timeout during the pairing. Can you confirm that you have a private chargepoint registered to your my new motiin account and a charge card?
it must be in your chargepoint list on the my new motion web site.

Yes I have a private chargepoint from Newmotion. Also I have webacces on my new motion.
I do not understand way the time out is.

Log out from the Homey mobile app, and back in again.

I have the same problem. Adding a device does not work due to a time-out.

Perhaps some changes were made to the NewMotion site.

might be the case. But my own charge point is still responding perfectly every day to my start and stop sessions.

But I need you to confirm:
Login to my.newmotion.com
You will be send to the dashboard
You have at least one private owned charge point in the charge tab
you have at least one charge card in the charge card tab

You can see in the dashboard the history of your charging sessions

In the cars menu item you have at least one car registered

Please confirm you those all are answered with a yes :slight_smile:

If so, please create a diagnostic report after trying to add the device and receiving the timeout and send it to the developer. I will then check the log to see were the response is failing

Thanks. There is one charge point and 2 cars in the profile. The profile also contains 2 charge cards, both managed by the car lease company. The first card is expired and blocked, but it cannot be removed from the profile. Either New Motion or the lease company has to do that. Maybe this is the problem. I have send the diagnostics report with number 190a41cf-6559-4ed2-87b1-7aaadb65a59b

Thanks for your help!

the log suggests its failing on decrypting the stored account password from app storage. Can you go to the app settings and store your account again there? Than try again and send me a new report.
might be that something changed on the homey version that is breaking my encryption trick

Tried again and failed again. I cannot seem to save the password in the app settings, only when adding the device.

Report: 757097b8-0b6f-4a5a-9f4a-20e2ec036c53

sorry i haven really busy.
i will have to test the app with the new homey sdk to see if something changed on de encryption stuff