[APP][Pro] Shell Recharge - Smart charging at home for you electric vehicle

Hi All,

I am happy to launch the “Shell Recharge” (formerly my New Motion) app.
Its inspired and forked from The New Motion app . However I quickly found that the use case is completely different than the original app by Jaimie Visser. So decided to include the name change to cover the new use cases better.

This new app is aimed to include your private Shell Recharge/New Motion chargers into your home automation. So it requires you to have an active account for account.shellrecharge.com with at least a single charger registered in that account and with at least one active charge card registered.
I believe that all owners of a lolo should meet these requirements anyway. But just to be clear.

So what does it do for you?

  • Start and stop charging sessions (using your default charge card)
  • Flow integration for starting/stopping action cards
  • Flow integration for changing charger status (also when triggered by website or physical charge cards)

You can find the app in the store now:

Well I am hoping someone else will enjoy the benefits of making your car charging smart and automated. I know it was a wish of mine for over a year now. Very happy that its working with Homey.

Hi Kaoh,

Could you maybe post a direct link to your app? I cannot find it in the Homey AppStore.
Thanks in advance!

So first time using the new app store system for this. Not sure what the link should be for the app. Its officially in Test status now (replacing the previous Beta option).

So lets see if this is what they mean with the link that is available in my dev dashboard.

The new link should look something like this:
But only AFTER review by Athom ofc.

ok, so how to start that review process? This app has been converted from an approved beta app to Test. No review is listed indeed. But the only option I have is to submit it for certification.

I submitted it now but not sure how long this would take.

This is indeed the only option u have.

That will depend on Athom. Normally, when there is no holidays, it takes a few days.
When u have some pics not looking sharp enough or a changelog in the README then it takes a copple of extra days.

Hi Kaoh, Ok, thanks for submitting the app for review. Please keep us posted here on the progress/outcome of the review…

Hi Kaoh,

Do you know the endpoint to change the max ampere setting on a charger?
I know that NewMotion is able to do it remotely.


All i have is what i could snif from website to their api communication. So no public api or docs. And since there is no way to set the amp from the website i am not sure how or if this can be done.
I know they use a api maintained by a foundation behind theirs, but the foundation does not open their generic charger api to persons only to chargepoint organisations.
So cant help you out there.

It was rejected due to some changes in store policies (there is a new place for change logs) so I just created a new build (with some new features in there). Its now in test, still now way to get a link as far as I can see though :(. So I will submit this version 2.1

Hi all, the app was approved this time around and is now available from the store.

Great news!!! Thanks for your efforts! Will install this weekend to check it out.

The app itself installs without any issues, but when I try to add a chargepoint (initial setup) and it asks me for my NewMotion credentials, it gives me the message “Unexpected token F in JSON at position 0” when I click “inloggen” or “volgende”. Could you recommend a workaround for this?

You sure you installed the my new motion app? Sounds like the bug in the ‘the new motion’ app.
Can you confirm that you can use these credentials to login the the my new motion website, there is a chargepoint registered there and a chargecard setup? So can you use that site to start a charging session without any input?

Hi Kaoh,

I’ve checked again and I can confirm that I’ve installed your “My New Motion” app.
See screenshot:
Schermafbeelding 2020-01-19 om 11.01.47

I can also confirm that the credentials I am using are the same I am using to log into the official NewMotion website and I can start and stop charging sessions from their website using my account there.

Schermafbeelding 2020-01-19 om 10.52.57

How to proceed?

FWIW, “F” is the first letter of “Forbidden” (HTTP 403).

Can you try using the apps -> new motion app - > configure and provide the settings there first.
Then try adding the charge point.

1 Like

So you get the same error?
Very strange that it works for me. What i do at that moment is try to get a bearere token by posting the login form to the website. To do that i first collect the form element names from the login form. Can you open the site from your location without loggin in and send me the source it generated?

I’m not using your app, just pointing towards a possible reason for the error :slight_smile:

Hi Kaoh, I’ve tried but got the same result. I would like to add something I see briefly before I get the error message. Aftet filling in my login credentials, the app goes to “Aan het zoeken naar nieuwe apparaten” and then to the message “Unexpected token F in JSON…”. So maybe the login form isn’t the issue but the step after that?

I’ve also generated an diagnostic report in the app config section. I don’t know if you received that in your developer portal at Homey, but maybe you can use that to see what is going wrong.