[APP][Pro] Samsung SmartTV

When will this app get an update? Lost connection months ago… Have a Samsung UE65RU7455… Hope something happens soon…

Thanks for building this app. Using it for quite a while now to switch on and off a few of my Samsung TVs
However, as I recently bought a Samsung The Frame 2022, I want to get a little bit more out of this.

I can use this app to switch off the TV, however, switching on the TV doesn’t work. As a work around I can switch on the TV by triggering the “Channel Up” “then” card.
What I would really like to use is the “Set input source to” card. However, the list of input sources is empty. I have created an API token. I have removed the device and added it again. I have restarted the app.

What am I doing wrong?

@Rudi_Hendrix the app hasn’t been updated for a year so I think you have to be patient if you want help… Have tried to reach out several times but don’t get any answer…

I guess you’re right. Or I am going to use the work around and send some keys to achieve the same thing. Little bit more puzzling but that should work as well.

Any success with this. I want the TV4 Play app too…

Nope, heard nothing back

Hi. Try to send a dm to the developer. I did and got some answers that way. Just a thought :smiley:

Installed the app yesterday and it worked like a charm. Today the only thing I get is “The TV needs a secure connection. Enable ‘Secure connection’ in Adv. settings.”
I’ve double checked ip-address and it’s the correct in the app. I’v also tried toggle on and off the secure connection in settings in app. Any suggestions?

Maybe; the settings in the TV itself?

Hi! I have the Samsung freestyle gen 2 beamer. With youre app i made 2 flows:

1 when the freestyle turns on during daylight hours, the switchbot smart-curtains must close automatically.

2 when the freestyle turns off during daylight hours the switchbot smart-curtains must open automatically.

Every time i make those flows again it goes well for a couple of weeks. After that the flows are starting without doing anything. Even when there is nobody home. The curtains are opening or closing while the freestyle beamer is doing nothing.

I know for sure that the problem is because of the freestyle flows because a have made automatic noticifactions for every flow where te cutains are a part of. With all the other flows there is no problem.

Can you help me to solve this problem?


I am trying to change the source of my Samsung Screen Odyssey G6 with this Samsung SmartTV App (via the SmartThings API). But when I am adding the “Then” card “Set input source to”, I can’t find any “Input source”. The Search does not find sources when I type e.g. “HDMI”:


I think I did configure properly the Device : I have created a token and enabled the API:


The problem is IMO not with the Token, as I am the same with the SmartThings Community App and it works.

Here is the answer of the API.

{"device":{"EdgeBlendingSupport":"false","EdgeBlendingSupportGroup":"0","FrameTVSupport":"false","GamePadSupport":"true","ImeSyncedSupport":"true","Language":"en_GB","OS":"Tizen","PowerState":"on","TokenAuthSupport":"true","VoiceSupport":"true","WallScreenRatio":"-1","WallService":"false","countryCode":"BE","description":"Samsung DTV RCR","developerIP":"","developerMode":"0","duid":"uuid:6f2ac83d-ee2a-44c5-a12a-b844c443125f","firmwareVersion":"Unknown","id":"uuid:6f2ac83d-ee2a-44c5-a12a-b844c443125f","ip":"","model":"22_PONTUSML_GMT6","modelName":"LS27BG650EUXEN","name":"Right Screen Odyssey G6","networkType":"wireless","resolution":"2560x1440","smartHubAgreement":"true","ssid":"7a:da:88:f2:9f:05","type":"Samsung SmartTV","udn":"uuid:6f2ac83d-ee2a-44c5-a12a-b844c443125f","wifiMac":"B0:99:D7:BC:CF:14"},"id":"uuid:6f2ac83d-ee2a-44c5-a12a-b844c443125f","isSupport":"{\"DMP_DRM_PLAYREADY\":\"false\",\"DMP_DRM_WIDEVINE\":\"false\",\"DMP_available\":\"true\",\"EDEN_available\":\"true\",\"FrameTVSupport\":\"false\",\"ImeSyncedSupport\":\"true\",\"TokenAuthSupport\":\"true\",\"remote_available\":\"true\",\"remote_fourDirections\":\"true\",\"remote_touchPad\":\"true\",\"remote_voiceControl\":\"true\"}\n","name":"Right Screen Odyssey G6","remote":"1.0","type":"Samsung SmartTV","uri":"","version":"2.0.25"}

And the screen is properly connected to my Samsung Account. It appears in “my SmartThings” dashboard:


How could I investigate further why it’s not working ?

Are you sure the Freestyle is not turning on and off for some reason? Perhaps waking up for an update check or something like that?

I am having the same issue. So far, no luck in getting the list populated.

In screenprint iyt says ip xxx.161 in api I only see xxx.160 (?)


The freestyle beamer is 100% up to date. The flows are starting even when there is nobody home or in the middle of the night when everybody is a sleep. So it looks like that the flow is thinking that the beamer is switching on or off when its not.

-------- Oorspronkelijk bericht --------

If you open your device in Homey there normally is a tab to check when your device is turned on/off. It also says by who or what. Did you check that?

Not saying it is not up to date… just saying that it may wake up to do a check for updates


I added the logfiles as a screenshot in this email. As you can see its the homey application that is switching on and off the freestyle beamer a couple of times a day. In practice the beamer itself is not switching on or off. When i switch on the freestyle beamer itself (by myself) the route is working well. But the flow looks like to live his own life…

-------- Oorspronkelijk bericht --------

In your log there is also a time you switched it on yourself or is there only the ‘strange’ behaviour?

Some devices show a difference when starting by a flow or through the app. It looks like the Samsung-app does not make that difference (at least as I see with my own devices).

You could try to add some messaging in the flow to make certain it is the flow (if you have not done that already of course :smiley:)

Just a wild thought: your device is not frequently connecting to internet for searching updates or something?

Or to check if it is the device itself ad a flow like:

1 Like


Volgens mij zijn we beide Nederlands dus ik doe het even zo :-). Ik heb de freestyle beamer een week of 2 geleden nog gecheckt op updates, daarna is hij niet meer door mij aangezet. Er was overigens geen enkel probleem met het internet detecteerbaar, alles wat up to date en correct werken. De flow zelf krijgt op een of andere manier dus wel een aan/uit signaal door. Ik heb beide flows voorzien van een notificatie push up bericht. Hierdoor weet ik inmiddels zeker dat het deze specifieke flows zijn die het probleem veroorzaken.

-------- Oorspronkelijk bericht --------