[APP][Pro] Nilan Air

Hi all. I’ve just submitted an app with Homey support for Nilan Air.
I’m the owner of a Nilan Compact P - Air9 heat-pump.

With LAN-connected and network settings configured, I am now able with this app to get data from the device into Homey. Communication is local-network based and using ModBus communication.

The journey getting data from the Nilan Compact P has been very challenging (and time-consuming) and this topic we can share information/troubleshooting.
The CTS-7000 controller is installed in my Nilan Air. Using ModBus all kind of different documents and addressing spaces searched to get the version/state of which the app is in now.

Looking forward to your constructive feedback.
Before using this App, please make sure the LAN/network settings are working as intended.


Link to app:

Hi Kim

I’m new to the Homey universe and have a Homey Pro 2023 and also a Nilan Comfort 300LR with CTS602 and Nilan Lan Gateway.

I tried your APP to see if it could connect and get some kind of data, and it seems like I get some readings but not sure if they are correct at any point.

Is it possible that you would share your code with me, so I can try to modify it to fit the Comfort 300LR, without starting from scratch.

Best regards

Yes, no problem. Give it a try.

Hi Kim & Niels

I have the exact same config as you (Niels) have, but get a connection error. The Nilan LAN app works fine, and Homey finds the Nilan Comfort but no data coming through and in the app it says connection error. So clearly IP/Port/ID is wrong. I have identified the IP adress from the router, but that is different from the one Homey setup automatically. How did you get Data from your Comfort 300L?

Br Martin

Hi @Martin_Lippert

One thing you can test is whether the ip and port are “listening”:
Powershell: Test-NetConnection 192.168.1.xxx -port 502



Hi Kim

Thx, just tested that:

It is not, connection failed. Do you know I can I make it listening to port?

Br Martin

I have no idea. I’ve checked the menu of my product, does not seem for user to change port - so should be the port mentioned in the app.

When working with an app, it should be connected to the “internet”.

Will this app work with CTS602 controller connected via ModBus to LAN? Or i need Nilan gateway? Thanks

Hi @Tibor_Haraga

I do not have a Nilan Gateway, I was told my product is not compatible with this. So did some digging myself. There is a lot of version/controllers and also different manuels/guides.

With my device connected to lan and I visit the ip in the browser (with http://), I get the folllowing:

i quess Homey can talk with Modbus module for ESPHome uStepper Store - uStepper

What happens when you enter the IP in a browser?
Not sure I would change components in my device.

I need only help or advice, if has to sense buy this.

Hi @Tibor_Haraga

If you know the ip of your device, try and put in a browser and paste what you see:

Maybe you do not need extra hardware. Its quite expensive.

I have CTS602 controller, it is not connected to LAN. I quess, via this modbus it is possible. I wanna my unit Nilan VPL 15 integrate to Homey. Any user experiences via your Homey App?

I dont know if (or how) your device is supported. Maybe some options are available with your controller and this app - or not. No guarantees.

In my case, with my device, a lan output was located inside the cabinet and with operator passcode, I was able to set network settings to match my network and then communicate.

Also cant Connect to my compact P AiR 9. The initial connection worked but then it says “no connection” in homey. I can’t understand why it’s not working, both the compact P and homey are on the same vlan so they should see each other. When I ping the Nilan it doesn’t respond. I am connected to the nilan gateway which in return is connect to the modbus. Any help or thoughts would be much appreciated!



Hi @y3ll3r

What does happen if you enter the ip in your browser? Like this:
http://192.168.1.xxx/ ?

This happens on my device:

Please share your findings.

Did you enter the IP address in the settings of your device?


Hey Kim,
Thanks for your swift reply. When I enter the ip address there is no response and no web page like you show. I could send Nilan a support ticket perhaps? But maybe the protocol for the gateway that I have is different? Since the Nilan app is working and I can control the heat pump with it I assume that the modbus connection is working. Orrr should there be a separate modbus connection into my lan?


Hello Kim,
Thanks for your app for Nilan.
I have a Nilan Compact P XL and have trying for a long time to read the data.
Was hoping that Homey community would eventually make an app.

It works just fine!
Initially I just had to change the IP address in the display of the unit back and forth - then the connection was ok and data being read.
Very nice!

Hi Kim

Would it be possible to add a “when” for outside temperature?
Making decision on the outside temperature makes sense to me - if under 5C I would turn on my air-supply pre-heater to save electricity in the unit (it turns on the compressor to heat air, when supply temperature is below setpoint)