[App][Pro] Nefit Easy

Nefit Easy

Current app version: 4.0.1 (test)

Control your Nefit Easy thermostat with Homey!



4.0.1 (2022-11-11):

  • Fixed some issues with setting changes (especially credentials)

4.0.0 (2022-11-10):

  • SDKv3 support

3.2.0 (2018-08-21):

  • Reverted to previous XMPP client (more resource-friendly)

3.1.1/3.1.2 (2018-08-10):

  • Possible memory leak fix

3.1.0 (2018-08-01):

  • Updated core Nefit library to improve autoreconnect behaviour

3.0.3 (2018-07-04):

  • Change of ownership

3.0.2 (2018-03-31):

  • Due to changes in the Nefit/Bosch backend the devices paired with the stable (pre-SDKv2) version of this App need to be repaired. This update will mark incompatible devices for re-pairing and re-establish the connection with the Nefit/Bosch backend.

3.0.0 (2018-05-29):

  • Fixes due to changes in the Nefit/Bosch backend (which stopped the app from working).


  • Capability changes to play nice with HomeyKit. Re-adding device is required (though not enforced if the previous device entry was based on 2.0.0).


  • Update to SDKv2, add various capabilities and functionalities. Re-adding device is enforced.


The quickest way to contact me is through Slack ( @robertklep ).

1 Like

Hi Robert, My Nefit is not connecting, it gives the message below. What can i do?

Homey kon je Nefit Easy niet vinden, of dit apparaat is al toegevoegd, controleer of de gegevens hieronder kloppen en probeer het opnieuw.

Hint: mocht je de gegevens niet meer herinneren, kijk op de voorkant van je Nefit Easy handleiding.

Kind regards,

The Nefit app doesn’t handle certain characters in passwords properly (like !, % and #). Are you using one of those in your password?

Hi Robert,

it’s working now, i restared my Homey :man_facepalming:

thanks for your response.

Hi Robert,

Thanks for the Nefit app! I’ve a question about it. The only 2 actions in the Flow it has, is to set a temp and a modus. Unfortunately, the ‘modus’ setting, is not the option to set it in Clock-modus and/or Manual-modus.
Is there a way to add this?

Thanx in advance.


The “Stel de modus in” action is a bit silly, because its values are useless for the Nefit. This card is automatically added by Homey because it uses the “thermostat_mode” capability.

I’ll try and see if I can remove that card, and replace it with something more useful. I’ve added an issue here.

Hi Robert

Same issue overhere,… (Homey kon je Nefit Easy niet vinden, of dit apparaat is al toegevoegd, controleer of de gegevens hieronder kloppen en probeer het opnieuw) have no “certain” characters in my password. Nefit easy is working Ok with the Nefit easy app. Password, serienummer, and toegangscode ok,… checked this several times. Tested these values also by removing app on phone and reinstalled the app, with this I check in my optinion all entry values. Rebooted homey. Removed and reinstalled your app version 3.20. But still same error/waring and no Nefit in Homey 8-(

Version of my Homey is 1.5.13-RC 11. Please advice next steps,…

With regards

I’d have to check if there’s a maximum size for the password. If you password is longer than, say, 8 characters, could you try and see if it works if you set a password that’s at most 8 characters?

Check this tomorrow,… password now is 12… let you kown asap.

Thnx Marcel

It could be that the official Nefit app (iOS/Android) will truncate a password to 10 characters, so a quick test could be to see if the Homey app works if you just use the first 10 characters of your password.

If that doesn’t solve the problem, testing with a new password that’s 10 (or 8) characters max is the next step.

Tested with the first 10 characters of current password,… still not working.
Created new 10 character pasword everthing worked well.

thnx for quick response, with regards,

Thanks for testing! I’ll add a warning that passwords should be 10 characters or less.

love this app, thank you for creating it, it helps us make our system more efficient. I have one question , the outside temperature has quite significant drops every few hours. sometimes of more than 10 degrees . After a short period of time this goes back to normal, see attached chart.

The Nefit unit gets its data from the internet, so I was just wondering if this a problem with the Nefit-homey app or with the data it gets ?

My graph looks exactly the same, so I think it’s related to the service that the Easy uses to determine the outside temperature.

ok , thanks for the reply, then I’ll look at other parameters for optimisation :slight_smile:

You could consider buying a cheap temperature sensor that works outdoors.

I have a Xiaomi Aqara sensor in the backyard (shielded against the elements, of course) that works very well. As an added bonus, it also measures humidity and atmospheric pressure.

yeah , that’s a good idea, at the moment I pull this from the internet.

I am trying to understand how the nefit easy reacts on the outside temperature , because we use the ‘weather dependant’ setting, and now I am just wondering if the nefit reacts on bad data , but that’s difficult to check .

Is it possible to make the thermostat step size configurable? This way a user could change how big the changes should be using .1° or .5° steps. This option would really make your app awesome!
Thanks for the great work!

1 Like

The device and flow cards use a system UI component that only allows steps of 0.5°C, I don’t think I can change that (even if I could, the subsequent problem would be that you can’t dynamically change such a setting: it has to be set during device pairing, so it won’t work for existing devices and once you have chosen a value, you can’t switch it back without re-pairing the device).

Ok, I understand. What is this UI component called? I could submit this as a feature request for Homey V2.0 :wink: