[APP][Pro] Mitsubishi WF-RAC - Cooling, heating and ventilation

First of all thank you for your great job to create this app. I love it. I have a general Mitsubishi Airco question. When I use the remote to switch on the Airco and I want to use your app to switch it Off when I leave the house this does not work because the Airco does not accept another connection on this moment. When I use your app to switch it on and switch it off when I leave the house it works fine. How can I force the Airco to communicate with your app instead of the remote control.

Is there also another way to send you a donation I do not have pay-pal account

With best regards

Erik

@Erik_H did you buy recently the WF-RAC module or do you have it for a while? Does the problem occur since you have been using this app?

I just tested it on my airco module (which I bought when this app was released :clap:) and I can control It from both sides, so when I put it on with the remote a second later I see this in the app. ofcourse when you set it off with the app the remote doesn’t get off because its only send out IR and no signal returns

Hi Erik,

Do you by any chance mean the “Smart-M-Air” instead of the “remote” here?

I will send you a PM with more information about a donation, which I greatly appreciate! :pray:

– Edwin

No I Mean the remote controller from the airco. if i switch the airco on by IR remote. I can not switch it off using your app.

Erik hoving

I tested a little more today. If I wait a little longer it works. I will test some more but for now I have no issues.
Erik

1 Like

Great app! I was hoping there was support for my Mitsubishi A/C. The problem with the (horrible) Smart M-Air app is that I cannot login (username and password not correct, but I quadruple checked) from any Apple device (Android works fine, but I don’t use that). So I need to use this app to control it.

Some questions and things…

  1. So the interface is always coloured? Blue when the temperature is above my setting and orange if it is under? It’s a bit distracting, because the color also shows when the device is OFF.

  2. When the A/C is set to heating, and the measured temperature is higher than the set temperature, the screen turns blue as if it was cooling, … but the mode is still heat. How does this work?

  3. Nothing to do with the app, but my A/C measures a room temperature of 23.2 ° while other sensors measure 17.2 ° (floor level) and 18.3 ° (face level). Is there any trick to easily adjust this? It’s a bit annoying then 20 ° is the temperature setting in the whole house the A/C thinks it needs to cool down…

  4. I notice a slight delay in the communication of the devices. Could that be the app? I saw something of the WF-RAC along the way, but my router is now showing two Broadlink RM Mini 3 (which I do not have, as far as I know). The A/C’s are also pushed through HomeKit with HomeKitty from @robertklep, but that doesn’t work.

Great app! I was hoping there was support for my Mitsubishi A/C. The problem with the (horrible) Smart M-Air app is that I cannot login (username and password not correct, but I quadruple checked) from any Apple device (Android works fine, but I don’t use that). So I need to use this app to control it.

Some questions and things…

  1. So the interface is always coloured? Blue when the temperature is above my setting and orange if it is under? It’s a bit distracting, because the color also shows when the device is OFF.

  2. When the A/C is set to heating, and the measured temperature is higher than the set temperature, the screen turns blue as if it was cooling, … but the mode is still heat. How does this work?

  3. Nothing to do with the app, but my A/C measures a room temperature of 23.2 ° while other sensors measure 17.2 ° (floor level) and 18.3 ° (face level). Is there any trick to easily adjust this? It’s a bit annoying then 20 ° is the temperature setting in the whole house the A/C thinks it needs to cool down…

  4. I notice a slight delay in the communication of the devices. Could that be the app? I saw something of the WF-RAC along the way, but my router is now showing two Broadlink RM Mini 3 (which I do not have, as far as I know). The A/C’s are also pushed through HomeKit with HomeKitty from @robertklep, but that doesn’t work.

Sounds like local networking issues.

It’s not that. Everything, both WiFi and HomeKit is working fine.

Other than two Broadlink RM Mini’s showing in your router, which seems abnormal.

Yeah, it uses the default thermostat UI component that is provided by Athom. An airco works in a slightly different way as a normal thermostat (they can’t cool), but I cannot control the colours unfortunately.

I have the same issue. I guess the temperature sensor on the devices just aren’t as good…

There is a 1 second delay beween every message that is sent to the device, else the device will start trippin’.

– Edwin

That may be abnormal. But probably unrelated to ‘network issues’ as the cause for everything.

Thanks for the reply.

Too bad. Athoms interface (components) aren’t always logical.

Hmm. The device is hot from itself :joy: I should look into logic / math corrections then?! Or how are you fixing this??

Check. A second seems long these days where everything seems instant.

I will receive my Mitsubishi AC within a few weeks. I was wondering if this app also measures the power usage? Like current wattage and/or total Kwh

No, it does not.

Concerning Temperatures: it obviously requires a translation table (from read values to temperatures).

I did some PHP script to read out all current settings, and also to change the settings (after some Internet research and own reverse engineering).

Can gladly provide it - if someone can need it.

Sample output:

LED Status WiFi Adapter:   0
Model Nr:                  0
Running:                   off
Operation Mode:            Cool
Vertical Wind Direction:   High
Air Flow:                  Auto
Preset Temperature:        26
Horizontal Wind Direction: Left / Center
3D Auto:                   off
Indoor Temperature:        25.5
Outdoor Temperature:       9
Electricity Consumption:   0

Interestingly the Electricity Consumption is provided in the returned data block (if I compare to other code that can be found at the Internet), but it always contains 0 for me (although the Smart M-Air app shows values) - no idea here …

any progress?

if necessary i want to test it?

There is a official app now

Yeah, you are posting in the app topic. :wink:

See the first post in this thread.

2 Likes

Hi,
Thanks for the great app!

Question: would it be possible to switch the airco also to Eco, Hi and/or Silent mode?

Thanks again