[APP][Pro] Magic Home LED

New app update (test: 3.3.4 ):

  • FIX: AK001-ZJ200 +
  • ADD: update magic-home library


Sorry this took some time. Had holidays and was busy on other apps on the community.
I think I found a fix after digging quite some time in the library.

Can you test if this fixes it for you?

In my search to new ledstrips i ran into this app. Looks great. Before buying some ledstrips. Will every “magic home” controller work?

I was looking to buy these, but want to be sure they work with Homey:

€ 5,90 30% Off | 5M 10M Led Strips Lights Wifi Magic Home App Controle Werk Met Alexa 12V Rgb Streep Lint tape Voor Slaapkamer Muur Decoratie 220V

Thank you!

@UA84 Yeah every Magic Home LED controller should work. As you can see in the thread some of the controllers have different behaviour.

I think the one you shared should work.

1 Like

Every 5050 strip i tried worked so far with the magic home controller, and so far every magic home controller worked with homey. Just a headsup, the image shows as if you can controll the leds individual (multicolor on 1 spool), it can not with these, so all leds will be the same color at the same time. Also there are single color (or white) leds, rgbw (so color and cool white) and rgbww, these have special leds for warm white. So depending on what you are looking for you might need to look for other adds on Aliexpress to find what you want (I always but the RGBWW). (this shop has all options https://nl.aliexpress.com/item/32826225482.html?spm=a2g0s.9042311.0.0.27424c4duRTTmn

If you do want to controll every led (not the whole strip) in different colors you should look for WS2812B, I don’t think these work with the Magic controller, but i think there are other controllers and apps here.

(oops replied to the wrong message @UA84)


Thank you for your answer and tips.

I already ordered the other one, but will keep it in mind for a next one! For now i don’t need to control every led separatly. The led will come in my game room and in my playstation mode flow, so the color will be blue most of the time :blush:.


If you like individually addressable LEDs, I would suggest WLED as controller firmware (on an ESP8266 or ESP32). Also controllable from Homey with [App] D.A.L.O.R - Digitally Addressable LEDs On Rest


I have multiple Magic Home wifi currently in Homey.

Now I purchased 2 sets of deck lights with a controller each…
Both are introduced to my Wi-Fi network with static dhcp adresses and work fine in the Magic home app

Only one of them are discovered by the homey app though

I noticed in the router that they present themselves with the same hostname, if thats relevant.
Of course they did get their own IP anyway, Mac adresses are unique

But… cant get the second one discovered…
Any ideas?


Hey @Lstrandmark ,
If you want you can send me a diagnostic report.
Then i’ll have a look if something looks wrong.

You can do that via:

More - apps - Magic Home Led - settings wheel right top - send diagnostic report


New app update (live: 3.3.4):

  • FIX: AK001-ZJ200 +
  • ADD: update magic-home library

Problem solved, one of the following;

Renamed the first of the two devices hostname in the router dhcp table (resolved name in the router).

Updated router firmware

Rebooted the router

Now Homey could find and add the second device…
All good but not sure what helped :slight_smile:

1 Like

Hey @Lstrandmark ,
Good that you found it. Only thing I could see was failing calls and trying to find the IP address.
So it had something to do with a failing IP i think.

Glad that it works now :smiley:

@martijnpoppen is there a way to switch the channels by software? My module is RGBW but my strip is RGWB…

Hey @DidierVU ,
For now only via the official Magic Home LED. Not inside Homey.

Oh really? Didn’t know this. Will it remember the setting to use with your app or will it only work through the official app? I’ll test it tonight :slight_smile:

Yes check out this post: [APP] Magic Home LED - #191 by martijnpoppen :smiley:

1 Like

@martijnpoppen Hmm strange, I don’t see the option to change the device type (AK001-ZJ200)…

Thats strange, i have 4 options (5 including Cancel), is it connected to the LAN or just the internet?!
And do you have the latest firmware?

Connected only through LAN. No “delete” function also here… My app is up2date, not sure about the device itself. I’ll try some more this evening!

Yeah thats pretty weird, I have these options on all my Magic home controllers, different types/versions. (screenshot is from a testdevice, I have about 10 in use)