[App][Pro] Homey Easy Logger

The field ‘spreadsheet-id’ is empty

You can find this in the URL of your spreadsheet between two slashes (long string of characters)

I have tried to insert it there, still get the same message.

On the video the logging is working perfectly without the ID (it seems)

Inserted some of my ID as an example, has the full ID in my flow, still get the same message though:


This works for me. The SpreadSheet-ID in this example is stored in a variable.

P.S. your spreadsheet-id looks a bit short.

Here is the full sheet-id and spreadsheet saved as a variable:

Is it possible by this error to determine whether this is regarding the app, the flowcard or the sheet?

Tried to run it without anything. I have to fill in everything except the spreadsheet-id by some reason.


The app:


What should I actually use the JSON file for other than writing the credentials in the app and store it on my computer?


The file contains:

Finding a lot of info at wiki.bwa.no, but it seems there are some screenshots/examples missing :open_mouth:

@bwa can you answer this please?

Yea, I have had some issues with my server. Working on it.

See this page, it’s not broken

It shows how you app would look like when it’s configured


1 Like

Just send a diag after you have called, I would probably see what’s wrong in the diag

It seems like my browser didn’t show some of the photos, I saw it now.

So every line has to be for themselves with colon, comma, quotation marks and the distance between?
The key there is so long that It doesn’t seem to fit in one line.

What you mean about call? Like a diagnostic report?

No, copy/paste the whole bunch including the curled brackets, that is called the ‘json’, don’t change anything in there.

1 Like

What you mean about call? Like a diagnostic report?

Yes, send a diag report

Still working on fixing the documentation

1 Like

Can I ask how you open the JSON file to get this?
I open it in Excel and when I copy/paste into the logger app, the result looks different than bwa shows.

Do you need to have a flow connected to the app somehow to make this work?
I am just testing directly with a flowcard.

I sent you a diag report now, hope you can see something from it

[EasyLoggerApp] Credentials file were invalid, could not parse the content SyntaxError: Unexpected token h in JSON at position 0

So it’s the credential json that is wrong

1 Like

Open in a text editor and copy from there, it must start with { and end with }


This helped me. The text editor opens this as a code.
When I pasted that, it now works :slight_smile:

Thanks all for the help!
I think this app can be a great tool for handling a lot of data systematically and maybe make a dashboard like Rune did.


I tested to tag my doorlock when it is “locked” and this seems to work.
But I get this little check mark at the end, why is that happening?


I use text, tag, tag

1 Like

That is your second tag, it shows True or False with this Checkmark, don’t know why.

Remark: these card always add a Date/Time column to your data, you can avoid this by adding @NoDate| in front of your data ( I use ; as delimiter, where you use | ):

You can make two flows, one with text ‘OPEN’ an one with text ‘CLOSED’
and use the one, depending on the Boolean (check-mark)

Just create a variable,and set it to ‘Yes’ or ‘No’, and use it in the logger

1 Like

I can see that Homey hasn’t been able to send any logging to the spreadsheet since yesterday.

When I manually test a card, it says there is a network request failure.


Since Homey is DHCP and it might get a new IP after restart, is this a problem?

Testet to restart the app, then it works again.
Don’t really know what was the problem that caused this.


you can send a diag and I will look at it

1 Like