[APP][Pro] Homewizard

Thanks for finding the solution @Jeroen_Tebbens. Great help :white_check_mark::ok_hand:t2:

@harmenkuijer no problem, enjoy your new homey and its potentials

Hello Jeroen,
Thanks for you homewizard app.
I have an issue, I retrieve all my temperature and meteo sensors but the polling stopped after some hours/day and now they are not refreshed for past 5 days.

Already tried to restart app, reinstall, remove then rediscover devices… Same behavior after 1 day max.

Any idea?
Thanks again & best regards
Marc

Yes, that means the Homewizard wifi connection has issues.

This is a common problem / known problem with Homewizard that it
loses its wifi link.

Powercycle Homewizard and verify if there are problems. Also be
100% it gets a static ip address from either your DHCP server or
it has hardcoded it in the homewizard config tool.

This is not related to Homey in any way.

Regards,

Jeroen

Hello,

Thanks, what is strange for me is that homewizard is reachable on both local wifi or internet trough a smartphone, so it seems connected (and it has a static IP).

Best regards

Marc

Are homey and HomeWizard on the same subnet?

Kind regards / groet,
Jeroen

Yes,

Sure. Initial discovery works fine. Adding sensors too. Collection of initial data same… Then it stop collecting.

Rebooting did not fix issue. I completely uninstall app then reinstall and discover. It worked but after some delay get same issue.

Best Regards

Marc

Sounds like your HomeWizard is under stress during all polling. Do you have other integrations active. Dominicz or HA that polls your HomeWizard?
I had one user that hammered his HomeWizard to much and it’s connection table was full. Not allowing new sessions.

Please ping your HomeWizard when it doesn’t update. If that all is fine try to access it via a browser.

Other option to troubleshoot is running the homey app in CLI debug cmd.

Sorry this problem is really local. I have two HomeWizards here and running fine.

Kind regards / groet,
Jeroen

I have exactly the same thing. Adding the HW is no problem, also the sensors too, but somehow it doesn’t collect the data anymore. Been going on for about 2 months. Before it worked perfect.

Hello some more observations for me.
I’m in latest homey pro 4 version.

After collection stop it never restart (hw fully accessible & responsive no other polling on it).

You can restart app or even homey it doe not restart.

Only way for me was to uninstall reinstall rediscover devices.

I also noticed that thermometers are probed very often only 2 or 1 time per hour while windmeter is always polled multiple time in a minute.

Is there a way to poll thermometers more often?

Also I have 464 and 868 thermometers which do not provide same api answer (type 0 and 1) can it be an issue?

“thermometers”:[

{“id”:0,“name”:“Chambre”,“code”:“15145162”,“model”:1,“lowBattery”:“no”,“version”:2.31,“te”:20.3,“hu”:48,“te+”:20.6,“te+t”:“11:06”,“te-”:19.1,“te-t”:“07:18”,“hu+”:55,“hu+t”:“12:04”,“hu-”:47,“hu-t”:“15:52”,“outside”:“no”,“favorite”:“no”},

{“id”:2,“name”:“Terrasse”,“code”:“5005763”,“model”:1,“lowBattery”:“no”,“version”:2.32,“te”:14.4,“hu”:45,“te+”:16.8,“te+t”:“15:21”,“te-”:10.0,“te-t”:“07:10”,“hu+”:57,“hu+t”:“06:45”,“hu-”:33,“hu-t”:“15:21”,“outside”:“yes”,“favorite”:“no”},

{“id”:5,“name”:“Sejour”,“channel”:3,“model”:0,“te”:21.3,“hu”:47,“te+”:21.9,“te+t”:“11:06”,“te-”:20.6,“te-t”:“07:08”,“hu+”:51,“hu+t”:“11:06”,“hu-”:45,“hu-t”:“06:51”,“outside”:“no”,“favorite”:“no”}],

Any idea on this issue I can try to follow ? (My intuition is that maybe after a collection failure the process never start again)

Thanks & best regards

Marc

Hi @Marc92120 & @Fred6

Sorry I don’t own a Homey Pro so can’t reflect your experience yet. I have two homewizard units in my network and both are fine (used for developing etc.). The Homewizard app on Homey polls every 10 seconds but the Homey app will only show this value change if it changes compared to the current value. If for example the value is static for 20c temperature you would not see this value change until the temperature it gets from Homewizard unit, only then it will change.

It is very hard for me to troubleshoot these problems you experience that the application dies and does not restart by itself. Frankly it should restart but not sure why it doesnt.

I need the console output to understand why the App stops getting this information from the Homewizard unit you guys have. So the only way is running the application in developer mode in a console. You can download the application from GIT (https://github.com/jtebbens/com.homewizard).
And follow the procedure running it via Athom CLI (see forum for how to).
Make sure you run the application rather than “install” else you would not get the CMD output during the init and comms setup upon start of the application. To resolve/understand the cause of the issue you face I need the output of the console from your end to troubleshoot.

Regards,
Jeroen

Hi Jeroen,

Is it possible u add the option to adjust the polling interval in the advanced settings? This way we can adjust individual sensor polling and reduce the load on the HomeWizard.

Grtz

Fred

Its on my todo list but lack currently the time to implement it. I hope when the whole Covid19 madness is over I got some slack to work on it.

Great! Thanks!

Hi there,
Same issue here. Long time HW user, 2 days Homey. HW adds ok, Heatlink and Thermometer add ok. Initial probing data ok. And that’s it. No new data and not able to set roomtemp. Red flash message about a time-out.
Both are on same segment and ssid.
Read comment about Domoticz. Polling interval is 15sec and I have had no performance issues accessing HW directly. But to rule it out completely I disabled HW in Domoticz, waited a while and retried to set roomtemp from Homey. Same message ‘time out after 30000ms’ . After 10min or so, neither any thermometer updates. So, I don’t think it has anything to do with Domoticz polling.

My intention/idea was to simplify by removing two layers (Domoticz & Controlicz) and keeping HW to just control the CV. But if this doesn’t work it gets more complicated with 2 captains on one ship…

I have another question. Just to make sure If I understand correctly.

I have 3 kaku switches on 15m with a few walls in between (garden/garage). My HW has been modified with external antenna’s to deal with that. I read about the Homey location considerations and planned to keep controlling these 3 with HW. However, I now notice no HW-attached kaku support in the HW-app? Controlling kaku this way is not possible?

Thanks

Hi and welcome. HW can be a pain with connection/wifi issues. I assume your domoticz is not wifi connected so hard to compare connectivity issues. I am using Unifi and had to enable Legacy support for HW.

Some people have just one SSID for HW to work on and nothing else. I know its not ideal but the HW wifi chip is a nightmare. What you can also look at is the https://homey.app/nl-nl/app/com.internet/HTTP-request-flowkaarten/ to check from Homey if the CMD’s HW API. I got a feeling your SSID / Accespoint has problems with WIfi clients talking to each other (B/G band protection).

And to answer your other question on Kaku devices. We haven’t implemented any of the Kaku devices because Homey should handle this directly. Range issues like you have modded your HW is though one. Either use that HTTP request flow app to trigger your HW as a backup.

I understand the use case for Kaku devices but doubt many still need it as more and more stop using that stuff and move to more mesh based solutions (even the new Kaku/Smartwares are dropping the 433Mhz frequency).

To prepare for Homey I changed HW’s segment/ssid because that is a config requirement. Are you saying that if I now move it back from 192.168.1.xxx to 192.168.2.xxx and to a dedicated ssid (different from Homey) my chance of succes increases?

Same network different SSID. Let say a dedicated SSID for HW only. I would avoid different subnets but if you are 100% on your internal routing you can try.

After some more thought I decided to return the Homey. The idea was to make things easier but with the heatlink and kaku distance challenge it will make things more complex.
I think there’s still a market for 433/stateless. It’s cheap and you don’t need a Rolls solution to switch lights. As usual, requirements determine the solution quality.
Thanks for your help anyway.